Elisa doesnt show/play any media files

Discussions Regarding Software

Moderator: Moderators

Elisa doesnt show/play any media files

Postby SathyaBhat » Wed Jan 07, 2009 3:58

Hi, I installed Sabayon4 r1, and I must say its great! I was trying out Elisa, it detects my media folders, I can navigate to it but it doesn't show any media filse, be it audio or video. vlc, SMPlayer can all play the files, any idea why elisa cannot show these files ?

(as a sidenote: why is elisa in Sabayon 4 v0.3.5 and the one on elisa's site 0.5-something ? )
SathyaBhat
Young Hen
 
Posts: 20
Joined: Wed Jan 07, 2009 3:55

Re: Elisa doesnt show/play any media files

Postby DHalens » Wed Jan 07, 2009 12:27

I've tried running it from a console and seems it has a few issues.... I suggest you to use xbmc instead.

Code: Select all
[email protected] ~ $ elisa
WARN  MainThread      media_manager               ene 07 12:13:53  Missing dependency Un-met dependency for daap: daap to create daap:daap_media (elisa/core/manager.py:98)
WARN  MainThread      service_manager             ene 07 12:13:54  Initializing gnome:gnome_screensaver_service failed: Component gnome_screensaver_service failed to initialize: Could not connect to the Gnome ScreenSaver: org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.ScreenSaver was not provided by any .service files. (elisa/core/manager.py:95)
WARN  MainThread      metadata_manager            ene 07 12:13:54  Creating provider gstreamer:gst_metadata_client failed. A full traceback can be found at /tmp/elisa_4fiGAH.txt (elisa/core/manager.py:103)
WARN  MainThread      media_manager               ene 07 12:13:54  Initializing fspot:fspot_media failed: Component fspot_media failed to initialize: FSpot DB not found at '/home/dhalens/.gnome2/f-spot/photos.db'. (elisa/core/manager.py:95)
WARN  MainThread      service_manager             ene 07 12:13:54  Initializing osso:osso_service failed: Component osso_service failed to initialize: hildon not running. (elisa/core/manager.py:95)
WARN  MainThread      media_manager               ene 07 12:13:54  Missing dependency Un-met dependency for flickr:flickr_media: twill to create flickr:flickr_media (elisa/core/manager.py:98)
sh: xdg-user-dirs-update: command not found
elisa: could not connect to socket
elisa: No existe el fichero o el directorio
WARN  MainThread      interface_controller        ene 07 12:13:54  Component lirc_input failed to initialize: Unable to initialize lirc! (elisa/core/interface_controller.py:326)
WARN  MainThread      comp_service_activity       ene 07 12:13:54  Plugin 'service' not found (elisa/plugins/base/activities/service_activity.py:54)
WARN  PoolThread-twisted.internet.reactor-1 egg_registry                ene 07 12:13:56  Cannot load plugins from cache:  (elisa/core/epm/egg_registry.py:147)
[]
WARN  MainThread      config                      ene 07 12:13:59  [Errno 13] Permiso denegado: u'/usr/lib64/python2.5/site-packages/elisa/plugins/raval_frontend/tango_theme/tango_theme.conf' (elisa/core/config.py:195)



The traceback from Creating provider gstreamer:gst_metadata_client:
Code: Select all
Traceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/twisted/internet/gtk2reactor.py", line 226, in simulate
    self.runUntilCurrent()
  File "/usr/lib64/python2.5/site-packages/twisted/internet/base.py", line 705, in runUntilCurrent
    call.func(*call.args, **call.kw)
  File "/usr/lib64/python2.5/site-packages/twisted/internet/task.py", line 251, in _tick
    result = iterator.next()
  File "/usr/lib64/python2.5/site-packages/elisa/core/manager.py", line 109, in load_providers_iter
    provider_name)
--- <exception caught here> ---
  File "/usr/lib64/python2.5/site-packages/twisted/internet/defer.py", line 106, in maybeDeferred
    result = f(*args, **kw)
  File "/usr/lib64/python2.5/site-packages/elisa/core/plugin_registry.py", line 546, in create_component
    res = component.initialize()
  File "/usr/lib64/python2.5/site-packages/elisa/plugins/gstreamer_plugin/gst_metadata.py", line 1391, in initialize
    dfr = self.launcher.startProcess()
  File "/usr/lib64/python2.5/site-packages/elisa/plugins/gstreamer_plugin/gst_metadata.py", line 1289, in startProcess
    protocol = self.buildProtocol(None)
  File "/usr/lib64/python2.5/site-packages/elisa/plugins/gstreamer_plugin/gst_metadata.py", line 1252, in buildProtocol
    protocol = pb.PBClientFactory.buildProtocol(self, addr)
  File "/usr/lib64/python2.5/site-packages/twisted/spread/pb.py", line 1059, in buildProtocol
    p = self.protocol(isClient=True, security=self.security)
exceptions.TypeError: __init__() got an unexpected keyword argument 'security'


Also, trying to reproduce something, outputs few like this to console:
Code: Select all
WARN  MainThread      twisted                     ene 07 12:19:34  A twisted traceback occurred. (twisted/internet/defer.py:415)

Twisted traceback:
Traceback (most recent call last):
Failure: __builtin__.type: <type 'exceptions.Exception'>
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Elisa doesnt show/play any media files

Postby joost » Wed Jan 07, 2009 13:29

elisa isn't a fully operational MediaCenter. At least, as far as i know its pretty beta. (correct me if i'm wrong ofcourse)

From now on Sabayon will ship with a different MediaCenter.

Code: Select all
equo install xbmc


Give that a try.
joost
Sagely Hen
 
Posts: 2566
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Elisa doesnt show/play any media files

Postby dunsurfin » Wed Jan 07, 2009 18:58

Also being disappointed in Elisa (nothing except "internet" seems to work) I decided to try xbmc. As soon as I run it I get the message "Cannot display this video mode. Optimum resolution 1280x1024 60HZ". Using backslash it reverts to a smaller screen but also takes half my desktop with it. Refresh desktop doesn't work and I have to Ctrl Alt Backspace to restart my session. Not a happy experience.

Sabayon 4-r1 x86_64 fresh install fully updated
Dell Dimension E521 (onboard sound turned off at BIOS)
AMD Athlon 64X2 4200+ processor
2 GB RAM 533Mhz DDR2
Nvidia Geforce 7300 LE 256MB
PCI Trust SC-5200 5.1 sound card
PCI V-Stream DVB-t DVBTV card
TSSTcorp DVD+-RW TS-H553A
Logitech S510 wireless USB Keyboard and Mouse
Broadcom BCM 4401-BO 100BASE-TX
200GB SATA hard disc
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: Elisa doesnt show/play any media files

Postby SathyaBhat » Sun Jan 25, 2009 21:26

thanks. will try xbmc
SathyaBhat
Young Hen
 
Posts: 20
Joined: Wed Jan 07, 2009 3:55

Re: Elisa doesnt show/play any media files

Postby dunsurfin » Mon Jan 26, 2009 23:59

The update of Elisa to 0.5.23 (in Entropy now) has made a big difference and I was fortunate to catch a bit of text flashing by during the equo install and, after editing my elisa.conf, all my music and graphics are seen. Here's the relevant bit in case anyone wasn't watching :)

* After first run of the box, edit elisa.conf and add some media
* locations in [xmlmenu:locaions_builder]
* e.g.
* locations = ['file://./sample_data/pictures', 'file:///media/videos']

However, my location was in my home directory .elisa-0.5/elisa_0_5_6.conf
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: Elisa doesnt show/play any media files

Postby SathyaBhat » Thu Jan 29, 2009 1:59

xbmc is also pretty darn awesome, its working pretty much perfectly
SathyaBhat
Young Hen
 
Posts: 20
Joined: Wed Jan 07, 2009 3:55

Re: Elisa doesnt show/play any media files

Postby Thev00d00 » Thu Jan 29, 2009 9:40

You need to add media to elisa on first run or it will crash. There is a big warning message at the end of the ebuild

Joost, its not beta the version we used to ship (0.3.5) was but its much nicer now.

Personally I prefer elisa
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: Elisa doesnt show/play any media files

Postby dunsurfin » Thu Jan 29, 2009 12:10

Eventually got xbmc to run but the backslash doesn't work. Does anyone know any other way of getting out of full screen mode or how to configure xbmc to start in a smaller window?

Although I would like to know how to get xbmc playing properly, I must admit that, compared to standalone players like amarok, both Elisa and xbmc are dreadfully clunky - a bit like MS mediaplayer - and I don't really see the point of them :)
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: Elisa doesnt show/play any media files

Postby Thev00d00 » Thu Jan 29, 2009 13:22

They are media centers, designed to be used from the couch, they have large simple full screen interfaces designed for tvs, and usable with a remotes.

They arent designed for normal veiwing on a pc
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Next

Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests

cron