Google Earth fonts not displayed [Solved]

Discussions Regarding Software

Moderator: Moderators

Google Earth fonts not displayed [Solved]

Postby MaxP90 » Sun Jan 04, 2009 15:11

here is what I see in google earth
Image
as you can see instead of place names there are some lines

I have this problem on both x86 and x86_64 version

any idea?
Last edited by MaxP90 on Mon Jan 05, 2009 10:08, edited 1 time in total.
MaxP90
Young Hen
 
Posts: 29
Joined: Mon Sep 22, 2008 15:03

Re: Google Earth fonts not displayed

Postby Fitzcarraldo » Sun Jan 04, 2009 21:09

I assume you have OpenGL enabled? What graphics hardware and driver are you using? It's probably those. I have exactly the same problem on an x86 installation on an older laptop with an ATI Mobility Radeon 9200 using the Radeon driver (the fglrx driver doesn't work with the current version of X Server). Some Nvidia drivers have the same problem apparently. My newer laptop has an ATI Mobility Radeon X1600 and I use the AMD/ATI fglrx driver with that and Google Earth fonts show up fine. Unfortunately it looks like you (we) will have to wait for a driver update.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Google Earth fonts not displayed

Postby MaxP90 » Sun Jan 04, 2009 21:25

Yes, OpenGL is enabled

I have an ATI Radeon x1550 with fglrx driver
MaxP90
Young Hen
 
Posts: 29
Joined: Mon Sep 22, 2008 15:03

Re: Google Earth fonts not displayed

Postby joost » Sun Jan 04, 2009 22:53

Nothing todo with any driver.

in your xorg.conf if you do not have a section files (mostly located at the top)

add it so it looks like this:

Code: Select all
Section "Files"                         
#FontPath "/usr/share/fonts/local/"
FontPath "/usr/share/fonts/misc/" 
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/TTF/"   
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/corefonts"
EndSection



Now if it doesn't work for some reason after you changed this in xorg.conf and restarted X...

Try to install the bitstream fonts as Google earth uses those fonts.

(as root)
Code: Select all
 # fc-list | grep Bitstream
joost
Sagely Hen
 
Posts: 2549
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Google Earth fonts not displayed

Postby Fitzcarraldo » Sun Jan 04, 2009 23:45

Ah ha! Adding the Files section to xorg.conf fixed it on my older laptop (radeon driver). Thanks. Question, though: Why was this section not added automatically when SL was installed to the HDD, both in my case (radeon driver) and in MaxP90's case (fglrx driver)? I've just looked at the xorg.conf on my newer laptop (fglrx driver and 3.5 install) and the section is there, so why was this not inserted for SL 4.0/4.0-r1?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Google Earth fonts not displayed

Postby joost » Sun Jan 04, 2009 23:55

Because these tasks are performed by hal nowadays.

Looks like either google earth is looking in xorg.conf for it (i think so) or we have some sort of mis configuration in hal.
Maybe its just an upstream bug.

All questions, no answers.. hail closed source.
joost
Sagely Hen
 
Posts: 2549
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Google Earth fonts not displayed

Postby MaxP90 » Mon Jan 05, 2009 10:07

thanks joost, now it works good!
MaxP90
Young Hen
 
Posts: 29
Joined: Mon Sep 22, 2008 15:03

Re: Google Earth fonts not displayed [Solved]

Postby alpensepp » Thu Feb 26, 2009 10:51

hello joost,

after troubleshooting for quite a time, I just wanted to say thank you for your hint concerning g.earth /xorg.conf.
it's people like you ... just a few words but big help for linux beginners like me.

thanks :wink:
alpensepp
Baby Hen
 
Posts: 4
Joined: Wed Feb 04, 2009 10:39


Return to Software in General

Who is online

Users browsing this forum: No registered users and 3 guests