Java support in OpenOffice

Discussions Regarding Software

Moderator: Moderators

Post Reply
Baby Hen
Posts: 2
Joined: Fri Jan 02, 2009 16:53

Java support in OpenOffice

Post by Oban » Fri Jan 02, 2009 17:04

I am using Sabayon 4 on AMD64 and OpenOffice 3.0

The options dialog/ java section does not show any runtime environment that can be selected. (Use a Java runtime environment is checked)
Java works from the command line and in browser(plugins).

When trying to add a jre, none of the folders /usr/lib/jvm/sun-jdk-, /opt/sun-jdk- or /opt/sun-jdk- are accepted. I have the same result with the installed icedtea folders.

Any suggestions?

Baby Hen
Posts: 2
Joined: Mon Jan 05, 2009 23:29

Re: Java support in OpenOffice

Post by benvdh » Mon Jan 05, 2009 23:46

I'm having the exact same problem here with sabayon 4.0 although I'm not on 64-bit.

I've already tried removing my local openoffice profile since that is where javavendors.xml file resides. But doesn't seem to work. This bug in ubuntu seems to be related to this problem: ... +bug/96875

Also when I run soffice.bin from the commandline I get the following errors when trying to select a jre through Tools > Options > Java:
(soffice:9110): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
[Java framework] Invalid value for bootstrap variable: UNO_JAVA_JFW_VENDOR_SETTINGS[Java framework] Invalid value for bootstrap variable: UNO_JAVA_JFW_VENDOR_SETTINGS
Another problem I run into is that when I try to run presenter it hangs and when I try to close it, it gives the attached output. I think it's related to the fact that there is no JRE available, although I'm not sure.



User avatar
Sagely Hen
Posts: 8094
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Java support in OpenOffice

Post by Fitzcarraldo » Tue Jan 06, 2009 0:40

Have you checked the Gentoo Forums? The last post in the following thread points to a couple of other threads with fixes. As SL is essentially Gentoo, those posts may help you.

Post Reply