ark crashing [Solved]

Discussions Regarding Software

Moderator: Moderators

ark crashing [Solved]

Postby dunsurfin » Sun Dec 28, 2008 19:38

Sabayon 4 x86-64 fresh install using KDE 3.5.10
ark crashes when opened from the menu or when right clicking on an archive and selecting extract but opens successfully from konsole.

backtrace and excerpt from xsession errors below.
Last edited by dunsurfin on Tue Jan 06, 2009 17:56, edited 1 time in total.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: ark crashing

Postby E.M.G. » Tue Dec 30, 2008 17:27

I'm getting the same thing ... I've tried re-installing ark but that didn't work ... so if you find a solution ..please post back
E.M.G.
Simple Hen
 
Posts: 80
Joined: Tue Jun 24, 2008 18:50
Location: 42.44°N 73.11°W

Re: ark crashing

Postby colejv » Wed Dec 31, 2008 19:32

Same issue, my logs look the same as those posted above

If I actually open a file from konsole (ark /path/to/file) the following warnings are shown but it works.

Code: Select all
kio (KMimeType): WARNING: mimetype not valid '' (missing entry in the file ?)
kparts: WARNING: StatusBarExtension::removeStatusBarItem. Widget not found : [KPushButton pointer (0x7c9e30) to widget CancelButton, geometry=100x30+0+0]


Sabayon 4 x86-64 KDE 3.5.10
colejv
Young Hen
 
Posts: 32
Joined: Sat Aug 04, 2007 19:30

Re: ark crashing

Postby DHalens » Thu Jan 01, 2009 1:14

Same issue here.
Also, right click on a file and "previsualize in ark" gives an error /usr/kde/3.5/lib64/kde3/libarkpart.so: undefined symbol: stat64
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: ark crashing

Postby dunsurfin » Thu Jan 01, 2009 9:11

I now have a working ark by doing:

Code: Select all
equo install ark


and then:

Code: Select all
equo remove ark-3.5.10 --nodeps


and pointing the menu to usr/kde/4.1/bin/ark

Perhaps someone more advanced can point me in the right direction for adding just that item to my path and also restoring the right click option for that entry on a compressed file in konqueror.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: ark crashing

Postby colejv » Sun Jan 04, 2009 2:56

I tried emerging ark (hoping rebuilding a dependency would help) it did not.
colejv
Young Hen
 
Posts: 32
Joined: Sat Aug 04, 2007 19:30

Ark crashes

Postby wilson.meier » Mon Jan 05, 2009 15:13

Hi,

ark is always crashing if it's started from kde context menu.

Here the traceback:

Code: Select all
[KCrash handler]
#5  0x00007fc99e585535 in raise () from /lib/libc.so.6
#6  0x00007fc99e5869e0 in abort () from /lib/libc.so.6
#7  0x00007fc9a4361687 in ?? () from /usr/kde/3.5/lib64/libkdecore.so.4
#8  0x00007fc9a4361855 in kdbgstream::flush ()
   from /usr/kde/3.5/lib64/libkdecore.so.4
#9  0x00007fc999952f48 in ?? () from /usr/kde/3.5/lib64/libkdeinit_ark.so
#10 0x00007fc999952f62 in ?? () from /usr/kde/3.5/lib64/libkdeinit_ark.so
#11 0x00007fc999952952 in ?? () from /usr/kde/3.5/lib64/libkdeinit_ark.so
#12 0x00007fc9999502f5 in ?? () from /usr/kde/3.5/lib64/libkdeinit_ark.so
#13 0x00007fc9a43bfece in KUniqueApplication::processDelayed ()
   from /usr/kde/3.5/lib64/libkdecore.so.4
#14 0x00007fc9a43bfff0 in KUniqueApplication::qt_invoke ()
   from /usr/kde/3.5/lib64/libkdecore.so.4
#15 0x00007fc9a2ee4e5c in QObject::activate_signal ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#16 0x00007fc9a31cac32 in QSignal::signal ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#17 0x00007fc9a2efd20d in QSignal::activate ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#18 0x00007fc9a2f03748 in QSingleShotTimer::event ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#19 0x00007fc9a2e8e5fd in QApplication::internalNotify ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#20 0x00007fc9a2e8f318 in QApplication::notify ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#21 0x00007fc9a435efe4 in KApplication::notify ()
   from /usr/kde/3.5/lib64/libkdecore.so.4
#22 0x00007fc9a2e84cfb in QEventLoop::activateTimers ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#23 0x00007fc9a2e45de7 in QEventLoop::processEvents ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#24 0x00007fc9a2ea2ea3 in QEventLoop::enterLoop ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#25 0x00007fc9a2ea2d52 in QEventLoop::exec ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#26 0x00007fc99994facd in kdemain () from /usr/kde/3.5/lib64/libkdeinit_ark.so
#27 0x0000000000406601 in ?? ()
#28 0x0000000000406d5f in ?? ()
#29 0x00000000004072b5 in ?? ()
#30 0x00000000004080f0 in ?? ()
#31 0x00007fc99e5724a4 in __libc_start_main () from /lib/libc.so.6
#32 0x00000000004047f9 in ?? ()
#33 0x00007fffad977318 in ?? ()
#34 0x0000000000000000 in ?? ()


Any suggestions?

Greets wilson

EDIT: Please remove this post.
Last edited by wilson.meier on Mon Jan 05, 2009 15:54, edited 1 time in total.
wilson.meier
Baby Hen
 
Posts: 8
Joined: Mon Jan 05, 2009 14:37

Re: Ark crashes if started from contextmenu

Postby MaxP90 » Mon Jan 05, 2009 15:50

a lot of people have this problem (me too)

viewtopic.php?f=59&t=15538
MaxP90
Young Hen
 
Posts: 29
Joined: Mon Sep 22, 2008 15:03

Re: ark crashing

Postby wolfden » Tue Jan 06, 2009 4:13

merged
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: ark crashing

Postby joost » Tue Jan 06, 2009 16:49

So its ark for kde 3.5.10 on sabayon x86_64 that is broken?
joost
Sagely Hen
 
Posts: 2548
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Next

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest