NFS mounting

Discussions Regarding Software

Moderator: Moderators

NFS mounting

Postby psilo357 » Tue Dec 23, 2008 2:28

I have a share on my freenas server that contains all of my music that i would like to mount, however, when i attempt to mount it I am getting an error, here is the command I am using to mount:

# mount -t nfs 192.168.1.115:/mnt/Music/Music /media/music

Which should work just fine, but everytime i run it, it takes about a minute then just outputs the following:

mount.nfs: internal error

any ideas?

EDIT: seem it is probably due to the portmap service not running, how would i go about starting this in sabayon? sorry for all the questions, am new to sabayon and somewhat new to linux. Also, if i wanted to add portmap to startup during boot, how would i do so? I am interested because i would like to mount this drive on boot every time as well, and can make the fstab entries, but would need it running of course.

EDIT2: guess im too fast to ask questions, sorry for wasting a post on the forums, but this was a great walkthrough and worked perfectly.

http://beans.seartipy.com/2006/04/13/a- ... on-gentoo/

One question though I would love answered, does sabayon use the exact same system as gentoo, so using the command

rc-update add portmap default

adds it to boot sequence? I used the command and it said added, but im not sure if sabayon uses the same setup.

thanks
psilo357
Baby Hen
 
Posts: 18
Joined: Mon Dec 22, 2008 4:15

Re: NFS mounting

Postby wolfden » Tue Dec 23, 2008 6:14

sabayon is gentoo so what works for gentoo works here
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest