Can't install Lazarus 0.9.26 & FPC 2.2.2. Not in repo?

Discussions Regarding Software

Moderator: Moderators

Can't install Lazarus 0.9.26 & FPC 2.2.2. Not in repo?

Postby calebs » Wed Dec 17, 2008 0:16

Hello all, i've trying to install lazarus 0.9.26 and fpc 2.2.2 but they are not in the equo or spritz repository, there are old versions and i need the new ones.
Tried also to download the tarball sources of the two, and installed but free pascal works but i can't make lazarus work neither compile it or build it... always asking for missing gdk libraries that can't be found.
I've readed a lot of forums but i can't find any solutions to it
Is some mirror for the sabayon or gentoo repositories where newest lazarus and fpc could be to install with equo or spritz or emerge? I need to install it on 4 or 5 computers to start a project.

Thanks for your time.
calebs
Young Hen
 
Posts: 30
Joined: Mon Aug 18, 2008 0:07

Re: Can't install Lazarus 0.9.26 & FPC 2.2.2. Not in repo?

Postby albfneto » Wed Dec 17, 2008 1:23

I dont use lazarus, but in my entropy (equo, spritz) databank, is the new version.

see:
Code: Select all
equo search lazarus
>>  @@ Searching...
>>   #1 Sabayon Linux Official Repository
>>      @@ Package: dev-lang/lazarus-0.9.26             branch: 4
>>        Category:             dev-lang
>>        Name:                 lazarus
>>        Masked:               False
>>        Available:            version: 0.9.26 ~ tag: NoTag ~ revision: 0
>>        Installed:            version: Not installed ~ tag: N/A ~ revision: N/A
>>        Slot:                 0
>>        Size:                 44.9MB
>>        Download:             packages/amd64/4/dev-lang:lazarus-0.9.26~0.tbz2
>>        Checksum:             c0b78ab4a7c3a11c308713fcffe28f20
>>        ## Dependencies:
>>        ##                    >=x11-libs/gtk+-2.0
>>        ##                    ~dev-lang/fpc-2.2.2
>>        ##                    net-misc/rsync
>>        ## Conflicts:
>>        ##                    =gnome-base/librsvg-2.16.1
>>        Homepage:             http://www.lazarus.freepascal.org/
>>        Description:          Lazarus IDE is a feature rich visual
>>                              programming environment emulating
>>                              Delphi.                       


You Sabayon was recently installed? Do you updated it?
anothet alternative is to use Portage, as in gentoo, command emerge,or portato as graphical installer...

For updating Entropy ( equo, spritz)

# equo install equo --ask
equo update
equo world
equo update

For updating Portage:

# emerge --sync && emerge -e world
# emerge -a -v portage portato

after try to install your packs.
But in less than one month, near Chrstimas Date, e new Sabayon version 4.0, will appear, and you may found the new packs, including the new Lazarus and Pascal compiler...
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Can't install Lazarus 0.9.26 & FPC 2.2.2. Not in repo?

Postby calebs » Wed Dec 17, 2008 15:03

Thanks for your reply.
I've updated the equo repositories several times but all i get is lazarus 9.24.
Tried with emerge and updated, and shows 9.26 there, so i guess i'm using wrong repository for equo?
I'll try to install lazarus from emerge, but i haven't used much... i'll keep updated
calebs
Young Hen
 
Posts: 30
Joined: Mon Aug 18, 2008 0:07

Re: Can't install Lazarus 0.9.26 & FPC 2.2.2. Not in repo?

Postby micia » Wed Dec 17, 2008 19:11

The latest version of Lazarus is in the branch 4 repositories,
in the 3.5 branch there is only the old version.

If you are able to wait until the Sabayon 4 release, which is scheduled
someday around Christmas, you will be able to update your Sabayon, Lazarus,
and many other packages, directly from entropy.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Can't install Lazarus 0.9.26 & FPC 2.2.2. Not in repo?

Postby Stupot » Wed Dec 17, 2008 21:38

Also, if Lazarus 0.9.24 is working just fine for you, then getting 0.9.26 really isn't that big of a deal. I know it's a hard habit to break, but if something is working just fine for you without being the newest version, then it's not that important for you to update it, particularly when you're dealing with just a regular application (i.e. not the desktop or a dependency of a bunch of other apps).
Stupot
Sagely Hen
 
Posts: 1556
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest

cron