java is not available for sun-jdk-1.6 on i686

Discussions Regarding Software

Moderator: Moderators

java is not available for sun-jdk-1.6 on i686

Postby lorebett » Wed Oct 29, 2008 11:53

When I try to run java from the command line, I always get:

Code: Select all
* java is not available for sun-jdk-1.6 on i686
* IMPORTANT: some Java tools are not available on some VMs on some architectures


but I had set the java 6 virtual machine with

Code: Select all
java-config -S sun-jdk-1.6


where am I doing wrong?

thanks in advance
Lore
lorebett
Baby Hen
 
Posts: 11
Joined: Fri Oct 03, 2008 9:52

Re: java is not available for sun-jdk-1.6 on i686

Postby WarraWarra » Wed Oct 29, 2008 12:45

http://gentoo-portage.com/dev-java/sun-jdk .

Have you tried installing it using emerge ?

also check
gcc-config --help

The installed versions most of the time revert to i586 and this could cause a problem during install / building jdk from source / emerge .

Lastly check /etc/make.conf and note the ~x86 or x86 but even so it should be available for both stable and unstable tree's of portage.

Have you tried the same in live cd /dvd and see if it does the same ?
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: java is not available for sun-jdk-1.6 on i686

Postby lorebett » Wed Oct 29, 2008 13:54

Actually this problem raised in a brand new installation (actually I had only upgraded the packages after the installation)...

/etc/make.conf says:

Code: Select all
CFLAGS="-Os -march=i686"
CHOST="i586-pc-linux-gnu"


and

gcc-config says

Code: Select all
i586-pc-linux-gnu-4.2.3
lorebett
Baby Hen
 
Posts: 11
Joined: Fri Oct 03, 2008 9:52

Re: java is not available for sun-jdk-1.6 on i686

Postby DontPanic » Wed Oct 29, 2008 23:35

SabayonLinux inherits Gentoo's method for managing possible multiple versions of java using the 'eselect' command.

It could be that eselect isn't pointing correctly to your installed java package.

Run the commands: 'eselect java-vm list' and 'eselect java-nsplugin list', and make sure they point to a valid entry.

Post back if the results of these commands is confusing to you.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: java is not available for sun-jdk-1.6 on i686

Postby tyranny12 » Wed Nov 05, 2008 22:05

Actually I've been getting the same thing for a bit.

Eselect shows the three installed versions, and 1.4 and 1.5 work when I have them eselected. 1.6, however, generates the console error the prior user in this thread stated, and a little popup tooltop stating the same.

'Equo world' has been reinstalling java 1.6 about three times a week, no version change just a reinstall, for some unknown reason. We'll see if it continues...
tyranny12
Young Hen
 
Posts: 21
Joined: Tue Jan 08, 2008 3:17

Re: java is not available for sun-jdk-1.6 on i686

Postby lorebett » Wed Nov 05, 2008 22:56

The PC where I experienced this problem seems to be broken after an 'equo world' (I get an error from grub), so I cannot test it right now... :cry:

I'll try to repair the installation with the DVD... otherwise I'll have to do a brand new install...
lorebett
Baby Hen
 
Posts: 11
Joined: Fri Oct 03, 2008 9:52

Re: java is not available for sun-jdk-1.6 on i686

Postby albfneto » Wed Nov 05, 2008 23:17

I hvae in mind that your system is working, because you said that finished configurate java...., with commands.
yuou used equo, in theis is is not a good practice to use meerge now, but you mmay tri remove java with equo oe espritz, and then,re install Java with emerge and changing the FLAGS fot obtain support for 686 architeture...
but the message that you ask, in their first post, for me, not indicates any problem, simply informyou that some plugins of the Java are not known for your architeture, indicating fo r me that some multi architeture versions works....!
an example, my DX2 Duo Core is a AMD 64 machine, is a 686 architeture, and when i install the sun java... ( becuase i use the messenger mercury, that is sun Java dependent), i received teh same message, i dont farid for it, in only belongs for me that "parts " of the Java are multi hardware architeture, Java is still working in my comp, since without Java, Mercury not works, and is working!
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1725
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest

cron