Wine not detecting optical drives? [Solved]

Discussions Regarding Software

Moderator: Moderators

Post Reply
BlueJayofEvil
Growing Hen
Posts: 183
Joined: Tue Jun 12, 2007 3:30
Location: Minnesota, USA

Wine not detecting optical drives? [Solved]

Post by BlueJayofEvil » Tue Oct 21, 2008 4:51

Does anyone else have this problem? I installed wine using equo and ran winecfg as a normal (non-su) user. I set up everything (sound, default Windows OS, etc), but when I went to the Drives tab and clicked the Autodetect button, my optical drives were not seen. This only happens to me in Sabayon, no other distro. Is there a known workaround for this?
I'm not sure if it matters, but I'm on the 3.5 64-bit version. Any help would be appreciated.
Last edited by BlueJayofEvil on Wed Oct 22, 2008 2:00, edited 1 time in total.

WarraWarra
Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: Wine not detecting optical drives?

Post by WarraWarra » Tue Oct 21, 2008 19:56

/etc/fstab and /etc/mtab

Check the cd /dvd drive if it is listed here with correct options.

Possibly check kde's "who can do what" options if using kde.

One of these could be causing it but not sure.

BlueJayofEvil
Growing Hen
Posts: 183
Joined: Tue Jun 12, 2007 3:30
Location: Minnesota, USA

Re: Wine not detecting optical drives?

Post by BlueJayofEvil » Tue Oct 21, 2008 23:53

They're apparently not listed in fstab. Here's what mine looks like at the moment:
/dev/VolGroup00/LogVol00 / ext3 user_xattr 1 1
UUID=e395a652-ee85-41e0-96fe-d7dbda4dd53c /boot ext3 user_xattr 1 2
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0


And here's mtab:
rootfs / rootfs rw 0 0
/dev/VolGroup00/LogVol00 / ext3 rw,errors=continue,user_xattr,acl,data=ordered 0 0
proc /proc proc rw,nosuid,nodev,noexec 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec 0 0
udev /dev tmpfs rw,nosuid,size=10240k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs rw 0 0
rc-svcdir /lib/rc/init.d tmpfs rw,nosuid,nodev,noexec,size=1024k,mode=755 0 0
cachedir /lib/splash/cache tmpfs rw,size=4096k,mode=644 0 0
/dev/sdb1 /boot ext3 rw,user_xattr 0 0
usbfs /proc/bus/usb usbfs rw,noexec,nosuid,devmode=0664,devgid=85 0 0
nfsd /proc/fs/nfsd nfsd rw,noexec,nosuid,nodev 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
securityfs /sys/kernel/security securityfs rw,noexec,nosuid,nodev 0 0
debugfs /sys/kernel/debug debugfs rw,noexec,nosuid,nodev 0 0


Doesn't look like they're in either?

EDIT: I fixed it. I needed to add a few lines to fstab (one for each of my drives.) Wine now detects them.

dave_p_b
Old Dear Hen
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Re: Wine not detecting optical drives? [Solved]

Post by dave_p_b » Thu Oct 23, 2008 21:47

Hi BlueJayofEvil

Can you tell us what lines you added to your /etc/fstab file?
This problem has been bugging me ever since I started using SabayonLinux. My DVDshrink never finds the CD/DVD drives.

Cheers

Dave

WarraWarra
Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: Wine not detecting optical drives? [Solved]

Post by WarraWarra » Thu Oct 23, 2008 22:38

http://www.gentoo.org/doc/en/handbook/h ... art1_chap8

Should be a modified

Code: Select all

/dev/cdrom  /mnt/cdrom   auto    noauto,user          0 0
or
/dev/sr0  /mnt/cdrom   auto    noauto,user          0 0


Actually after new version install I check all my settings as if it is not yet set against above linked pages including localtime etc. and it seems to fix a lot of stuff or helps to avoid them as some programs still default to this settings like wine does.

Post Reply