Epiphany doesn't start

Discussions Regarding Software

Moderator: Moderators

Epiphany doesn't start

Postby Pontux » Sun Oct 12, 2008 12:19

Hi!

I love this browser and I alwaus used it when I used Ubuntu, but I can't get it working now. :/

When i command: epiphany, I get:

@localhost ~ $ epiphany
epiphany: error while loading shared libraries: libgtkembedmoz.so: cannot open shared object file: No such file or directory

I tried to reinstall and nothing. Any suggestions?
Pontux
Baby Hen
 
Posts: 5
Joined: Fri Oct 10, 2008 21:04

Re: Epiphany doesn't start

Postby nimekuwa » Sun Oct 12, 2008 20:38

me too!

I not sure of the equo command to find which package libgtkembed should be in.

Firefox 3.0.2

Thanks,
nimekuwa
Baby Hen
 
Posts: 3
Joined: Sat Oct 04, 2008 18:12

Re: Epiphany doesn't start

Postby Fitzcarraldo » Thu Oct 16, 2008 22:38

Same happens to me now I'm trying out Entropy rather than using Portage.

Apparently it's because Epiphany is looking for the library libgtkembededmoz.so in the Firefox and/or XULRunner directories. If the library is not present there, or is not the version expected by Epiphany then you get the error message.

I think Firefox 3 dropped XULRunner in favour of Webkit, in which case there is no longer an libgtkembededmoz.so in the Firefox directories, so that's probably your reason. Maybe if you were to install Firefox 2.0.0.17 you'd get Epiphany to work again. That's what happened when I moved back to Firefox 2.0.0.17 from 3.0.2/3.

The latest version of Epiphany is not in the Entropy repository yet, but that may solve your problem, because the GNOME folks who maintain Epiphany are ditching XULRunner in favour of Webkit. But, if you're an Entropy user, you'll have to wait.

Software... pah!
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Epiphany doesn't start

Postby nimekuwa » Fri Oct 17, 2008 8:29

Fitzcarraldo wrote:Same happens to me now I'm trying out Entropy rather than using Portage.

Apparently it's because Epiphany is looking for the library libgtkembededmoz.so in the Firefox and/or XULRunner directories. If the library is not present there, or is not the version expected by Epiphany then you get the error message.

I think Firefox 3 dropped XULRunner in favour of Webkit, in which case there is no longer an libgtkembededmoz.so in the Firefox directories, so that's probably your reason. Maybe if you were to install Firefox 2.0.0.17 you'd get Epiphany to work again. That's what happened when I moved back to Firefox 2.0.0.17 from 3.0.2/3.

The latest version of Epiphany is not in the Entropy repository yet, but that may solve your problem, because the GNOME folks who maintain Epiphany are ditching XULRunner in favour of Webkit. But, if you're an Entropy user, you'll have to wait.

Software... pah!


Thanks, however I don't think it is to do with WebKit as my Firefox 3.0.2 from Entropy still uses Gecko and requires xulrunner 1.9.0.2; and I believe it is Epiphany that are looking to use WebKit in a future version.
nimekuwa
Baby Hen
 
Posts: 3
Joined: Sat Oct 04, 2008 18:12

Re: Epiphany doesn't start

Postby xlnagla » Sat Oct 18, 2008 4:19

try going the portage route for epiphany (just this once) and see what it pulls in.

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44


Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests