kde-meta-9999 [Solved]

Discussions Regarding Software

Moderator: Moderators

kde-meta-9999 [Solved]

Postby nemesis » Mon Sep 29, 2008 10:41

I'm attempting to install kde4 from kdesvn-portage, and keep getting hung up on libplasma. I've searched the net for a clue to what's wrong, to no avail. I'm compiling on a fresh install of 3.5 x86. Here's the log file from the build fail.

* WARNING! This is an experimental ebuild of the kdebase-workspace KDE4 SVN tree.
* Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
* of this ebuild!

>>> Unpacking source...
* Fetching disabled since 1 hours has not passed since last update.
* Using existing repository copy at revision 865835.
* working copy: /usr/portage/distfiles/svn-src/KDE/kdebase/kdebase

* Exporting parts of working copy to /var/tmp/portage/kde-base/libplasma-9999/work/libplasma
Saving library dependendencies in libplasma:kde-svn
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/kde-base/libplasma-9999/work/libplasma ...
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/i586-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/i586-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/i586-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/i586-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Failed
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found Phonon: /usr/lib/libphonon.so
-- Found Phonon Includes: /usr/include/KDE;/usr/include
-- Found KDE 4.2 include dir: /usr/kde/svn/include
-- Found KDE 4.2 library dir: /usr/kde/svn/lib
-- Found KDE4 kconfig_compiler preprocessor: /usr/kde/svn/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Strigi 0.6.0
-- Found Strigi: /usr/lib/libstreams.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found QImageBlitz: /usr/include/qimageblitz
-- Found ZLIB: /lib/libz.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found LIBUSB: /lib/libusb.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Fontconfig: /usr/lib/libfontconfig.so
-- Found Freetype: -lfreetype -lz
-- checking for modules 'libggadget-1.0>=0.10.3;libggadget-qt-1.0>=0.10.3'
-- package 'libggadget-1.0>=0.10.3' not found
-- package 'libggadget-qt-1.0>=0.10.3' not found
-- Could NOT find Googlegadgets (missing: GOOGLEGADGETS_LIBRARIES GOOGLEGADGETS_INCLUDE_DIRS)
-- Performing Test PAM_MESSAGE_CONST
-- Performing Test PAM_MESSAGE_CONST - Success
-- Found PAM: /lib/libpam.so;/usr/lib/libdl.so
-- Looking for getspnam
-- Looking for getspnam - found
-- Looking for crypt in crypt
-- Looking for crypt in crypt - found
-- Looking for include files HAVE_CRYPT_H
-- Looking for include files HAVE_CRYPT_H - found
-- Looking for XkbLockModifiers in X11
-- Looking for XkbLockModifiers in X11 - found
-- Looking for getpassphrase
-- Looking for getpassphrase - not found
-- Looking for vsyslog
-- Looking for vsyslog - found
-- Looking for statvfs
-- Looking for statvfs - found
-- Looking for include files HAVE_LIMITS_H
-- Looking for include files HAVE_LIMITS_H - found
-- Looking for include files HAVE_SYS_TIME_H
-- Looking for include files HAVE_SYS_TIME_H - found
-- Looking for include files HAVE_STDINT_H
-- Looking for include files HAVE_STDINT_H - found
-- Looking for include files HAVE_SYS_VFS_H
-- Looking for include files HAVE_SYS_VFS_H - found
-- Looking for include files HAVE_SYS_STATVFS_H
-- Looking for include files HAVE_SYS_STATVFS_H - found
-- Looking for include files HAVE_SYS_PARAM_H
-- Looking for include files HAVE_SYS_PARAM_H - found
-- Looking for include files HAVE_SYS_MOUNT_H
-- Looking for include files HAVE_SYS_MOUNT_H - found
-- Looking for include files HAVE_SYS_STATFS_H
-- Looking for include files HAVE_SYS_STATFS_H - found
-- Looking for statfs
-- Looking for statfs - found
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of struct ucred
-- Check size of struct ucred - done
-- Looking for getpeereid
-- Looking for getpeereid - not found
-- checking for module 'xrandr>=1.2'
-- found xrandr, version 1.2.2
-- Found Soprano: /usr/lib/libsoprano.so
-- Found Soprano includes: /usr/include
-- Found Soprano Index: /usr/lib/libsopranoindex.so
-- Found Soprano Client: /usr/lib/libsopranoclient.so
-- Found Soprano Plugins: nquadparser nquadserializer sesame2backend
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:57 (MESSAGE):
Could NOT find NEPOMUK (missing: NEPOMUK_LIBRARIES NEPOMUK_INCLUDE_DIR)
Call Stack (most recent call first):
/usr/kde/svn/share/apps/cmake/modules/FindNepomuk.cmake:46 (find_package_handle_standard_args)
libs/plasma/CMakeLists.txt:2 (find_package)


-- Configuring incomplete, errors occurred!
*
* ERROR: kde-base/libplasma-9999 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3047: Called kde4overlay-meta_src_compile
* environment, line 2332: Called kde4overlay-meta_src_configure
* environment, line 2338: Called kde4overlay-base_src_configure
* environment, line 2077: Called cmake-utils_src_configureout
* environment, line 748: Called die
* The specific snippet of code:
* cmake ${cmakeargs} "${S}" || die "Cmake failed";
* The die message:
* Cmake failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/lib/entropy/logs/kde-base:libplasma-9999:20080929-095221.log'.
* The ebuild environment file is located at '/var/tmp/portage/kde-base/libplasma-9999/temp/environment'.
* This ebuild used the following eclasses from overlays:
* /usr/portage/local/layman/kdesvn-portage/eclass/kde4svn-meta.eclass
* /usr/portage/local/layman/kdesvn-portage/eclass/kde4svn.eclass
* /usr/portage/local/layman/kdesvn-portage/eclass/kde4overlay-meta.eclass
* /usr/portage/local/layman/kdesvn-portage/eclass/kde4overlay-functions.eclass
* /usr/portage/local/layman/kdesvn-portage/eclass/kde4overlay-base.eclass
*

I've installed nepomuk by itself, and still get the same error. Any help would be appreciated.

Thanx,
Raunie

edit: Solution: Go figure, I usually end up messing around with things and figure it out before I can get a response. emerging nepomuk-kde (after unmasking it) did the trick. I also found this useful information in gentoo bugs that helped me once in the past...http://bugs.gentoo.org/show_bug.cgi?id=233696
nemesis
Simple Hen
 
Posts: 69
Joined: Sun Feb 04, 2007 0:19
Location: Grovetown, GA

Re: kde-meta-9999 [Solved]

Postby wolfden » Wed Oct 01, 2008 4:34

Edited thread titled to [Solved] as per viewtopic.php?f=57&t=1730
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests

cron