SIGSEGV on OpenOffice application exit

Discussions Regarding Software

Moderator: Moderators

SIGSEGV on OpenOffice application exit

Postby thenthenio » Tue Sep 23, 2008 15:02

When I exit from any OpenOffice application it causes signal 11 (SIGSEGV).
If I run it from a console shell i get (once I close the application):
$ oocalc
QMultiInputContext::changeInputMethod(): index=0, slave=xim
$ KCrash: Application 'soffice.bin' crashing...
XIO: fatal IO error 9 (Descrittore di file non valido) on X server ":0.0"
after 122 requests (122 known processed) with 0 events remaining.

This happens on both SL 3.5 x86_64 machines i use (a desktop PC and a protable PC).
Everithig works fine, only at exit there is this problem.

Bye.
Mauro
thenthenio
Old Dear Hen
 
Posts: 522
Joined: Thu Mar 01, 2007 23:11
Location: Melegnano (MI) Italy

Re: SIGSEGV on OpenOffice application exit

Postby dunsurfin » Tue Sep 23, 2008 17:06

Same here. I just live with it as the crash only happens after OO has closed - there are many posts in other forums about the crashes happening on start up or during operation.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: SIGSEGV on OpenOffice application exit

Postby sjieke » Tue Sep 23, 2008 17:15

I have the exact same error... A solution, cause or direction where to look would be appreciated.
I also run the 64bit dvd version
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: SIGSEGV on OpenOffice application exit

Postby Fitzcarraldo » Thu Oct 23, 2008 23:26

Now that I'm trying out Entropy/Equo/Spritz I'm seeing this problem too on my x86_64 installation and openoffice-2.4.1 from Entropy. It's a pain as the error window pops up at the office every time I close any of the OOo applications, which is frequently as I'm using OOo Writer, Calc and Impress a lot.

It didn't happen to me with the openoffice-bin-2.4.1 and the openoffice-bin-3.0.0 merged from Portage.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: SIGSEGV on OpenOffice application exit

Postby sjieke » Fri Oct 24, 2008 8:04

Can we conclude that the problem is only with the openoffice entropy version, or could it be some other library used by openoffice that is causing this?

@Fitzcarraldo: the portage versions you had/have installed, were they on a 3.5 system or on an updated 3.4 system?
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: SIGSEGV on OpenOffice application exit

Postby Fitzcarraldo » Fri Oct 24, 2008 13:02

^On an updated (rolling updates) 3.4f installation, in other words, all the packages and libraries were the latest in Portage, which means several were later versions than those in the Entropy repository.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: SIGSEGV on OpenOffice application exit

Postby sjieke » Mon Oct 27, 2008 8:53

Fitzcarraldo,

did you already tried installing openoffice using portage instead of equo in your 3.5 install? I would try it myself but the problem occures on my development machine, and I can't affort to break something... On my other box I don't have the problem, but there I selected as little as possible during installation and only XFCE (it is an old machine with not much processing power). Afterwarts I installed openoffice using equo, but I don't have the crash there...
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: SIGSEGV on OpenOffice application exit

Postby Fitzcarraldo » Mon Oct 27, 2008 11:48

No, I have not tried to install it using Portage rather than Entropy; I also cannot afford to break anything on my laptop as I'm travelling on business most of the time at the moment. I could boot into Windows XP if installing from Portage were to trash OOo and/or SL but I prefer to keep Linux functioning if possible. As soon as SL 4.0 is released I will be reverting to Portage, as Entropy -- good as it is -- does not have all the latest versions and gives me less flexibility than I'm used to. Until then, unless someone finds a solution to this bug or a bug-free 3.0.0 is added to the Entropy repository, I'll put up with the pop-up error message.

Is your other box an x86_64 machine, or an x86 machine? From what I've read on the Web this crash on exit only seems to occur on 64-bit versions. Apparently the Ubuntu folks have fixed it already.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: SIGSEGV on OpenOffice application exit

Postby sjieke » Mon Oct 27, 2008 12:45

My other box is a x86 machine, so that probably explains why it doesn't crash there.
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: SIGSEGV on OpenOffice application exit

Postby palemoon » Mon Dec 15, 2008 5:02

Hey did anyone figure this out yet?

I just did a clean install of SL 3.5.1 x86_64 and have the same problem.
palemoon
Baby Hen
 
Posts: 3
Joined: Mon Dec 15, 2008 3:20
Location: USA

Next

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest