Executing (Dolphin, Kate, Kwrite) as root is (im)possible.

Discussions Regarding Software

Moderator: Moderators

Post Reply
gentmixer
Simple Hen
Posts: 60
Joined: Wed Jan 17, 2018 17:21

Executing (Dolphin, Kate, Kwrite) as root is (im)possible.

Post by gentmixer » Mon Jan 22, 2018 1:51

After Martin Graesslin's decision (I will not comment, look at the threads on Opensuse or Manjaro forums), executing these apps (versions 17+) as root is impossible... Really? There are some workarounds...
1) Compile your own apps with a patch (patches exist, read: https://forums.gentoo.org/viewtopic-t-1 ... rt-25.html), (this patch changes few lines in"/src/main.cpp" inside the sources).
2) Rebuild your packages in the Gentoo way with the same patch. It is complicated a bit and requires reworking ebuilds and patches after every versions update.
3) Save the binaries from the old (16.*) version and overwrite files from new versions with the older. It will work at this moment because the same QT5 version in Sabayon.
4) Look at OpenSuse Tumbleweed or Leap editions repositories https://software.opensuse.org/package/ managed by "wolfi"... Many thanks, Wolfi!
You will find there some prepatched binaries. The same problem: eventually different versions QT5, but you must try. The 17.12.0 version is working in Sabayon at this moment (compiled with the same QT5 version). You would edit the versioning inside the package but it is rather difficulty...
So: after every update overwrite the files inside Sabayon with unpacked files from Tumbleweed or Leap...
For kate amd kwrite in /usr/bin/ only, for dolphin in /usr/bin and /usr/lib64...
Install Nemo (for example) just in the case.
5) The last chance: buy for Mr. Graesslin ticket to the Mars...
I know, there are a security objections... So: don't use your browser or mail client when you have opened dolphin, kate, kwrite as root (gksu, kdesu,sudo). Close these immediately after working over system, etc. ...
Last edited by gentmixer on Wed Mar 07, 2018 22:36, edited 6 times in total.

User avatar
sabayonino
Sagely Hen
Posts: 3290
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Executing (Dolphin, Kate, Kwrite) as root is (im)possibl

Post by sabayonino » Mon Jan 22, 2018 17:38

At your risk , edit the file :

Code: Select all

/etc/entropy/client.conf
and set

ignore-spm-downgrades = disable

to

ignore-spm-downgrades = enable

after every "emerge" command , run

Code: Select all

# equo rescue spmsync
and all files you've merged will never overwritten

Feel free to broke your system :mrgreen:

Sabayon(devs and community) doesn't support this.
Entropy is the main package-manager
Gentoo way is allowed but not for all users and for a small things

but please
You don't suggest to sabayon users these methodologies if they don't understand how portage works
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

gentmixer
Simple Hen
Posts: 60
Joined: Wed Jan 17, 2018 17:21

Re: Executing (Dolphin, Kate, Kwrite) as root is (im)possibl

Post by gentmixer » Mon Jan 22, 2018 18:09

I want to keep packages from Sabayon but sometimes a bit different (if of course these exist and work without flaws)... and of course as an exception rather, not rule. The concept of integrity is disputable... These packages don't collide with the systemic structure of Sabayon, come from KDE (in all cases: compiled in Gentoo, precompiled in Sabayon or in SUSE). I don't change structure of Sabayon tools too... because Portage and Entropy work independently in this case. Simply: the REAL files are replaced, but without changing the systemic tools... So: no mix Portage and Entropy (no "ignore-spm-downgrades" changing value too and no danger to the system because old packages)... and I want to use the newest versions... and I have compiled and patched some packages.
Thank you, Sabayonino. I will take care.
No comment.

gentmixer
Simple Hen
Posts: 60
Joined: Wed Jan 17, 2018 17:21

Re: Executing (Dolphin, Kate, Kwrite) as root is (im)possible.

Post by gentmixer » Tue Jul 31, 2018 22:43

There is at this moment (after long dispute between KDE developers) a partial solution...
Read the history of this dispute and main arguments:
https://phabricator.kde.org/D12732
Finally executing Dolphin as root is accepted but after login as root only. There is a new ebuild in Portage (18.04.3-r1) so emerge it and enjoy anew this old feature ...
Not my problem. I have been using a reworked (patched) ebuilds for emerging dolphin (kate and kwrite also) since 17.12.3 version...
Read also:
https://blog.martin-graesslin.com/blog/ ... 7-edition/

Post Reply