Amuleadu don't start, again. [Solved]

Discussions Regarding Software

Moderator: Moderators

Re: Amuleadu don't start, again.

Postby albfneto » Wed Jul 02, 2014 22:50

He said that the system is in initial condition...

also, im my house, my system with amuleadu, it only works after the library is installed in their 2.24 version, with Portage,

without this, the messages that i received was identical of the messages that Burno received. Binutils version 2.23 not works.

simply Installing the 2.24 version of binutils and also install amuleadu . Sabayonino, may be my English!

Seems thar Burno not understood. A Typical, Regular compilation of amuleadu and also of the 2.24 version of binutils,both with Portage, solve the issue.

see these messages that i posted:

viewtopic.php?f=59&t=31828&start=10#p171400
viewtopic.php?f=59&t=31828#p171340

and also my screenshot of opened amuleadu.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1725
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Amuleadu don't start, again.

Postby Burno Sauri » Thu Jul 03, 2014 18:33

After these commands:
Code: Select all
# emerge --sync
# layman -S
# layman -a sabayon
# layman -d sabayon
# layman -a sabayon
# layman -a sabayon-distro
# layman -d sabayon-distro
# layman -a sabayon-distro
# layman -S
# LINGUAS="it" emerge -av binutils amuleadu

and with "git" and "the later binutils", the situation is the same:
Code: Select all
[email protected] ~ $ amuleadu
bash: amuleadu: command not found
[email protected] ~ $

Also, I have installed amule aduwith Equo:
Code: Select all
sabayon ~ # equo install amuleadu

and this this is the well-known output:
Code: Select all
sabayon ~ # equo install amuleadu
╠  @@ calcolo delle dipendenze...
╠  ## [N] [sabayonlinux.org] net-p2p/amuleadu-2010.1|2
╠  @@ Pacchetti che richiedono di essere installati/aggiornati/retrocessi: 1
╠  @@ Pacchetti da rimuovere: 0
╠  @@ Dimensione download: 1.6MB
╠  @@ Spazio su disco liberato: 0.0b
╠  @@ Hai bisogno di almeno: 3.2MB di spazio libero
╠  ::: >>>  (1/1) 1 pacchetto
╠    ## Scaricamento: 1 pacchetto
╠    ## ( mirror #1 ) [net-p2p:amuleadu-2010.1~2.tbz2] @ http://na.mirror.garr.it
╠   ## Download aggregato: 1 elemeto
╠    # [1] na.mirror.garr.it => net-p2p:amuleadu-2010.1~2.tbz2
╠    ## Controllo firma pacchetto...
╠       : [net-p2p:amuleadu-2010.1~2.tbz2] GPG validato
╠       : [net-p2p:amuleadu-2010.1~2.tbz2] SHA1 validato
╠       : SHA256 disabilitato
╠       : SHA512 disabilitato
╠    ## ( mirror #1 ) [net-p2p:amuleadu-2010.1~2.tbz2] successo @ http://na.mirror.garr.it
╠    ##  Velocità di trasferimento aggregata: 1.3MB/secondo
╠  +++ >>>  (1/1) net-p2p/amuleadu-2010.1
╠    ## Scompattamento: net-p2p:amuleadu-2010.1~2.tbz2
╠    ## Fase pacchetto: setup
╠    ## Fase pacchetto: preinstall
╠    ## Installazione pacchetto: net-p2p/amuleadu-2010.1
╠    ## [aMule AdunanzA, IL software p2p per la comunita' fastweb]
╠    ## Aggiornamento della repository dei pacchetti installati: net-p2p/amuleadu-2010.1
╠    ## Fase pacchetto: postinstall
 * Per maggiori informazioni sullo sviluppo di aMule AdunanzA
 * e per richieste di supporto potete consultare il forum della
 * comunita': http://forum.adunanza.net
╠    ## Pulizia: net-p2p/amuleadu-2010.1
╠  @@ Installazione completata.
╠  @@ Nessun file di configurazione da aggiornare.
☛ C'è 1 libreria preservata sul sistema
╠ /usr/lib64/librpm.so.3 [librpm.so.3:2 -> app-arch/rpm-4.11.2]
sabayon ~ # exit
logout

[email protected] ~ $ amuleadu
amuleadu: error while loading shared libraries: libbfd-2.22.so: cannot open shared object file: No such file or directory
[email protected] ~ $





I thank all of you.
Burno Sauri
Simple Hen
 
Posts: 80
Joined: Sat Sep 24, 2011 18:09

Re: Amuleadu don't start, again.

Postby sabayonino » Thu Jul 03, 2014 23:30

Burno Sauri wrote:After these commands:
Code: Select all
# emerge --sync
# layman -S
# layman -a sabayon
# layman -d sabayon
# layman -a sabayon
# layman -a sabayon-distro
# layman -d sabayon-distro
# layman -a sabayon-distro
# layman -S
# LINGUAS="it" emerge -av binutils amuleadu


without "#" symbol !

# --> is root prompt (default) and means run the comands as root
$ --> is user prompt (default) and means run the comands as user

"#" is a comment symbol in the script language also.

run all commands without "#"
Image

http://www.gentoo.org/doc/en/articles/prompt-magic.xml

If you see
Code: Select all
$ nano -w myfile

"myfile" will opened/edited as user

and


Code: Select all
# nano -w myfile

"myfile" will opened/edited as root



PS : dottout overlay provide amuleadu-9999
User avatar
sabayonino
Sagely Hen
 
Posts: 2574
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Amuleadu don't start, again.

Postby sabayonino » Fri Jul 04, 2014 0:40

viewtopic.php?f=59&t=31828&p=171518#p171516
ehm ...
try
Code: Select all
$ amule

"amule" provides
Code: Select all
# amule [2xTAB]
amule     amulecmd 



or

try this :

Example : Download amuleadu.9999 in your home folder
Code: Select all
$ wget https://www.dropbox.com/s/6a58r9ewnmtud16/net-p2p%3Aamuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2

Code: Select all
# equo unmask net-p2p/amuleadu-9999

Code: Select all
# equo i net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2


Mask all amuleadu version from sabayon repository
Code: Select all
# equo mask "amuleadu::sabayon-weekly,sabayonlinux.org"

run "amule" not "amuleadu"
Code: Select all
$ amule


Image
User avatar
sabayonino
Sagely Hen
 
Posts: 2574
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Amuleadu don't start, again.

Postby albfneto » Fri Jul 04, 2014 17:07

Your package works. Im also using it,
this is more recent than the prior package.
Thanks for the compilation!

:lol: :D

Information for Sabayonino
i mantained also the binutils-2,24 version, that i previously installed with emerge, but i switched to binutils-2.23 with binutils-config, in order to amuleadu working. My GCC compiler is working good with both versions
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1725
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Amuleadu don't start, again.

Postby sabayonino » Sat Jul 05, 2014 2:52

albfneto wrote:Your package works. Im also using it,
this is more recent than the prior package.
Thanks for the compilation!

:lol: :D

Information for Sabayonino
i mantained also the binutils-2,24 version, that i previously installed with emerge, but i switched to binutils-2.23 with binutils-config, in order to amuleadu working. My GCC compiler is working good with both versions


I've compiled amuleadu-9999 with binutils-2.23
User avatar
sabayonino
Sagely Hen
 
Posts: 2574
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Amuleadu don't start, again.

Postby Burno Sauri » Sat Jul 05, 2014 10:31

The compilation with amuleadu.9999 , don't work on my pc.
I think so because I have installed the binutils-2.24 and not the 2.23 version.
Now, if I would try a very last attempt...., I can try with:
1)
Code: Select all
# emerge --sync
yes
2)and edit the file /etc/entropy/client.conf and in the line ignore spmdowngrades, change "disable" to "enable"
yes
3)
Code: Select all
# equo install git
yes
4)
Code: Select all
emerge -p binutils
emerge -av binutils
absolutely not.
5)
Code: Select all
# layman -S
# layman -a sabayon
# layman -d sabayon
# layman -a sabayon
# layman -a sabayon-distro
# layman -d sabayon-distro
# layman -a sabayon-distro
# layman -S
# LINGUAS="it" emerge -av binutils amuleadu
yes
6)
Code: Select all
# equo rescue spmsync
yes
7)
Code: Select all
$ wget https://www.dropbox.com/s/6a58r9ewnmtud16/net-p2p%3Aamuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2
# equo unmask net-p2p/amuleadu-9999
# equo i net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2
 # equo mask "amuleadu::sabayon-weekly,sabayonlinux.org"
$ amule


ok?
I thank all of you.
p.s.
If I can't install Amule Adunanza, I could sent my pc directly to your home, for a net installation.... :D
Burno Sauri
Simple Hen
 
Posts: 80
Joined: Sat Sep 24, 2011 18:09

Re: Amuleadu don't start, again.

Postby sabayonino » Sat Jul 05, 2014 12:25

Burno Sauri wrote:The compilation with amuleadu.9999 , don't work on my pc.
I think so because I have installed the binutils-2.24 and not the 2.23 version.
Now, if I would try a very last attempt...., I can try with:
1)
Code: Select all
# emerge --sync
yes
2)and edit the file /etc/entropy/client.conf and in the line ignore spmdowngrades, change "disable" to "enable"
yes
3)
Code: Select all
# equo install git
yes
4)
Code: Select all
emerge -p binutils
emerge -av binutils
absolutely not.
5)
Code: Select all
# layman -S
# layman -a sabayon
# layman -d sabayon
# layman -a sabayon
# layman -a sabayon-distro
# layman -d sabayon-distro
# layman -a sabayon-distro
# layman -S
# LINGUAS="it" emerge -av binutils amuleadu
yes
6)
Code: Select all
# equo rescue spmsync
yes
7)
Code: Select all
$ wget https://www.dropbox.com/s/6a58r9ewnmtud16/net-p2p%3Aamuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2
# equo unmask net-p2p/amuleadu-9999
# equo i net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2
 # equo mask "amuleadu::sabayon-weekly,sabayonlinux.org"
$ amule


ok?
I thank all of you.
p.s.
If I can't install Amule Adunanza, I could sent my pc directly to your home, for a net installation.... :D


no need to merge binutils-2.24 keep 2.23 (sabayon).
no need to play with overlays

Download amuleadu-9999 from my dropbox only and install with "equo" as i explained


PS : I've compiled amuleadu-9999 for 64bit version only

Do you need 32 bit package version ?
User avatar
sabayonino
Sagely Hen
 
Posts: 2574
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Amuleadu don't start, again.

Postby Burno Sauri » Sat Jul 05, 2014 13:24

Do you need 32 bit package version ?

No, I use only SO with 64 bit.

Download amuleadu-9999 from my dropbox only and install with "equo" as i explained

And so I will not use emerge and edit the file /etc/entropy/client.conf ecc.ecc.?
Burno Sauri
Simple Hen
 
Posts: 80
Joined: Sat Sep 24, 2011 18:09

Re: Amuleadu don't start, again.

Postby Burno Sauri » Sat Jul 05, 2014 16:28

Nothing:
Code: Select all
[email protected] ~ $ wget https://www.dropbox.com/s/6a58r9ewnmtud16/net-p2p%3Aamuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f%7E0.tbz2
--2014-07-05 16:24:46--  https://www.dropbox.com/s/6a58r9ewnmtud16/net-p2p%3Aamuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f%7E0.tbz2
Risoluzione di www.dropbox.com... 108.160.166.20
Connessione a www.dropbox.com|108.160.166.20|:443... connesso.
Richiesta HTTP inviata, in attesa di risposta... 302 FOUND
Posizione: https://dl.dropboxusercontent.com/content_link/Z8reRWDisbNj8kCejxRY3y5IJ5ynPSxtHhnE9eZl3ouHIX7u2Mx1MrCpaXh9NNkM [segue]
--2014-07-05 16:24:47--  https://dl.dropboxusercontent.com/content_link/Z8reRWDisbNj8kCejxRY3y5IJ5ynPSxtHhnE9eZl3ouHIX7u2Mx1MrCpaXh9NNkM
Risoluzione di dl.dropboxusercontent.com... 107.20.188.108, 23.23.91.86, 23.23.245.193, ...
Connessione a dl.dropboxusercontent.com|107.20.188.108|:443... connesso.
Richiesta HTTP inviata, in attesa di risposta... 200 OK
Lunghezza: 2563697 (2,4M) [application/octet-stream]
Salvataggio in: "net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2"

100%[======================================>] 2.563.697    933KB/s   in 2,7s   

2014-07-05 16:24:51 (933 KB/s) - "net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2" salvato [2563697/2563697]

[email protected] ~ $ su -
Password:
sabayon ~ # equo i net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2
☛  !!! Nessun accoppiamento per net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2 nelle repository.
╠    ? Quando hai scritto net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2 Intendevi(tm) uno di questi sotto?
╠     # net-libs/nativebiginteger:0
╠     # net-misc/netpipe:0
╠     # net-misc/netpipes:0
╠     # dev-python/notify-python:0
☢ Nessun pacchetto trovato.
sabayon ~ # exit
logout

[email protected] ~ $ sudo equo i net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2

Questa lezione dovrebbe essere stata impartita dall'amministratore
di sistema locale. Solitamente equivale a:

    #1) Rispettare la privacy degli altri
    #2) Pensare prima di digitare
    #3) Da grandi poteri derivano grandi responsabilità

Password:
╠  @@ calcolo delle dipendenze...
☢  @@ Dipendenze non trovate:
☛  !!! Ogni pacchetto corrispondente a net-p2p/amuleadu-9999 è mascherato.
☛     # Motivo mascheramento: mascherato completamente (per keyword?)
☛      <> atomo: net-p2p/amuleadu-9999 in net-p2p:amuleadu-9999.99059dda93a20df7536c3e5c81c777074ea3ab2f~0.tbz2
[email protected] ~ $ amule
bash: amule: command not found
[email protected] ~ $





the software is masked.
Burno Sauri
Simple Hen
 
Posts: 80
Joined: Sat Sep 24, 2011 18:09

PreviousNext

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest