Page 1 of 1

VMware workstation will not start!!

Posted: Sat Jun 03, 2017 6:35
by knosence
Hello all,

I have been trying to figure out what is going on with VMware workstation. I have installed, removed it fully, and installed it again and still nothing. What it will do it when I click on the icon, the screen will jump like it had opened it and closed it at the same time. I made sure that all of the components are installed and if anyone thinks that displaying this info would be helpful the let me know. If there is any additional information that anyone needs to help me solve this issue, please do not hesitate, I need VMware to do development!!

Thanks in advance!

-Sence

Re: VMware workstation will not start!!

Posted: Sun Jun 04, 2017 22:37
by VolvoBirkenstock
I am experiencing the same problem and I performed the equo update/upgrade process yesterday (Saturday, June 3).
I am running an AMD processor.

My "VirtualBox - About" shows version 5.1.22 r115126 (Qt5.6.1).
My kernel target is kernel-genkernel-x86_64-4.8.0-sabayon.
Xf86 Video Virtualbox 5.1.22 is installed.
Virtualbox Guest Additions 5.1.22#4.8.0 is installed.
Virtualbox Bin 5.1.22.115126 is installed.
Virtualbox Modules 5.1.22#4.8.0-sabayon in installed.

Here is what is reported on the VIrtualBox - Error popup:

Code: Select all

Result Code: 
The VM session was aborted.

NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
Interface: ISession {7844aa05-b02e-4cdd-a04f-ade4a762e6b7}
Can anyone hand me a clue?

Thank you very much in advance.

Re: VMware workstation will not start!!

Posted: Mon Jun 05, 2017 3:05
by svantoviit
VirtualBox != VMWare
VolvoBirkenstock wrote:Can anyone hand me a clue?
Yes, Google.

Both VMWAre and VirtualBox run fine for me. Knosence, have you added your user to the vmware group? If not:

Code: Select all

# gpasswd -a USER vmware
Run it as root and replace USER with your regular user.

Do you have any logs? Some error when vmware is executed from CLI?

Edit: No errors during install? Seems there are no modules for all kernels. What is your kernel version?

Re: VMware workstation will not start!!

Posted: Mon Jun 05, 2017 6:06
by VolvoBirkenstock
Thanks, svantoviit.

I previously looked at Google before posting and started looking through the many possible issues and performed numerous experiments until I ran out of time. I was hoping someone else in the Sabayon/Gentoo community had run into the problem. Apologies for my ignorance regarding VMware != VBox. I will keep trying because I need VBox capability.

Re: VMware workstation will not start!!

Posted: Mon Jun 05, 2017 8:52
by sabayonino
Hi. VMware reuired 4.5.0 kernel 'cause wanto to install 4.5.0 modules version

Code: Select all

$ sudo equo i app-emulation/vmware-workstation-12.1.0.3272444-r2 -a
Password: 
╠  @@ calcolo delle dipendenze...
╠  @@ Questi sono i pacchetti che verrebbero installati:
╠  ## [N] [sabayonlinux.org] media-libs/libpng-1.2.57|0
╠  ## [N] [sabayonlinux.org] x11-libs/libgksu-2.0.12-r2|0
╠  ## [N] [sabayonlinux.org] x11-libs/pangox-compat-0.0.2-r1|0
╠  ## [N] [sabayonlinux.org] dev-libs/libgcrypt-1.5.6-r101|0
╠  ## [N] [sabayonlinux.org] app-emulation/vmware-workstation-12.1.0.3272444-r2|0
╠  ## [N] [sabayonlinux.org] app-emulation/vmware-tools-9.9.4.3206955|0
╠  ## [N] [sabayonlinux.org] app-emulation/vmware-modules-308.1.0#4.5.0-sabayon#4.5.0-sabayon|0

VMware needs

Code: Select all

app-emulation/vmware-modules-308.1.0#4.5.0-sabayon#4.5.0-sabayon|0
but unfortnely linux-sabayon-4.5.0 is no longer mantained to SL repository

Code: Select all

$ equo s linux-sabayon -qv
sys-kernel/linux-sabayon-3.10.105
sys-kernel/linux-sabayon-3.12.73
sys-kernel/linux-sabayon-3.18.50
sys-kernel/linux-sabayon-4.1.39
sys-kernel/linux-sabayon-4.10.17
sys-kernel/linux-sabayon-4.11.3-r1
sys-kernel/linux-sabayon-4.4.67
sys-kernel/linux-sabayon-4.6.4
sys-kernel/linux-sabayon-4.7.10
sys-kernel/linux-sabayon-4.8.17
sys-kernel/linux-sabayon-4.9.27
I think this could fix filing a bug report

Re: VMware workstation will not start!!

Posted: Tue Jun 06, 2017 23:08
by svantoviit
There are module versions for some other kernels too:

Code: Select all

$ equo s -vq vmware-modules
app-emulation/vmware-modules-308.1.0#3.10.0-sabayon
app-emulation/vmware-modules-308.1.0#3.12.0-sabayon
app-emulation/vmware-modules-308.1.0#3.18.0-sabayon
app-emulation/vmware-modules-308.1.0#4.1.0-sabayon
app-emulation/vmware-modules-308.1.0#4.4.0-sabayon
app-emulation/vmware-modules-308.1.0#4.5.0-sabayon
One could just switch to a suitable kernel. I would suggest 4.4 since it's LTS and to be supported till February 2018.

Actually although I got some errors during install, VMWare runs fine on 4.9 even with the 4.5 module. But a bug report/package request is a good idea.

Knosence, why VMWare? Can't you just use another virtualisation solution like VirtualBox or KVM/QEMU ? Maybe something more lightweight as Docker or LXC would suite your needs too…

@VolvoBirkenstock: Sorry to be so harsh. Maybe you could start a separate topic and it will get proper attention. Good luck with VB.

Re: VMware workstation will not start!!

Posted: Wed Jun 07, 2017 3:31
by VolvoBirkenstock
I discovered and fixed my problem with VirtualBox.
Since I posted incorrectly to this thread, I just wanted to mention that it has been fixed.
I will post details of the fix in another thread.