virtualbox with vagrant version issue

Discussion for all VM - Installing, Software, Problems

Moderator: Moderators

Post Reply
fazzyx
Baby Hen
Posts: 10
Joined: Tue Nov 13, 2012 15:21

virtualbox with vagrant version issue

Post by fazzyx » Mon Aug 08, 2016 11:09

Hi,

I get with the weekly update the virtualbox version 5.1. This version will not work with vagrant <1.8.5
Vagrant 1.8.5 is not available atm. Now I would like to downgrade the virtualbox to 5.0.
I mask version 5.1 but it looks like that this is the only available version.
Is it not possible at all to downgrade virtualbox to 5.0?

Thanks

Paolo
Growing Hen
Posts: 104
Joined: Sun Sep 07, 2014 5:03
Location: Italy

Re: virtualbox with vagrant version issue

Post by Paolo » Mon Aug 08, 2016 12:50

Hi, first of all, you can open a bug request for vagrant 1.8.5 https://bugs.sabayon.org/enter_bug.cgi?product=Entropy

Building packages for sabayon
https://wiki.sabayon.org/index.php?titl ... yon_Devkit
https://github.com/Sabayon/devkit

fazzyx
Baby Hen
Posts: 10
Joined: Tue Nov 13, 2012 15:21

Re: virtualbox with vagrant version issue

Post by fazzyx » Wed Aug 10, 2016 8:35

Hi Paolo,

thank you for the response and the links.

A quick fix for me was to update the driver files from 1.8.5 repository
https://github.com/mitchellh/vagrant/co ... 1ecb4b69f9

Greetz

Paolo
Growing Hen
Posts: 104
Joined: Sun Sep 07, 2014 5:03
Location: Italy

Re: virtualbox with vagrant version issue

Post by Paolo » Wed Aug 10, 2016 9:35

Can you explain how to update the driver files from 1.8.5 repository ? So it will help other users, who are facing similar issue.
Thanks

fazzyx
Baby Hen
Posts: 10
Joined: Tue Nov 13, 2012 15:21

Re: virtualbox with vagrant version issue

Post by fazzyx » Wed Aug 17, 2016 14:42

I just copied the three files from
https://github.com/mitchellh/vagrant/co ... 1ecb4b69f9
to my local installation under /opt/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/...
Thats all.

Greetz

Post Reply