VirtualBox guest additions, again

Discussion for all VM - Installing, Software, Problems

Moderator: Moderators

Post Reply
Growing Hen
Posts: 116
Joined: Fri Jul 03, 2015 15:11
Location: Townsville, Australia

VirtualBox guest additions, again

Post by fusion809 » Sat Aug 29, 2015 7:59


This is rather embarrassing. My Lenovo Laptop has had hard drive issues so now I'm using a new PC and I couldn't recover the Sabayon Linux VDI file on the Lenovo Laptop. This VDI file was the one I installed VirtualBox guest additions on in this question. I have tried to do what I did last time, namely installing make, gcc, bzip2 and perl using emerge, running ./ after mounting my VirtualBox guest additions ISO to /media/VirtualBoxGuestAdditions and then finally running

Code: Select all

gpasswd -a <USER> vboxusers
and rebooting. This time, however, running ./ gave:

Code: Select all

Verifying archive integrity... All good.
Uncompressing VirtualBox 5.0.2 Guest Additions for Linux............
VirtualBox Guest Additions installer
Removing installed version 5.0.2 of VirtualBox Guest Additions...
 * Removing existing VirtualBox non-DKMS kernel modules ...               [ !! ]
Copying additional installer modules ...
add_symlink: link file /usr/lib/VBoxGuestAdditions already exists
Installing additional modules ...
 * Removing existing VirtualBox non-DKMS kernel modules ...               [ !! ]
 * Building the VirtualBox Guest Additions kernel modules ...

 * Building the main Guest Additions module ...                           [ !! ]
(Look at /var/log/vboxadd-install.log to find out what went wrong)
 * Doing non-kernel setup of the Guest Additions ...                      [ ok ]
 * Installing the Window System drivers ...

 * Installing X.Org Server 1.16 modules ...                               [ ok ]
 * Setting up the Window System to use the Guest Additions ...            [ ok ]
You may need to restart the the Window System (or just restart the guest system)
to enable the Guest Additions.

 * Installing graphics libraries and desktop services components ...      [ ok ]
my /var/log/vboxadd-install.log file is this.

Now if I ignore this error message from running the .run file and continue with the proceedure outlined earlier, upon rebooting I get the notification:
VBoxClient: the VirtualBox kernel service is not running. Exiting
And despite selecting a bidirectional clipboard in the VirtualBox settings window I do not have a bidirectional clipboard now. FYI I am using the latest version of VirtualBox (5.0.2), so I can't simply use the VirtualBox Guest Additions package in the Entropy store, as it is simply too old. I have also tried using Portage (emerge) to install VirtualBox guest additions namely by running:

Code: Select all

emerge =app-emulation/virtualbox-guest-additions-5.0.2
(as root) but this gives the error, this is my log file.

while this is the output of

Code: Select all

emerge --info '=x11-drivers/xf86-video-virtualbox-5.0.2::gentoo'
Brenton Horne
Favourite distros: Arch Linux, Fedora, openSUSE, Sabayon Linux and Ubuntu.
Usernames: Fuse809 (Wikimedia), fusion809 (RuneScape), Brenton (Sabayon Wiki) and fusion809 (Gentoo Wiki).
My Blog on Sabayon | Google+

Post Reply