VirtualBox Not Showing in Menu [Solved]

Discussion for all VM - Installing, Software, Problems

Moderator: Moderators

VirtualBox Not Showing in Menu [Solved]

Postby Sorceror » Mon Nov 04, 2013 2:44

Just recently installed Sabayon 13.04 KDE and after installing VirtualBox I can't find a launcher for it anywhere in the menus.
Last edited by Sorceror on Thu Nov 14, 2013 12:36, edited 1 time in total.
Sorceror
Young Hen
 
Posts: 22
Joined: Sat Feb 18, 2012 20:35

Re: VirtualBox Not Showing in Menu

Postby sihox » Mon Nov 04, 2013 8:56

Hi there!

First check if you are in the vboxusers group (just type 'id' in terminal).
If no you should do as root:
Code: Select all
# usermod -a -G vboxusers YOUR_USER_NAME


Taken from this little HOWTO: https://wiki.sabayon.org/index.php?title=HOWTO:_Using_Virtualbox
sihox
Young Hen
 
Posts: 22
Joined: Tue Dec 01, 2009 23:22
Location: Poland

Re: VirtualBox Not Showing in Menu

Postby Sorceror » Mon Nov 04, 2013 12:14

Apologies for my not being very terminal savvy......Not sure what I'm specifically looking for when typing 'id' and tried the command for adding my username to that group anyway and got 'command not found'. I'm completely guessing that I use 'su' to switch user to root? I entered the command after doing so and nothing happened.
Sorceror
Young Hen
 
Posts: 22
Joined: Sat Feb 18, 2012 20:35

Re: VirtualBox Not Showing in Menu

Postby sihox » Tue Nov 05, 2013 14:22

'id' just tells you in which groups you are :) You're looking for vboxusers group.

Sorceror wrote:I'm completely guessing that I use 'su' to switch user to root?

Of course :)

Sorceror wrote:I entered the command after doing so and nothing happened.

Did you used your username in the command?

You can always try to run virtualbox from terminal and see what is happening. Just run:
Code: Select all
VirtualBox
sihox
Young Hen
 
Posts: 22
Joined: Tue Dec 01, 2009 23:22
Location: Poland

Re: VirtualBox Not Showing in Menu

Postby Sorceror » Wed Nov 06, 2013 3:01

vboxusers does show as a group I'm in.

When trying to run it from the terminal this is the response I get:
WARNING: The VirtualBox kernel modules are not loaded.
Please load all the needed kernel modules by:

for m in vbox{drv,netadp,netflt}; do modprobe $m; done

You will not be able to start VMs until this problem is fixed.

Not sure how to tackle this either.
Sorceror
Young Hen
 
Posts: 22
Joined: Sat Feb 18, 2012 20:35

Re: VirtualBox Not Showing in Menu

Postby tollgate » Wed Nov 06, 2013 3:44

Try adding:

modules="vboxdrv vboxnetflt vboxnetadp"

to /etc/conf.d/modules

and reboot
tollgate
Growing Hen
 
Posts: 105
Joined: Thu May 31, 2012 3:57
Location: Jomtien, Thailand

Re: VirtualBox Not Showing in Menu

Postby linuxfluesterer » Wed Nov 06, 2013 9:52

I assume, you will boot with 'systemd'. So the last post will not really help you. You can check, you have activated 'sysvinit' or 'systemd' with the following in a console as root:
Code: Select all
eselect sysvinit list
Available init implementations:
  [1]   systemd *
  [2]   sysvinit

And in case you boot with systemd, in systemd protocol, additional modules to be loaded at boot time must be placed in
Code: Select all
/etc/modules-load.d/
insgesamt 16
drwxr-xr-x   2 0 0   59 15. Jul 09:36 .
drwxr-xr-x 152 0 0 8192 15. Jul 05:53 ..
-rw-r--r--   1 0 0   96 15. Jul 09:36 Virtualbox.conf

Here an adopted example for loading virtualbox modules. Regard, the files to be loaded must have .conf extension. In my case for Virtualbox.conf it looks like this:
Code: Select all
cat /etc/modules-load.d/Virtualbox.conf
# Modules for VirtualBox, loaded by systemd
# Stand: 15/07/2013
vboxdrv
vboxnetadp
vboxnetflt

Eventually you'll have to enable 'systemd-modules-load.service' with:
Code: Select all
 systemctl systemd-modules-load.service

and then reboot. If you could load your vbox modules manually before, then it will be done automatically now.

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 699
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: VirtualBox Not Showing in Menu

Postby tollgate » Wed Nov 06, 2013 10:01

Thanks for adding that Linuxfluesterer. Still using openrc here, but I now have complete instructions to make the change to systemd from Lxnay.
tollgate
Growing Hen
 
Posts: 105
Joined: Thu May 31, 2012 3:57
Location: Jomtien, Thailand

Re: VirtualBox Not Showing in Menu

Postby linuxfluesterer » Wed Nov 06, 2013 11:35

Exactly, I would really recommend you to save/backup your personal data and then install an actual Sabayon realease.
A daily build is a good choice also. I do always, when there is a new Kernel mainline (3.9, 3,10, 3,11) or in my case, a new KDE version (KDE 4.9, KDE 4.10, KDE 4.11). This often prevents many times occuring upgrade problems.

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 699
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: VirtualBox Not Showing in Menu

Postby Sorceror » Sun Nov 10, 2013 13:52

Ummm.....sorry, I know new starters can be aggravating but I'm struggling to understand all that code as I'm not very terminal savvy.
I typed in 'eselect sysvinit list' and got the same result as yours showed but the * was after 'sysvinit' instead of 'systemd'.
I don't know if that changes anything as far as your other instructions are concerned?
Sorceror
Young Hen
 
Posts: 22
Joined: Sat Feb 18, 2012 20:35

Next

Return to Virtual Managers

Who is online

Users browsing this forum: No registered users and 2 guests