VirtualBox modules not found though installed [Solved]

Discussion for all VM - Installing, Software, Problems

Moderator: Moderators

VirtualBox modules not found though installed [Solved]

Postby linuxfluesterer » Wed Apr 03, 2013 12:34

Hallo guys.
I've upgraded my SL KDE 64bit system 2 days ago. Today I wanted to use my also updated VirtualBox, but I got an error message, that the module 'vboxdrv' wasn't loaded to use VirtualBox properly. I was advised to
Code: Select all
/etc/init.d/vboxdrv setup
which is impossible to do in Sabayon distro, because it doesn't exist.
But in Rigo, there are 'VirtualBox Modules' for all Kernels, including my one I use, 3.8(.5).
And in Rigo I see also, that 'VirtualBox.bin 4.2.8', 'VirtualBox Guest additions 4.2.8#3.8.0' and also 'VirtualBox Modules 4.2.8#3.8.0' are installed already, but I can't load vboxdrv with
Code: Select all
modprobe vboxdrv
nor I can load 'vboxnetflt', nor 'vboxnetadp'.
I have installed Kernel 3.8 (I assume after upgrade, now it is 3.8.5).
So, I have deinstalled 'Virtualbox.bin', 'VirtualBox Guest additions' and 'VirtualBox Modules' by hand with Rigo and then reinstalled all three VirtualBox parts (bin, modules and guest additions) matching to my Kernel again.
But there is still the same problem. I can't load the VirtualBox modules manually nor automatically when booting.
I receive an error:
Code: Select all
modprobe: FATAL: Module vboxdrv not found
though with a 'locate vboxdrv' command I receive:
Code: Select all
/lib64/modules/3.8.0-sabayon/misc/vboxdrv.ko

I assume there is a mismatch. In the past, it was always complicated after an update of VirtualBox to get it run again, but finally I got it. Now the same procedure doesn't work.
Anyone has an idea, what I can do?

-Linuxfluesterer (I love KDE ...)
Last edited by linuxfluesterer on Wed Apr 03, 2013 19:15, edited 1 time in total.
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 704
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: VirtualBox modules not found though installed

Postby Ryuno-Ki » Wed Apr 03, 2013 16:52

Hm, I suggest twice:

Then we can look further ;)
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: VirtualBox modules not found though installed

Postby linuxfluesterer » Wed Apr 03, 2013 19:14

I'm not sure, what really was my problem, but as I assumed, I might have had a kernel mismatch.
Anyway, I deleted all my partition and restored my Backup from April, 1st.
After this I've repeated system upgrade.
Now I have the latest SL status with Kernel Linux-Sabayon 3.8.5 and VirtualBox with version 4.2.8 including its modules is running fine. That situation before was confusing to me.
Thank you for reply ....

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 704
Joined: Thu Sep 20, 2012 19:47
Location: Germany


Return to Virtual Managers

Who is online

Users browsing this forum: No registered users and 1 guest