Language problems again [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

msdobrescu
Old Dear Hen
Posts: 876
Joined: Sun Aug 21, 2011 8:48

Re: Language problems again

Post by msdobrescu » Sat Apr 25, 2020 17:30

I don't know, maybe the so called "working system" is wrong.
It does not work. If it worked, I would have not created this topic.
Can't really tell what is the source of the problem.

User avatar
sabayonino
Sagely Hen
Posts: 3540
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Language problems again

Post by sabayonino » Sat Apr 25, 2020 18:36

You need of "en/us" GUI parts and keep your regional settings
Is it right ?

You want to fix a "broken" system that you have a mixed GUI language . Is it right ?

so... in your "broken" localization st the LANGUAGE variable.
Keep away the working system.

Some times ago the installer had a problem to setup the language during installation.

See
https://www.gnu.org/software/gettext/ma ... iable.html

msdobrescu
Old Dear Hen
Posts: 876
Joined: Sun Aug 21, 2011 8:48

Re: Language problems again

Post by msdobrescu » Sat Apr 25, 2020 19:21

Yes and yes.
Actually, the broken system has an issue. It seems it does not set the LANGUAGE variable. Or something can't get to the scripts where it is set.
But it seems to react to the regional settings only.
The language is always according to the region set in KDE Settings.

User avatar
sabayonino
Sagely Hen
Posts: 3540
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Language problems again

Post by sabayonino » Sat Apr 25, 2020 20:27

02locale
LANGUAGE="us"


reboot

It sounds strange it doesn't work

msdobrescu
Old Dear Hen
Posts: 876
Joined: Sun Aug 21, 2011 8:48

Re: Language problems again

Post by msdobrescu » Sun Apr 26, 2020 6:40

I've said "let's do it the tricky way", so I've opened KDE Plasma settings and tried to add a language to it.
It opens the list of languages, but doesn't add anything.
I see no message in the console (I've launched with `kcmshell5 kcm_translations`.
Is there a way to log more?

msdobrescu
Old Dear Hen
Posts: 876
Joined: Sun Aug 21, 2011 8:48

Re: Language problems again

Post by msdobrescu » Sun Apr 26, 2020 6:43

First clue:

Code: Select all

kcmshell5 formats
Couldn't load plugin: "The shared library was not found."
But what library? equo libtest did not return something except:

Code: Select all

╠  ## Not matched:
╠     => /usr/lib/libgdk_pixbuf-2.0.so.0.2600.4
╠     => /usr/lib/libldap-2.4.so.2.9.1
╠     => /usr/lib/libldap_r-2.4.so.2.9.1
╠     => /usr/lib/qt4/libQt3Support.so.4.8.5
╠     => /usr/lib/qt4/libQtDBus.so.4
╠     => /usr/lib/qt4/libQtDBus.so.4.8.5
╠     => /usr/lib/qt4/libQtDeclarative.so.4
╠     => /usr/lib/qt4/libQtDeclarative.so.4.8.5
╠     => /usr/lib/qt4/libQtGui.so.4.8.5
╠     => /usr/lib/qt4/libQtNetwork.so.4.8.5
╠     => /usr/lib/qt4/libQtOpenGL.so.4
╠     => /usr/lib/qt4/libQtOpenGL.so.4.8.5
╠     => /usr/lib/qt4/libQtScript.so.4.8.5
╠     => /usr/lib/qt4/libQtScriptTools.so.4.8.5
╠     => /usr/lib/qt4/libQtSql.so.4.8.5
╠     => /usr/lib/qt4/libQtSvg.so.4
╠     => /usr/lib/qt4/libQtSvg.so.4.8.5
╠     => /usr/lib/qt4/libQtTest.so.4
╠     => /usr/lib/qt4/libQtTest.so.4.8.5
╠     => /usr/lib/qt4/libQtXml.so.4.8.5
╠     => /usr/lib/qt4/libQtXmlPatterns.so.4
╠     => /usr/lib/qt4/libQtXmlPatterns.so.4.8.5

Code: Select all

ldd /usr/lib64/qt5/plugins/kcm_formats.so 
        linux-vdso.so.1 (0x00007fffcd3e8000)
        libKF5ConfigWidgets.so.5 => /usr/lib64/libKF5ConfigWidgets.so.5 (0x00007fa7053de000)
        libKF5WidgetsAddons.so.5 => /usr/lib64/libKF5WidgetsAddons.so.5 (0x00007fa70527f000)
        libQt5Widgets.so.5 => /usr/lib64/libQt5Widgets.so.5 (0x00007fa704c0d000)
        libKF5ConfigCore.so.5 => /usr/lib64/libKF5ConfigCore.so.5 (0x00007fa704ba0000)
        libQt5Gui.so.5 => /usr/lib64/libQt5Gui.so.5 (0x00007fa704610000)
        libKF5I18n.so.5 => /usr/lib64/libKF5I18n.so.5 (0x00007fa7045be000)
        libKF5CoreAddons.so.5 => /usr/lib64/libKF5CoreAddons.so.5 (0x00007fa704512000)
        libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5 (0x00007fa703fe1000)
        libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/libstdc++.so.6 (0x00007fa703dda000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fa703c04000)
        libKF5Codecs.so.5 => /usr/lib64/libKF5Codecs.so.5 (0x00007fa703bc6000)
        libKF5ConfigGui.so.5 => /usr/lib64/libKF5ConfigGui.so.5 (0x00007fa703ba6000)
        libKF5GuiAddons.so.5 => /usr/lib64/libKF5GuiAddons.so.5 (0x00007fa703b89000)
        libKF5AuthCore.so.5 => /usr/lib64/libKF5AuthCore.so.5 (0x00007fa703b63000)
        libQt5DBus.so.5 => /usr/lib64/libQt5DBus.so.5 (0x00007fa703ad1000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fa7054d2000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fa703aae000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fa703964000)
        libGL.so.1 => /usr/lib64/opengl/nvidia/lib/libGL.so.1 (0x00007fa7036bb000)
        libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x00007fa703680000)
        libz.so.1 => /lib64/libz.so.1 (0x00007fa703666000)
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x00007fa703568000)
        libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/libgcc_s.so.1 (0x00007fa70354e000)
        libsystemd.so.0 => /lib64/libsystemd.so.0 (0x00007fa703495000)
        libdouble-conversion.so.3 => /usr/lib64/libdouble-conversion.so.3 (0x00007fa703486000)
        libicui18n.so.65 => /usr/lib64/libicui18n.so.65 (0x00007fa70319a000)
        libicuuc.so.65 => /usr/lib64/libicuuc.so.65 (0x00007fa702fbd000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fa702fb7000)
        libpcre2-16.so.0 => /usr/lib64/libpcre2-16.so.0 (0x00007fa702f35000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007fa702e11000)
        libdbus-1.so.3 => /usr/lib64/libdbus-1.so.3 (0x00007fa702dc4000)
        libGLX.so.0 => /usr/lib64/opengl/nvidia/lib/libGLX.so.0 (0x00007fa702b94000)
        libGLdispatch.so.0 => /usr/lib64/opengl/nvidia/lib/libGLdispatch.so.0 (0x00007fa7028c1000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007fa7027f4000)
        libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x00007fa7027cf000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fa7027c3000)
        liblzma.so.5 => /lib64/liblzma.so.5 (0x00007fa70279a000)
        liblz4.so.1 => /usr/lib64/liblz4.so.1 (0x00007fa702778000)
        libcap.so.2 => /lib64/libcap.so.2 (0x00007fa70276f000)
        libgcrypt.so.20 => /usr/lib64/libgcrypt.so.20 (0x00007fa702650000)
        libicudata.so.65 => /usr/lib64/libicudata.so.65 (0x00007fa700b9d000)
        libpcre.so.1 => /lib64/libpcre.so.1 (0x00007fa700b28000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007fa7009e7000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007fa7009d2000)
        libbz2.so.1 => /lib64/libbz2.so.1 (0x00007fa7009bf000)
        libgpg-error.so.0 => /usr/lib64/libgpg-error.so.0 (0x00007fa70099c000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007fa700970000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007fa70096b000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007fa700963000)
        libbsd.so.0 => /usr/lib64/libbsd.so.0 (0x00007fa700948000)
Last edited by msdobrescu on Sun Apr 26, 2020 14:28, edited 1 time in total.

User avatar
sabayonino
Sagely Hen
Posts: 3540
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Language problems again

Post by sabayonino » Sun Apr 26, 2020 12:28

Hey man .... qt4 was dropped years ago . no longer supported

Code: Select all

 which kcmshell5
/usr/bin/kcmshell5

Code: Select all

@sabayon ~/Desktop $ equo q belongs /usr/bin/kcmshell5
╠  @@ Belong Search
╠      @@ Package: kde-plasma/kde-cli-tools-5.18.3 branch: 5, [__system__] 
╠          Installed:     version: 5.18.3 ~ tag: NoTag ~ revision: 0
╠          Slot:          5
╠          Homepage:      https://cgit.kde.org/kde-cli-tools.git 
╠          Description:   Tools based on KDE Frameworks 5 
╠                         to better interact with the system 
╠          License:       GPL-2
╠   Keyword:  /usr/bin/kcmshell5
╠   Found:    1 entry

Code: Select all

LANGUAGE="us" equo q revgraph kde-plasma/kde-cli-tools
╠  @@ Reverse graphing installed package kde-plasma/kde-cli-tools...
========================================
[0]     kde-plasma/kde-cli-tools-5.18.3
[1]       kde-apps/kaccounts-integration-19.12.3
[2]         kde-misc/kio-gdrive-1.2.7
[2]         kde-frameworks/purpose-5.67.0
[3]           kde-apps/pimcommon-19.12.3
[4]             kde-apps/kdepim-runtime-19.12.3
[4]             kde-apps/knotes-19.12.3
[3]           kde-plasma/plasma-browser-integration-5.18.3
[2]         kde-apps/akonadi-19.12.3
[3]           kde-apps/akonadi-contacts-19.12.3
[4]             media-gfx/digikam-6.4.0
[3]           kde-apps/akonadi-mime-19.12.3
[3]           kde-apps/akonadi-search-19.12.3
[3]           kde-apps/libkdepim-19.12.3
[3]           kde-apps/kmailtransport-19.12.3
[3]           kde-apps/akonadi-calendar-19.12.3
[3]           kde-apps/kgpg-19.12.3
[3]           kde-apps/kalarmcal-19.12.3
[2]         kde-apps/kaccounts-providers-19.12.3
[1]       kde-apps/khelpcenter-19.12.3
[1]       kde-apps/print-manager-19.12.3
[1]       kde-plasma/kscreenlocker-5.18.3
[2]         kde-plasma/libkworkspace-5.18.3
[3]           kde-plasma/systemsettings-5.18.3
[1]       kde-plasma/kscreen-5.18.3
[1]       kde-plasma/sddm-kcm-5.18.3
[1]       kde-plasma/plasma-nm-5.18.3
[1]       kde-plasma/powerdevil-5.18.3
[1]       kde-plasma/breeze-5.18.3
[2]         kde-plasma/breeze-gtk-5.18.3
[2]         kde-plasma/plasma-integration-5.18.3
[1]       kde-plasma/kwin-5.18.3
[1]       kde-plasma/plasma-workspace-5.18.3
[2]         net-p2p/ktorrent-5.1.2-r2
[2]         kde-plasma/kdeplasma-addons-5.18.3
[1]       kde-plasma/bluedevil-5.18.3
[1]       kde-plasma/kinfocenter-5.18.3
[1]       kde-plasma/oxygen-5.18.3
[1]       kde-plasma/plasma-desktop-5.18.3
[1]       kde-plasma/khotkeys-5.18.3
[1]       kde-plasma/kde-gtk-config-5.18.3
[1]       kde-plasma/plasma-meta-5.18.3
[1]       app-office/libreoffice-6.3.4.2-r1
╠ Legend:
╠ [x] packages passed as arguments
╠ [x] packages with no further dependencies
╠ [x] packages with further dependencies (node)
╠ [x] packages already pulled in as dependency in upper levels (circularity)
========================================

msdobrescu
Old Dear Hen
Posts: 876
Joined: Sun Aug 21, 2011 8:48

Re: Language problems again

Post by msdobrescu » Sun Apr 26, 2020 14:16

Code: Select all

LANGUAGE="us"  which kcmshell5
/usr/bin/kcmshell5

Code: Select all

LANGUAGE="us" equo q belongs /usr/bin/kcmshell5
╠  @@ Belong Search
╠      @@ Package: kde-plasma/kde-cli-tools-5.18.4.1 branch: 5, [__system__] 
╠          Installed:     version: 5.18.4.1 ~ tag: NoTag ~ revision: 0
╠          Slot:          5
╠          Homepage:      https://cgit.kde.org/kde-cli-tools.git 
╠          Description:   Tools based on KDE Frameworks 5 
╠                         to better interact with the system 
╠          License:       GPL-2
╠   Keyword:  /usr/bin/kcmshell5
╠   Found:    1 entry

Code: Select all

LANGUAGE="us" equo q revgraph kde-plasma/kde-cli-tools
╠  @@ Reverse graphing installed package kde-plasma/kde-cli-tools...
========================================
[0]     kde-plasma/kde-cli-tools-5.18.4.1
[1]       kde-apps/kaccounts-integration-19.12.3
[2]         kde-apps/akonadi-19.12.3
[3]           app-text/kjots-5.0.2
[3]           kde-apps/akonadi-contacts-19.12.3
[4]             media-gfx/digikam-6.4.0
[3]           kde-apps/akonadi-mime-19.12.3
[3]           kde-apps/akonadi-search-19.12.3
[3]           kde-apps/libkdepim-19.12.3
[4]             kde-apps/akregator-19.12.3
[4]             kde-apps/libksieve-19.12.3
[3]           kde-apps/pimcommon-19.12.3
[4]             kde-apps/libgravatar-19.12.3
[3]           kde-apps/kdepim-apps-libs-19.12.3
[3]           kde-apps/kmailtransport-19.12.3
[3]           kde-apps/akonadi-calendar-19.12.3
[3]           kde-apps/calendarsupport-19.12.3
[3]           kde-apps/eventviews-19.12.3
[3]           kde-apps/incidenceeditor-19.12.3
[3]           kde-apps/messagelib-19.12.3
[3]           kde-apps/mailimporter-19.12.3
[3]           kde-apps/mailcommon-19.12.3
[3]           kde-apps/akonadiconsole-19.12.3
[3]           kde-apps/kalarmcal-19.12.3
[3]           kde-apps/kdepim-runtime-19.12.3
[3]           kde-apps/kalarm-19.12.3
[3]           kde-apps/calendarjanitor-19.12.3
[3]           kde-apps/kaddressbook-19.12.3
[3]           kde-apps/kgpg-19.12.3
[3]           kde-apps/kmail-account-wizard-19.12.3
[3]           kde-apps/kmail-19.12.3
[3]           kde-apps/konsolekalendar-19.12.3
[3]           kde-apps/korganizer-19.12.3
[2]         kde-apps/kaccounts-providers-19.12.3
[2]         kde-apps/ktp-accounts-kcm-19.12.3
[3]           kde-apps/plasma-telepathy-meta-19.12.3
[4]             kde-apps/kdenetwork-meta-19.12.3
[2]         kde-apps/ktp-common-internals-19.12.3
[3]           kde-apps/ktp-contact-list-19.12.3
[4]             kde-apps/ktp-approver-19.12.3
[3]           kde-apps/ktp-text-ui-19.12.3
[3]           kde-apps/ktp-kded-module-19.12.3
[3]           kde-apps/ktp-contact-runner-19.12.3
[3]           kde-apps/ktp-filetransfer-handler-19.12.3
[3]           kde-apps/ktp-send-file-19.12.3
[2]         kde-apps/ktp-auth-handler-19.12.3
[2]         kde-frameworks/purpose-5.69.0
[3]           kde-plasma/plasma-browser-integration-5.18.4.1
[1]       kde-apps/khelpcenter-19.12.3
[1]       kde-apps/kmix-19.12.3
[1]       kde-apps/print-manager-19.12.3
[2]         kde-apps/kdeutils-meta-19.12.3
[1]       kde-apps/konqueror-19.12.3
[1]       app-office/libreoffice-6.3.4.2-r1
[1]       kde-plasma/breeze-5.18.4.1
[2]         kde-plasma/plasma-integration-5.18.4.1
[2]         kde-plasma/breeze-gtk-5.18.4.1
[1]       kde-plasma/kscreenlocker-5.18.4.1
[2]         kde-plasma/libkworkspace-5.18.4.1
[3]           kde-plasma/systemsettings-5.18.4.1
[1]       kde-plasma/kwin-5.18.4.1-r1
[1]       kde-plasma/plymouth-kcm-5.18.4.1
[1]       kde-plasma/kscreen-5.18.4.1
[1]       kde-plasma/plasma-workspace-5.18.4.1
[2]         media-video/plasma-mediacenter-5.7.5
[2]         kde-plasma/kdeplasma-addons-5.18.4.1
[1]       kde-plasma/oxygen-5.18.4.1
[1]       kde-plasma/plasma-desktop-5.18.4.1-r1
[1]       kde-plasma/bluedevil-5.18.4.1
[1]       kde-plasma/sddm-kcm-5.18.4.1
[1]       kde-plasma/kinfocenter-5.18.4.1-r1
[1]       kde-plasma/plasma-nm-5.18.4.1
[1]       kde-plasma/powerdevil-5.18.4.1
[1]       kde-plasma/kde-gtk-config-5.18.4.1
[1]       kde-plasma/khotkeys-5.18.4.1
[1]       kde-plasma/plasma-meta-5.18.4.1
╠ Legend:
╠ [x] packages passed as arguments
╠ [x] packages with no further dependencies
╠ [x] packages with further dependencies (node)
╠ [x] packages already pulled in as dependency in upper levels (circularity)
========================================

User avatar
sabayonino
Sagely Hen
Posts: 3540
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Language problems again

Post by sabayonino » Tue Apr 28, 2020 11:11

I'm installing Sabayon from tar.gz

It has 02locale set as following (by default "us")

Code: Select all

LANG="us_US.UTF-8"
LANGUAGE="us_US.UTF-8""
LC_ALL="us_US.UTF-8"

msdobrescu
Old Dear Hen
Posts: 876
Joined: Sun Aug 21, 2011 8:48

Re: Language problems again

Post by msdobrescu » Tue Apr 28, 2020 12:51

It works until I set the region to something else.

Post Reply