KAlarm, Akonadi, and MariaDB Errors

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
twhite
Baby Hen
Posts: 15
Joined: Tue Sep 20, 2016 20:57

KAlarm, Akonadi, and MariaDB Errors

Post by twhite » Wed Sep 11, 2019 20:32

Recently KAlarm stopped working, I was unable to create or update alarms, I have errors like "Failed to insert new part into database." and "Cannot connect to the Akonadi service." After stopping then starting Akonadi from the command line I noticed many database code "1452" errors and others. I read that this also effects other applications as well.

This is a known problem that looks like it has been fixed but doesn't appear to have come to Sabayon yet as I just upgraded and it still fails. As described in https://bugs.archlinux.org/task/63025 the workaround is to downgrade MariaDB to 10.3.16-1, I'm currently on 10.4.7-r1 with the update I got today.

Is is possible to downgrade this in Sabayon and how do I do it? Is this a known issue with Sabayon as I couldn't find anything here?

Stupot
Sagely Hen
Posts: 1816
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: KAlarm, Akonadi, and MariaDB Errors

Post by Stupot » Thu Sep 12, 2019 16:51

That arch bug makes it sound like it was an arch migration issue.

It's possible Sabayon has the same sort of migration issue, so maybe try out what the guy in the last comment said.

Yes, it seems this does the trick. I guess I'm going to run the following on my machines then:

Code: Select all

find /tmp -ipath "/tmp/akonadi-$USER.*/mysql.socket" -exec mysql --socket={} -e 'create database mysql' \; -exec mysql_upgrade --socket={} \;
akonadictl restart
There is no need to restart KMail.

So I guess this ticket can be closed. After all it was just a missing migration like I have already suspected. However, it would be nice if it was mentioned similar to the "regular" database migration (https://www.archlinux.org/news/mariadb- ... tervention) because only executing `systemctl restart mariadb.service && mariadb-upgrade -u root -p` does not affect the MariaDB instance used by Akonadi.

twhite
Baby Hen
Posts: 15
Joined: Tue Sep 20, 2016 20:57

Re: KAlarm, Akonadi, and MariaDB Errors

Post by twhite » Fri Sep 13, 2019 21:07

I found where the socket is found on Sabayon and tried to run the command modified from the link.

mariadb --socket=/run/user/1001/akonadi/mysql.socket -e 'create database mysql'
I believe it is using MariaDB and not MySQL but there's no update_mariadb like for mysql.


Now when I start akonadi I get these errors and fails to start:

Code: Select all

$ org.kde.pim.akonadiserver: Starting up the Akonadi Server...
org.kde.pim.akonadiserver: mysqld for Akonadi is already running, trying to connect to it.
org.kde.pim.akonadiserver: Failed to connect to database!
org.kde.pim.akonadiserver: Database error: "Access denied for user 'tim'@'localhost' (using password: NO) QMYSQL: Unable to connect"
org.kde.pim.akonadiserver: Failed to remove runtime connection config file
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...
It was starting before but not now so I must have done something to change that. I've reinstalled both MariaDB and Akonadi but it acts the same. I also tried logging on to both databases outside Akonadi but get the same error. I'm not very familiar with mysql/mariadb so I'm considering trying with postgresql.

Is anyone else having problems with KAlarm or Kmail?

iosman987
Baby Hen
Posts: 2
Joined: Fri Mar 20, 2020 6:32

Re: KAlarm, Akonadi, and MariaDB Errors

Post by iosman987 » Sun Mar 22, 2020 15:28

I do the updates and restart my PC only
to get three question marks and then a blinking cursor forever.
krogerfeedback
talktosonic
talktowendys
I have wasted so many DVDs trying to install this OS and
it's just terrible that I am having so much trouble. I need some help or
I just will say goodbye to Sabayon Linux Thanks.
Last edited by iosman987 on Wed May 06, 2020 15:53, edited 1 time in total.

picard12
Growing Hen
Posts: 151
Joined: Thu Jan 27, 2011 5:26

Re: KAlarm, Akonadi, and MariaDB Errors

Post by picard12 » Thu Apr 02, 2020 4:07

I solved this issue deleting the follow folder in your home, but before you need to stop akonadi server:
akonadictl stop

remove : home/.config/akonadi
home/.local/share/akonadi
then restart your pc.

Post Reply