After Upgrades.... KDE not open, SDDM not open [Solved].

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

User avatar
albfneto
Sagely Hen
Posts: 1921
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil
Contact:

Re: After Upgrades.... KDE not open, SDDM not open

Post by albfneto » Thu Jun 07, 2018 21:32

SOLVED........ SOLVED.............. SOLVED...........!

Thank you MSDOBRESCU... Your idea let me to search the net until i found the solution.

POST SOLUTION IN ORDER TO HELP THE COMMUNITY Sabayon

1. At first, i see the info that in new Linux, Gallium package is into the Mesa package... Mesa is installed

First i checked in the "not working" Sabayon, that in the dir /usr/lib/llvm no "5" subdir.... This indicates for me no LLVM support for Qt5-KDE5. I removed the files LLVM, and reinstall the latest;

Code: Select all

# equo rm  -av --configfiles --purge llvm
# equo up
# equo i -av llvm
Now I have the dir /usr/lib/llvm/5.

2. In this Tutorial, i found the problem and solution:

https://wiki.ubuntu.com/X/Troubleshooting/3D

It was the i915 module, i executed these commands:

Code: Select all

# rmmod i915
# modprobe i915
$ lsmod | grep i915 
# pkill X
start the new session (lxdm login manager, XFCE session). checked the 3 D accel:

Code: Select all

$ glxinfo | grep render
glxinfo | grep render
ATTENTION: default value of option vblank_mode overridden by environment.
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: AMD CEDAR (DRM 2.50.0 / 4.16.0-sabayon, LLVM 5.0.1)
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil, 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 
for test, i activated Compiz, cube effects etc... using Fusion Icon. working good....

3. Now, return to my main Login Manager (SDDM) and return to my main Graphical Environment, KDE5 Plasma.

Code: Select all

# systemctl stop lxdm.service
# systemctl disable lxdm.service
# systemctl enable sddm.service -f
And reboot:

Code: Select all

# systemctl reboot
SDDM Open.... Login to the KDE Plasma Session, OK and with the configurated Kwin effects

See My Desktop return..... and with glxgears, proof of the working 3D accel.:

http://uploaddeimagens.com.br/imagens/aceleroo-png
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

msdobrescu
Old Dear Hen
Posts: 867
Joined: Sun Aug 21, 2011 8:48

Re: After Upgrades.... KDE not open, SDDM not open [Solved].

Post by msdobrescu » Fri Jun 08, 2018 6:25

Don't mention it! I have no contribution.
My setup is still messed up and tried a lot to clean it up, but I have no success.
Why am I saying that? Because after switching to Nouveau and to nVidia back, Celestia still needs the path to the nVidia and OpenGL libs in order to start.

Post Reply