Nvidia problem [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Nvidia problem [Solved]

Postby moldmaker » Sun Dec 24, 2017 16:53

Just updated Nvidia Userspace from 384.98 to 387.34 -> no graphics, text mode only.
Rolled back to 384.98 -> all good again.
Can anyone comfirm this?

Mm.
Last edited by moldmaker on Mon Dec 25, 2017 21:37, edited 1 time in total.
moldmaker
Young Hen
 
Posts: 24
Joined: Fri Feb 28, 2014 18:54

Re: Nvidia problem

Postby sabayonino » Sun Dec 24, 2017 17:15

nvidiauserspace packages need (ad builtin dep) of

x11-drivers/nvidia-drivers-XXX.XX#<kernel-version> package

a list of nvidia-drivers available is :
Code: Select all
# equo s nvidia-drivers -qv
x11-drivers/nvidia-drivers-304.137#4.1.0-sabayon
x11-drivers/nvidia-drivers-304.137#4.11.0-sabayon
x11-drivers/nvidia-drivers-304.137#4.12.0-sabayon
x11-drivers/nvidia-drivers-304.137#4.13.0-sabayon
x11-drivers/nvidia-drivers-304.137#4.4.0-sabayon
x11-drivers/nvidia-drivers-304.137#4.9.0-sabayon
x11-drivers/nvidia-drivers-340.104#4.1.0-sabayon
x11-drivers/nvidia-drivers-340.104#4.11.0-sabayon
x11-drivers/nvidia-drivers-340.104#4.12.0-sabayon
x11-drivers/nvidia-drivers-340.104#4.13.0-sabayon
x11-drivers/nvidia-drivers-340.104#4.14.0-sabayon
x11-drivers/nvidia-drivers-340.104#4.4.0-sabayon
x11-drivers/nvidia-drivers-340.104#4.9.0-sabayon
x11-drivers/nvidia-drivers-384.90#4.1.0-sabayon
x11-drivers/nvidia-drivers-384.90#4.11.0-sabayon
x11-drivers/nvidia-drivers-384.90#4.12.0-sabayon
x11-drivers/nvidia-drivers-384.90#4.4.0-sabayon
x11-drivers/nvidia-drivers-384.90#4.9.0-sabayon
x11-drivers/nvidia-drivers-384.98#4.1.0-sabayon
x11-drivers/nvidia-drivers-384.98#4.11.0-sabayon
x11-drivers/nvidia-drivers-384.98#4.12.0-sabayon
x11-drivers/nvidia-drivers-384.98#4.13.0-sabayon
x11-drivers/nvidia-drivers-384.98#4.14.0-sabayon
x11-drivers/nvidia-drivers-384.98#4.4.0-sabayon
x11-drivers/nvidia-drivers-384.98#4.9.0-sabayon
x11-drivers/nvidia-drivers-387.34#4.1.0-sabayon
x11-drivers/nvidia-drivers-387.34#4.11.0-sabayon
x11-drivers/nvidia-drivers-387.34#4.12.0-sabayon
x11-drivers/nvidia-drivers-387.34#4.13.0-sabayon
x11-drivers/nvidia-drivers-387.34#4.14.0-sabayon
x11-drivers/nvidia-drivers-387.34#4.4.0-sabayon
x11-drivers/nvidia-drivers-387.34#4.9.0-sabayon


just try :
Code: Select all
# equo i nvidia-userspace nvidia-drivers#$(uname -r) --ask
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)
User avatar
sabayonino
Sagely Hen
 
Posts: 3140
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Nvidia problem

Postby moldmaker » Sun Dec 24, 2017 17:45

OK did it and the same thing happened again.
I think I know now what went wrong. Equo installed only nvidia-userspace-387.34, but nvidia-drivers-384.98 was not updated.
No problem, I removed nvidia-userspace-387.34 and re-installed nvidia-userspace-384.98. Now it's working again.
Is this due to my repositories? My enabled repositories are community and sabayonlinux.org. Disabled are sabayon-limbo and sabayon-weekly.

Mm.
moldmaker
Young Hen
 
Posts: 24
Joined: Fri Feb 28, 2014 18:54

Re: Nvidia problem

Postby cgherman » Mon Dec 25, 2017 10:56

yes nvidia-drivers-387.xx are masked but nvidia-userspace not.

I unmasked and instaled last nvidia driver and system works again :)
cgherman
Baby Hen
 
Posts: 6
Joined: Sat May 11, 2013 7:02

Re: Nvidia problem

Postby moldmaker » Mon Dec 25, 2017 21:36

Ah thanks 8)

Mm.
moldmaker
Young Hen
 
Posts: 24
Joined: Fri Feb 28, 2014 18:54

Re: Nvidia problem [Solved]

Postby Omnomnom9 » Fri Dec 29, 2017 17:33

I have the same problem. Sabayon 17.12 kde fresh install. When I try to update the system, it says internal error. When I remove the nvidia-userspace-387.34, all nvidia drivers are removed and I can update the system. When I reinstall the nvidia-userspace-384.98 after that and reboot the system, I end up in console and kde doesn't start.

Thanks in advance
Omnomnom9
Baby Hen
 
Posts: 11
Joined: Sun Oct 23, 2016 20:54

Re: Nvidia problem [Solved]

Postby jaguar1637 » Sat Dec 30, 2017 21:30

hi
BTW, how did you set up your fresh installation w/ Nvidia card
jaguar1637
Simple Hen
 
Posts: 62
Joined: Sun Jul 26, 2009 9:11
Location: Toulouse - France

Re: Nvidia problem [Solved]

Postby Omnomnom9 » Wed Jan 03, 2018 18:07

I used the Sabayon 17.12 KDE iso. I think I solved the problem by not updating the nvidia-userspace-387.34. Installation was no problem, if you meant that?
Omnomnom9
Baby Hen
 
Posts: 11
Joined: Sun Oct 23, 2016 20:54

Re: Nvidia problem [Solved]

Postby jaguar1637 » Sun Jan 07, 2018 18:59

hi
Yes, the isntallation is impossible on an ACER Helios 300 w/ nvidia GTX 1060.
It's impossible to launch the Sabayon MAte last release.

Did you made something in the settings ?
Did you modify the Xorg configuration in order to install Sabayon , coz Nvidia driver is not taken into account ?
I try to put the driver fb, without being sucessful

any advice from you would be welcomed ?
jaguar1637
Simple Hen
 
Posts: 62
Joined: Sun Jul 26, 2009 9:11
Location: Toulouse - France

Re: Nvidia problem [Solved]

Postby Omnomnom9 » Tue Jan 09, 2018 20:33

I didn't made any changes to settings, nor the Xorg configuration.

Can you start the installation? At which point of the installation occurs the problem?
Omnomnom9
Baby Hen
 
Posts: 11
Joined: Sun Oct 23, 2016 20:54

Next

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests

cron