Cannot change to SDDM login screen [reopened]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Re: Cannot change to SDDM login screen

Postby sabayonino » Tue Aug 22, 2017 12:16

these are sddm packages I've installed
Code: Select all
$ equo q installed sddm  -qv
kde-plasma/sddm-kcm-5.9.5
x11-misc/sddm-0.14.0-r1
x11-themes/sabayon-artwork-sddm-base-15
x11-themes/sabayon-artwork-sddm-default-15-r2
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)
User avatar
sabayonino
Sagely Hen
 
Posts: 3154
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Cannot change to SDDM login screen

Postby linuxfluesterer » Tue Aug 22, 2017 18:21

sabayonino wrote:these are sddm packages I've installed
Code: Select all
$ equo q installed sddm  -qv
kde-plasma/sddm-kcm-5.9.5
x11-misc/sddm-0.14.0-r1
x11-themes/sabayon-artwork-sddm-base-15
x11-themes/sabayon-artwork-sddm-default-15-r2


I just added the last two packages, which where not installed before. Then I tried to change from lightdm to sddm again. The result was that I received one terminal (I assume VT1) and when I changed to VT7 with <Ctrl - Alt - F7> then I only saw a strange line of characters like this (yes, with white filled squares on a black screen):
Code: Select all
A■■■■■■■■■AAAAA■■■■■■■■■■■AAAAA

which was elongered when I entered a key, and then I could no more soft reboot. I had to boot into recovery mode again and then 'repair' this misbehavior with a fallback to lightdm.
I was at my friend today. And I could check, he has sddm as login service working properly.

-Linuxfluesterer (I love KDE...)
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 855
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Cannot change to SDDM login screen

Postby sabayonino » Tue Aug 22, 2017 19:35

X session starts on VT1 not VT7
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)
User avatar
sabayonino
Sagely Hen
 
Posts: 3154
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Cannot change to SDDM login screen

Postby linuxfluesterer » Tue Aug 22, 2017 19:40

sabayonino wrote:X session starts on VT1 not VT7

On VT1 there is only a text terminal, a text login screen.
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 855
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Cannot change to SDDM login screen

Postby Fitzcarraldo » Wed Aug 23, 2017 17:31

When I'm using LightDM in SL as installed, the X Windows session is in VT7. When I'm using SDDM in SL, the X Windows session is in VT1. The default VT for X Windows in installations using systemd is VT1. You can change the SDDM session from VT1 to VT7 as I explained in a previous post.

It looks like what you are experiencing is a known bug in SDDM which affects certain installations:

https://bugs.gentoo.org/show_bug.cgi?id=584960
https://github.com/sddm/sddm/issues/644
https://github.com/sddm/sddm/issues/715
https://github.com/sddm/sddm/issues/799

P.S. You did not post the contents of /var/log/Xorg.0.log. The contents of that file will probably confirm the above. The only other thing I can suggest is to backup your personal files and re-install SL from a recent LivePenDrive, but that might not change anything in your case, as the above-mentioned Gentoo and SDDM bug reports are still open. Or you live with LightDM, which is a perfectly good DM and has been in development longer than SDDM. If you want to change the greeter background and reconfigure LightDM, that is possible.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 8090
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Cannot change to SDDM login screen

Postby linuxfluesterer » Wed Aug 23, 2017 18:55

Hallo Fitz.
I will try to configure lightdm but there is no
Code: Select all
lightdm-kde-greeter.desktop
in Sabayon repo. And I would like to have a nice background and secondly my username shown on the login screen that I only need to enter my password, like in sddm.
Or, is it possible to configure this settings within Plasma system setting?

Thank you in advance.

-Linuxfluesterer (I love KDE...)
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 855
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Cannot change to SDDM login screen

Postby Fitzcarraldo » Thu Aug 24, 2017 0:44

Edit /etc/lightdm/lightdm.conf to make sure it specifies the LightDM GTK greeter:

Code: Select all
# grep -v "^#\|^$" /etc/lightdm/lightdm.conf
[LightDM]
session-wrapper=/etc/lightdm/Xsession
[Seat:*]
greeter-session=lightdm-gtk-greeter
session-wrapper=/etc/lightdm/Xsession
[XDMCPServer]
[VNCServer]


LightDM is very configurable. See the following Web page for a few of the options:

https://www.freedesktop.org/wiki/Softwa ... iguration/

Configuration of the LightDM GTK greeter is done in /etc/lightdm/lightdm-gtk-greeter.conf. Change the background to whatever PNG file you want. Also uncomment the line '#indicators=' and add the indicators you want (see the various comments at the top of the configuration file for the options available). For example:

Code: Select all
# grep -v "^#\|^$" /etc/lightdm/lightdm-gtk-greeter.conf
[greeter]
background=/usr/share/backgrounds/mychosenbackground.png
indicators=~host;~spacer;~clock;~spacer;~language;~power


Furthermore, irrespective of which DM you use, note that there is a bug in KDE Plasma 5 which means users' avatars are not set up properly, nor displayed correctly, by System Settings > User Manager:

https://bugs.kde.org/show_bug.cgi?id=336994

I used the procedure below to work around the bug.

1. I created a 96x96 PNG avatar /home/fitzcarraldo/Pictures/fitzcarraldo.png

2. I edited the file /var/lib/AccountsService/users/fitzcarraldo to contain the following (replace 'en_GB.utf8' with your language)

Code: Select all
[User]
Language=en_GB.utf8
XSession=plasma
SystemAccount=false
Icon=/var/lib/AccountsService/icons/fitzcarraldo


3. I made sure that file has 644 permissions

Code: Select all
# ls -la /var/lib/AccountsService/users/fitzcarraldo
-rw-r--r-- 1 root root 104 Aug  5 16:43 /var/lib/AccountsService/users/fitzcarraldo


4. I copied the avatar to the relevant directory and made sure it has 644 permissions

Code: Select all
# cp /home/fitzcarraldo/Pictures/fitzcarraldo.png /var/lib/AccountsService/icons/fitzcarraldo
# ls -la /var/lib/AccountsService/icons/fitzcarraldo
-rw-r--r-- 1 root root 12667 Aug  5 16:23 /var/lib/AccountsService/icons/fitzcarraldo


After rebooting, the desired avatar was displayed on LightDM's GTK Greeter screen, on the KDE Plasma 5 Lock screen, in 'System Settings' > 'Account Details' > 'User Manager', and at the top of the KDE Plasma 5 Application Launcher menu.

I recommend not using 'System Settings' > 'Account Details' > 'User Manager' until the bug is squashed, but you can copy the avatars of other users to /var/lib/AccountsService/icons/ and edit the other users' files in /var/lib/AccountsService/users/ as explained above. I have always used app-admin/superadduser on the command line to add new users, and it has never failed me. So you can add new users and specify their avatars without touching 'System Settings' > 'Account Details' > 'User Manager'.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 8090
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Cannot change to SDDM login screen

Postby linuxfluesterer » Thu Aug 24, 2017 14:06

Hallo Fitz.
Thank you very much for your efforts. Finally I was able to individualize some login / greeter settings of lightdm.
But using the entry of lightdm-kde-greeter in lightdm.conf has the effect of just only a text terminal, no login screen:

Fitzcarraldo wrote:Edit /etc/lightdm/lightdm.conf to make sure it specifies the LightDM GTK greeter:
Code: Select all
# grep -v "^#\|^$" /etc/lightdm/lightdm.conf
[LightDM]
session-wrapper=/etc/lightdm/Xsession
[Seat:*]
greeter-session=lightdm-gtk-greeter
session-wrapper=/etc/lightdm/Xsession
[XDMCPServer]
[VNCServer]



So, I will try to find out some useful settings in lightd then with individual background pictures first. The hint with clock, language and time is nice. I use this also. But honestly, I don't understand most of the settings. Especially I don't get displayed my username so that I simply have to type in my password.
Anyway, my status is much better now. I like it much better now.

I'll mark this thread for solved. The reason for misbehave of sddm is given and there is an appropriate way to solve my issue.

So, thank you again, Fitz.

-Linuxfluesterer (I love KDE...)
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 855
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Cannot change to SDDM login screen

Postby Fitzcarraldo » Thu Aug 24, 2017 14:59

linuxfluesterer wrote:But using the entry of lightdm-kde-greeter in lightdm.conf has the effect of just only a text terminal, no login screen:

Fitzcarraldo wrote:Edit /etc/lightdm/lightdm.conf to make sure it specifies the LightDM GTK greeter:
Code: Select all
# grep -v "^#\|^$" /etc/lightdm/lightdm.conf
[LightDM]
session-wrapper=/etc/lightdm/Xsession
[Seat:*]
greeter-session=lightdm-gtk-greeter
session-wrapper=/etc/lightdm/Xsession
[XDMCPServer]
[VNCServer]


The LigfhtDM KDE Greeter was dropped from Gentoo in July 2017 due to the KDE developers not maintaining it for several years[1]: Gentoo Bug Report No. 620796 - x11-misc/lightdm-kde - last-rite.

Andreas Sturmlechner wrote:x11-misc/lightdm-kde has not seen any development since 2013 and consequently still rdepends on kde-apps/plasma-runtime, which in turn blocks dev-qt/qtwebkit:4 removal.

https://cgit.kde.org/scratch/davidedmun ... m-kde.git/

Therefore it is not possible to specify lightdm-kde-greeter as the greeter-session in /etc/lightdm/lightdm.conf. That is why you don't see a greeter screen when you specify lightdm-kde-greeter. The LightDM GTK Greeter has more options in any case, and is better than the LightDM KDE Greeter was.

[1] When I created a patch for LightDM in Gentoo to enable non-systemd users to suspend and hibernate from the login screen, I looked at the LightDM KDE Greeter code with a view to patching that too but the code is ancient (requiring upower <0.99.0) so I switched to the GTK greeter, which works well. I notice that, even when the KDE greeter was still available in Gentoo, the SL KDE edition used the GTK greeter.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 8090
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Cannot change to SDDM login screen [Solved]

Postby linuxfluesterer » Tue Oct 17, 2017 17:51

Hallo guys, hallo Fitz.
In between, after some upgrades of my Sabayon Plasma OS to version 5.11 now, I am able to login now with SDDM.
But my login screen is of very low resolution with a cut background (selected wallpaper) and a very big login window. I assume it's quite vesa with 1024 x 768, in letters, which I can see while booting Sabayon.
The point is, I have a Dell U3415W screen with 3440x1440 pixels.

So, how or where can I change the active resolution from beginning, from boot screen where only boot messages appear and then that later a smooth well drwan SDDM login window appears?

After last upgrade I had such a perfect boot screen and a perfect login screen, but sadly my running Plasma crashed while hanging in Kaffeine so that I only could hard reset with totally power off :( .

What can I do? The Plasma desktop itself is in well shape with 3440x1440 pixels.

Thank you in advance.

-Linuxfluesterer (I love KDE...)
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 855
Joined: Thu Sep 20, 2012 19:47
Location: Germany

PreviousNext

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests