Blinking boot [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Blinking boot [Solved]

Postby msdobrescu » Sun Apr 13, 2014 21:09

Hello,

After the last updates, although I have set systemd since long time, the computer doesn't boot in Sabayon anymore.
I have blinking screens and leds on the keyboard and black screen after.

I have a flash pen with the latest cd for KDE (14.01) , but it could not start the KDE.
I've tried a chroot (from here https://wiki.sabayon.org/index.php?titl ... m_a_LiveCD) and to reinstall systemd as others, but with no effect.

Adding to grub the init=/usr/lib/systemd/systemd or init=/usr/lib64/systemd/systemd line did not work.

I have 64 bit system with UEFI configuration on an Asus N76VZ notebook.

What could I do?
Last edited by msdobrescu on Tue May 20, 2014 13:25, edited 1 time in total.
msdobrescu
Technological Hen
 
Posts: 424
Joined: Sun Aug 21, 2011 8:48

Re: Blinking boot

Postby betazed » Mon Apr 14, 2014 21:05

I had a similar issue with my laptop. I noticed your laptop seems to have an Optimus graphics set up. What I had to do to boot the LiveCD into KDE was to disable the nVidia graphics in the BIOS. The laptop should then boot normally.

If you want to confirm this is the problem, make sure you're on TTY1, then run "top." You should see the KDE processes running even though you can't see any interface.
User avatar
betazed
Young Hen
 
Posts: 28
Joined: Thu Jan 09, 2014 11:07
Location: St. Petersburg, FL

Re: Blinking boot

Postby msdobrescu » Mon Apr 14, 2014 22:34

Thank you for the reply, but I don't find the option to disable nVidia graphics.
Anyway, I've took the 14.05 dvd and flashed it.
Guess what? It does exactly the same as the installed Sabayon itself.
Flashes, blinking leds and after a while shuts down...
Could it be the kernel? I will try to chroot and switch to an old kernel.
msdobrescu
Technological Hen
 
Posts: 424
Joined: Sun Aug 21, 2011 8:48

Re: Blinking boot

Postby msdobrescu » Mon Apr 14, 2014 22:51

Another kernel works! So, 3.13.7 works, 3.14 doesnt! I wish I know why.
msdobrescu
Technological Hen
 
Posts: 424
Joined: Sun Aug 21, 2011 8:48

Re: Blinking boot

Postby Stupot » Tue Apr 15, 2014 15:17

You probably have the 3.13 version of the nvidia drivers installed, not the 3.14 version.

There's a tool called kernel-switcher Sabayon provides which is an easy way to switch kernels, as it also switches graphics and other kernel version dependent modules.
https://wiki.sabayon.org/index.php?titl ... l_Switcher
Stupot
Sagely Hen
 
Posts: 1545
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Blinking boot

Postby msdobrescu » Tue Apr 15, 2014 16:01

I know. I actually don't know how to install a new kernel without the kernel switcher. The issue is elsewhere, in the 3.14 kernel config or in the drivers.
If I take the DVDs, 14.01 starts in command line only, can't start KDE, for example; 14.05 has exactly the same behavior as the installed Sabayon with 3.14 kernel, i.e. some black screen with dots in the upper left area of the screen, blinking leds, shutdown after a while.
This problem is real, there are several threads already here, on the same issue.
msdobrescu
Technological Hen
 
Posts: 424
Joined: Sun Aug 21, 2011 8:48

Re: Blinking boot

Postby Stupot » Tue Apr 15, 2014 16:09

Sorry, I misread. You mentioned blinking LEDS, and I read blinking cursor, which is typically what people write about when their graphics drivers aren't loading correctly. I believe I'm using the 3.14 kernel at home, so we probably need to start investigating hardware differences, since it seems to be more than just a single user's issue.
Stupot
Sagely Hen
 
Posts: 1545
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Blinking boot

Postby msdobrescu » Tue Apr 15, 2014 16:14

No problem. The blinking cursor is happening only with 14.01 live DVD, the one I've been telling it works in command line only.
Concerning the hardware, I have an Asus N76VZ: ASUS 17.3'' N76VZ-V2G-T1179D, FHD Procesor Intel® Core™ i7-3630QM 2.4GHz Ivy Bridge, 16GB, 750GB SSH, GeForce GT 650M 2GB.
msdobrescu
Technological Hen
 
Posts: 424
Joined: Sun Aug 21, 2011 8:48

Re: Blinking boot

Postby msdobrescu » Wed Apr 16, 2014 23:46

Additionally, under my config, which is still 3.13, KDE desktop effects are broken. My video card, which is a Geforce GT 650M, has OpenGl 4.4, but KDE could use 2.0 instead of 3.1. Could be due to CPU integrated video?
msdobrescu
Technological Hen
 
Posts: 424
Joined: Sun Aug 21, 2011 8:48

Re: Blinking boot

Postby ElDuderino » Thu Apr 17, 2014 0:55

Try kernel 3.14-r1 from limbo. I had the same issue when I tried 3.14, using no proprietary graphics drivers. Now, with 3.14-r1, everything is fine.

EDIT: Perhaps related to this issue? https://bbs.archlinux.org/viewtopic.php?id=179456
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Next

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron