Page 1 of 1

Home directory not detected [Abandoned]

Posted: Fri Nov 22, 2013 1:24
by cmost
Strange problem today... I turned on my computer as usual and when it booted, it went straight to a command prompt. Logging in caused a message:

Code: Select all

No directory, logging in with HOME = /
The BIOS reports no problems with the hard disk that contains the HOME partition. Moreover, when I boot from a live CD of any distro, I can plainly see my home directory and all files intact. Any ideas on how to fix this quick? I have Limbo enabled and installed a few updates yesterday but stupidly I did not pay attention to what they were because all updates have been smooth as silk lately. :( Unfortunately, logging in as root and trying to check for updates in this crippled state that might automagically fix the problem fails too. I've had my system installed for quite awhile now and do not want to have to wipe and re-install. Please help!!

Re: Home directory not detected

Posted: Sat Nov 30, 2013 19:26
by cmost
Such an outpouring of help on this issue guys. :D

Google was not at all helpful in sorting it out either, and trust me, I searched relentlessly. So, I tried to do a fresh install with the KDE daily from Nov. 20th. Unfortunately, while the daily disk booted fine and the installation went without issue, the installer apparently couldn't write Grub to the MBR which resulted in an unbootable system. I tried it twice, same result. My system does not seem to cotton to Systemd (Arch and any of its derivatives like Manjaro or Antergos would hang while booting from their respective live CDs) so I'm moving back to tried and trusted Debian (by way of LMDE) for now. It's been a nice ride with Sabayon these past few years. As Arnold Schwarzenegger said in Terminator: "I'll be back"