Can't start kde after last upgrade

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
Simple Hen
Posts: 68
Joined: Wed Sep 07, 2011 0:46

Can't start kde after last upgrade

Post by King_DuckZ » Mon Sep 02, 2013 13:12

I keep my system up-to-date and I run equo upgrade every Monday (plus emerge --update @myset). Today upgrading broke my system, after reboot I wasn't able to start kde anymore. My fix was:

rm -f ~/.kde4/share/plasmarc

Apparently trying to load a non-existing theme is enough to crash kde and have all sort of "sorry kmix has crashed" reports? Then I could finally boot into a working desktop (btw, why is enlightenment so unstable on Sabayon? having it didn't help me in the least). Next problem is I didn't have decorations anymore, and starting kwin manually from a console would give an error like

kwin: error while loading shared libraries: cannot open shared object file: No such file or directory

So, not sure what configuration file is pulling a dependency on this file (which I seemed to have before updating and at least before I did "equo remove --deep -a enlightenment", as I could locate it but not anymore after an updatedb). So, running

equo install -a xcb-util-keysyms

fixed kwin at last, but I'm left wondering about what else got messed up which I don't see yet. Nor deptest nor libtest reported anything missing, so I had to install this thing by hand. I hope this will be useful to anybody having the same problem I have (you can also try renaming your .kde4 into something else and see if it helps at all), and I hope those who decide what updates go in can try to run better tests the next time. Some of us use Linux for work, and wasting half a day fixing broken updates not only damages the person in question, but the overall perception of Linux as a stable, mature and usable system.

User avatar
Sagely Hen
Posts: 1917
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Can't start kde after last upgrade

Post by albfneto » Wed Sep 04, 2013 14:58

at this moment, i have a related problem.KDE no more opens in a complete manner.
open, runs, but without plasma,widgets, bars, menus, etc...
other DEs works normally.
I will try to reinstall the package.

This not solve my issue, the problem is in kwin, since when i tried "kwin --replace" it try to reload and then a message thai "segmentation vault" in kwin. i'm using the MATE session.
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

Technological Hen
Posts: 386
Joined: Mon Jun 18, 2007 7:01
Location: If It Moves Compile It

Re: Can't start kde after last upgrade

Post by sqlpython » Fri Sep 06, 2013 19:00

I had the similar issues after an Arch kde update..
My Sabayon is Xfce
Seems to me there are KDE package issues out there not particular to the Distros.
Criticism accepted for Solutions that work. ;^)
Sabayon 13-DEBIAN 8- #! -Sid-Slackware 14-Calculate 13-Bridge

Post Reply