[Fix included] Latest updates really did a number... (gdm)

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

[Fix included] Latest updates really did a number... (gdm)

Postby Gordon » Wed Aug 14, 2013 10:03

Rebooting after the updates I found I had no desktop. Deptest, libtest showed nothing missing. Manually running startx complained that it couldn't find xterm while it should run gdm :evil:

I had to completely reinstall gnome to get my desktop back again and today I found a new issue. I run vmware on my station, with several images being created on Windows machines from work and since the updates I ran the day before yesterday vmware now crashes on every file that has "Windows-1252" stamped in it to use as encoder. Anybody have any idea how to fix that?
Last edited by Gordon on Fri Aug 16, 2013 12:22, edited 1 time in total.
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22

Re: Latest updates really did a number on my computer

Postby Gordon » Thu Aug 15, 2013 8:20

Update: Gnome is NOT fixed. Booting today I again had no desktop and had to pull a number of stunts to get it back again. Also I see a warning when restarting xdm that there is no /var/run/gdm.pid. What's going on here? Don't you guys test before you release?
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22

Re: Latest updates really did a number on my computer

Postby Gordon » Thu Aug 15, 2013 8:44

Another update:

Just been reading the "Contributing to Sabayon & systemd" topic below and realize now that the boot procedure has been changed. This will most likely contribute to the warning about the missing pid file given by the Init-V script for xdm. And in fact even though I did get gdm running again through that Init-V script it doesn't register as started in `rc-status`. So the problem appears to be systemd.
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22

Re: Latest updates really did a number on my computer

Postby Gordon » Fri Aug 16, 2013 7:58

A new day and it appears confirmed. After booting doing a `ps aux | grep gdm` shows me two instances of gdm running and a load of process that are owned by a user named gdm. Running `killall gdm` did not remove all those other processes. Killing the root owned proces gdm-simple-slave did remove all the gdm owned process except for one: /usr/bin/pulsaudio. After killing that last remaining gdm owned process I could now start xdm sucessfully.

One step closer to a solution which I apparently have to figure out myself. Surely there must be others whose system got crippled by this update?
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22

Fix for not booting into gdm

Postby Gordon » Fri Aug 16, 2013 12:21

Found it...

As it turns out systemd doesn't do anything. The machine still boots into linuxrc and the key was in the error message about the missing pid. Now whatever causes the boot process to call /etc/init.d/xdm twice I don't know, but the missing pid also allows this process to start gdm twice, thus creating a conflict. Inspecting the /var/run path I found that gdm.pid has moved to its own subfolder (i.e. it is now /var/run/gdm/gdm.pid) while the xdm script (belonging to x11-base/xorg-server) still has it hardcoded to /var/run/gdm.pid

Thinking I might have missed some update somewhere I removed the xdm script and reinstalled xorg-server, only to find that the newly installed script had the same issue. So this is now officially a bug and I guess it is safe to say that the developers do in fact not check what they release as "stable". Thank you very much :evil:

Fix:
Code: Select all
sudo sed -i "s/\/var\/run\/gdm.pid/\/var\/run\/gdm\/gdm.pid/" /etc/init.d/xdm


Now the only issue I hev left here is that if switch to tty1 during the rather long blackout that occurs while starting gdm, somthing crashes and it shows the famous "Oh no" screen (gnome-session-failure).

And of course there also still the issue of the Windows-1252 font support having gone missing in action.
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22

Re: [Fix included] Latest updates really did a number... (gd

Postby ph03 » Sun Aug 18, 2013 14:35

I had the problem of not being able to restart gdm by init.d/xdm already a long time!
Today, after an upgrade, gdm didn't start at all with OpenRC anymore.
Your fix helped to solve the problem, thanks a lot! This is a really annoying bug that should definitively be fixed asap!!
ph03
Young Hen
 
Posts: 30
Joined: Thu Oct 27, 2011 11:43

Re: [Fix included] Latest updates really did a number... (gd

Postby slacker » Sun Aug 18, 2013 18:36

I've run into the same issue.
Finally got Gnome to start by killing off all the gdm processes and using startx, but gdm still does not work correctly.

Tried changing the gdm.pid to /var/run/gdm/gdm.pid but gdm still does not start correctly. After bootup, I get dumped to the command line and VT7 just shows the white 'Ooops, something went wrong' screen.

/var/log/gdm/:0-greeter.log shows this:
Code: Select all
gnome-session[10479]: WARNING: Error getting login monitor: -2

(gnome-settings-daemon:10603): color-plugin-WARNING **: failed to create device: failed to obtain org.freedesktop.color-manager.create-device auth

(gnome-settings-daemon:10603): color-plugin-WARNING **: failed to obtain org.freedesktop.color-manager.create-profile auth
      JS LOG: GNOME Shell started at Sun Aug 18 2013 10:51:11 GMT-0600 (MDT)
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!

(gnome-shell:10784): Cogl-ERROR **: Failed to create an OpenGL framebuffer object
      JS LOG: GNOME Shell started at Sun Aug 18 2013 10:51:13 GMT-0600 (MDT)
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!

(gnome-shell:10919): Cogl-ERROR **: Failed to create an OpenGL framebuffer object
gnome-session[10479]: WARNING: App 'gnome-shell.desktop' respawning too quickly

(gnome-settings-daemon:10603): GLib-GIO-CRITICAL **: g_dbus_proxy_call_internal: assertion `G_IS_DBUS_PROXY (proxy)' failed

(gnome-settings-daemon:10603): Gdk-WARNING **: gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
gnome-session[10479]: Gdk-WARNING: gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.


eselect opengl and opencl are set to nvidia (which is correct for this computer).

Again, Gnome runs fine by using startx, but gdm still crashes.
slacker
Baby Hen
 
Posts: 7
Joined: Sun Aug 18, 2013 18:26

Re: [Fix included] Latest updates really did a number... (gd

Postby ph03 » Sun Aug 18, 2013 20:50

Maybe upstream should have a look at this?
ph03
Young Hen
 
Posts: 30
Joined: Thu Oct 27, 2011 11:43

Re: [Fix included] Latest updates really did a number... (gd

Postby Tighe » Mon Aug 19, 2013 11:04

I am having the same problem:

viewtopic.php?f=57&t=30547
User avatar
Tighe
Simple Hen
 
Posts: 42
Joined: Mon Apr 26, 2010 0:15
Location: Richmondville, NY

Re: Fix for not booting into gdm

Postby Tighe » Mon Aug 19, 2013 11:32

Gordon wrote:Found it...

As it turns out systemd doesn't do anything. The machine still boots into linuxrc and the key was in the error message about the missing pid. Now whatever causes the boot process to call /etc/init.d/xdm twice I don't know, but the missing pid also allows this process to start gdm twice, thus creating a conflict. Inspecting the /var/run path I found that gdm.pid has moved to its own subfolder (i.e. it is now /var/run/gdm/gdm.pid) while the xdm script (belonging to x11-base/xorg-server) still has it hardcoded to /var/run/gdm.pid

Thinking I might have missed some update somewhere I removed the xdm script and reinstalled xorg-server, only to find that the newly installed script had the same issue. So this is now officially a bug and I guess it is safe to say that the developers do in fact not check what they release as "stable". Thank you very much :evil:

Fix:
Code: Select all
sudo sed -i "s/\/var\/run\/gdm.pid/\/var\/run\/gdm\/gdm.pid/" /etc/init.d/xdm


Now the only issue I hev left here is that if switch to tty1 during the rather long blackout that occurs while starting gdm, somthing crashes and it shows the famous "Oh no" screen (gnome-session-failure).

And of course there also still the issue of the Windows-1252 font support having gone missing in action.



My /etc/init.d/xdm did have /var/run/gdm.pid in it and I changed it to /var/run/gdm/gdm.pid but it didn't resolve my problem where gdm hangs after login.

I did notice that /etc/init.d/logind is running on boot, something I have never seen before. I looked inside and found this:

Code: Select all
~ $ cat /etc/init.d/logind
#!/sbin/runscript
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

command="/usr/lib/systemd/systemd-logind"
start_stop_daemon_args="--quiet --background"
description="Login Service and ConsoleKit replacement"

depend() {
   need dbus udev-mount
   use logger
   after tmpfiles.setup
}


Wait what? command="/usr/lib/systemd/systemd-logind" ??? But I am running sysvinit!

Code: Select all
~ $ eselect sysvinit list
Available init implementations:
  [1]   systemd
  [2]   sysvinit *


should I rc-update delete logind default?
User avatar
Tighe
Simple Hen
 
Posts: 42
Joined: Mon Apr 26, 2010 0:15
Location: Richmondville, NY

Next

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests