Display problems after update... [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
Baby Hen
Posts: 1
Joined: Wed Jul 31, 2013 1:53

Display problems after update... [Solved]

Post by blue_on_blue » Wed Jul 31, 2013 2:25

For the third time now I have done 'equo upgrade' only to not be able to boot back into the system. Everything acts normal, but when it is supposed to be booting to my login screen everything goes black. I eventually figured out the previous times that something had changed my eselect opengl and opencl to Xorg. It is supposed to be ATI. I remounted rw and corrected it. When I rebooted, everything was as it should be. That is until this most recent time...

This time I assumed it was the same situation, and I employed the usual fix. It seemed to be working, and I believe it did take me to the login GUI screen. However, the screen is completely messed up and I cannot see anything. I can tell the mouse pointer as a 1" square box that moves when the mouse moves. If I type in my username and password it seems like it logs in. There are strange changes in the kaleidoscope of colors, but the display is basically useless.

I am probably an intermediate level linux user, and I have been using Sabayon for a few years now. However, I think I'm about to give up on it. The same annoying problems creep up again and again, and I can't seem to get any support. The Live Chat is a ghost town. I've never gotten any help there. And the resources available online leave much to be desired, often confusing issues more than helping at all. This is my first attempt seeking help in the forums. I hope I fare better than I have elsewhere. If someone can at least point me in the right direction, that would likely be all I need. Also, if someone could explain to me why these upgrades are routinely messing with settings they should not touch, I would love to understand that and know how to put a stop to it. From my perspective, there is no excuse for an upgrade to tell my computer I'm not using the same video card. That is just ridiculous!

I appreciate any help. The sooner the better, as I hope to stay with Sabayon a while longer but am on the verge of moving to another distro. I never had these problems with various Arch builds or Crunchbang. I may as well go Gentoo from scratch if I want this experience. In fact, what little help of benefit I've managed to find for Sabayon has tended to be on Gentoo sites and forums, anyway.

Thanks in advance!

EDIT: Good news and bad news. The good news is I fixed it! :D The bad news is that I have to eat crow :( I fixed it thanks to this: http://wiki.sabayon.org/index.php?title ... in_Sabayon

Post Reply