Booting Sabayon 13.07 results in pitch-black screen [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Booting Sabayon 13.07 results in pitch-black screen [Solved]

Postby Antidieu » Sun Jul 07, 2013 16:54

When booting live session from Sabayon_Linux_13.07_amd64_GNOME, the splash screen doesn't show up, just a blinking cursor, and system ends up with a pitch-black screen as if the monitor was totally dimmed or turned off. I'm able to hear sound from desktop by changing volume with keyboard though. I'm also able to reboot machine with Ctrl+Alt+Del.

Same problem happens with montlhy ISO image Sabayon_Linux_13.06_amd64_GNOME. Only workaround I've found is to press F5 to access advanced options in main menu, then remove video=uvesafb:1024x768,ywrap,mtrr:3 from kernel command line and press Enter to start live session. It seems uvesafb doesn't work because sys-apps/v86d is not installed and you need to install that package before you can use uvesafb.

UPDATE 1: Solution provided by linuxfluesterer here.

UPDATE 2: I tried out release 13.08 and it worked as expected: boot splash screen shows up but still disappears as soon as systemd takes over. I also noticed fonts look a little blurry in this release.
Last edited by Antidieu on Wed Aug 07, 2013 11:15, edited 2 times in total.
Gateway M-6804m (2 GiB RAM)
Intel Core 2 Duo T5250
Intel GM965/GL960
Antidieu
Simple Hen
 
Posts: 68
Joined: Fri Apr 24, 2009 5:45

Re: Booting Sabayon 13.07 results in pitch-black screen

Postby TDKyon » Mon Jul 08, 2013 15:40

I was thinking that I am the only one with this issue. Same thing happens on my computer. I am no longer able to boot with live cd, live usb anymore - the last version that worked for me was 13.04. My computer is 2 years old and it have no uefi bios. Before my screen to become black I see some error regarding plymouth 2.7 or python 2.7, saw the same error when I tried to install fedora 18 few months ago.
Everything was stable with SL 11, all of the problems was created with version 13.04. Don't know what the devs are doing, but I am certain if the things continue to get worse I will switch off from the distro.
TDKyon
Young Hen
 
Posts: 25
Joined: Mon Apr 29, 2013 9:52

Re: Booting Sabayon 13.07 results in pitch-black screen

Postby Stupot » Mon Jul 08, 2013 16:24

You do realize that 13.04 is the latest official release from the Sabayon dev team, right?

These monthly builds get kicked off automatically, without any sort of QA. When the team wants to have a supported release, they do a bunch of QA, make sure things are all working nicely and fix up any problems. At that point, the automatic builds work great and then they are advertised.

Obviously, nobody wants the automatic builds to get broken, but they do. With the current transition of Sabayon supporting systemd, it should be somewhat expected that things get broken more than usual. But they will be fixed before any official release comes out.

If only we could come up with an automatic way to QA like we have for the build system, we'd be golden.
Stupot
Sagely Hen
 
Posts: 1518
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Booting Sabayon 13.07 results in pitch-black screen

Postby TDKyon » Mon Jul 08, 2013 21:00

I got few computers in home and the day when 13.04 came out installed it on one of them and saw that it had issues with automounting, others had different issues. SL 11 was the most solid build, all of the reputation for the stability of Sabayon gone since 13.04. For your computer the releases higher than 11 might work okay, but the rest of us it isn't working okay in comparison to every single distro that I've tried past 2 years on this computer.
With the current transition of Sabayon supporting systemd, it should be somewhat expected that things get broken more than usual. But they will be fixed before any official release comes out.

I am literally pissed off that I have to install firstly SL 11 and then do upgrade on the whole system and it have to download around 700 MB. I'm running SL 11 with systemd,upgraded to the lastest kernel and software, but I am unable to have this in 13.04...becase of issues. Currently running SL 11 with systemd without issues, can you tell me what's wrong with 13.04 and later releases ?

edit: Again, this issue is not comming from systemd,kernel or the software, but the releases and their configuration files.
TDKyon
Young Hen
 
Posts: 25
Joined: Mon Apr 29, 2013 9:52

Re: Booting Sabayon 13.07 results in pitch-black screen

Postby Stupot » Mon Jul 08, 2013 22:23

I thought you had said that 13.04 worked for you. This thread is about 13.07 problems. 13.04 should work great. 13.07, may or may not. 13.04 = officially supported. 13.07 = experimental.

I have a feeling that once systemd stuff is all squared away and the default init systems on the LiveDVDs, that monthly releases should go back to being stable and we'll probably see an official release.
Stupot
Sagely Hen
 
Posts: 1518
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Booting Sabayon 13.07 results in pitch-black screen

Postby Antidieu » Tue Jul 09, 2013 4:59

Stupot wrote:You do realize that 13.04 is the latest official release from the Sabayon dev team, right?

I thought monthly images were supposed to be snapshots of up-to-date 13.04. So what's the point of having experimental monthly builds when you already have daily ones for that matter? Anyway, I'm aware boot splash doesn't work fine with systemd, problem was monitor ended up turning off. I just wanted to post a workaround for those facing similar issues in monthly releases. Although not my case, some people are complaining about problems related to the official release too.
Last edited by Antidieu on Tue Aug 06, 2013 16:23, edited 2 times in total.
Gateway M-6804m (2 GiB RAM)
Intel Core 2 Duo T5250
Intel GM965/GL960
Antidieu
Simple Hen
 
Posts: 68
Joined: Fri Apr 24, 2009 5:45

Re: Booting Sabayon 13.07 results in pitch-black screen

Postby TDKyon » Tue Jul 09, 2013 6:07

Stupot...

13.04 is working but not flawlessly and it's not great. Had to point that all of the problems started with it. How many times do I have to point yout that systemd is not causing these boot & mounting issues ? I told you that I can make stable up to date 11 but can't do that with 13.04, can't boot 13.06 or 13.07. The direction where sabayon goes does not suit me. Want lxnay and others hear my opinion so they can start working and roll backing to 11.

This is my last post here in the forum, if the next release tend to follow 13.04 and above will give up and walk away.
TDKyon
Young Hen
 
Posts: 25
Joined: Mon Apr 29, 2013 9:52

Re: Booting Sabayon 13.07 results in pitch-black screen

Postby lxnay » Tue Jul 09, 2013 14:51

The problem is in your hardware, unfortunately. Basically, uvesafb asks the display to switch to 1024x768 through "video=uvesafb:1024x768". We switched to uvesafb because it's the only generic vesa framebuffer driver that works with plymouth, if you don't want it, just drop the resolution part, including the colon character. I will probably drop the default resolution, but then we would start hearing people complaining about their boot resolution stuck to 640x480.
It's easy to blame us and our work, but we're not paid for doing this nor we're a commercial entity. So please be respectful of the time we dedicate to the project and try to be collaborative. Don't give our support and time for granted.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Booting Sabayon 13.07 results in pitch-black screen

Postby lxnay » Tue Jul 09, 2013 15:43

Out of curiosity, can you try booting with "video=uvesafb:x" (replace the existing video= parameter)
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Booting Sabayon 13.07 results in pitch-black screen

Postby lxnay » Tue Jul 09, 2013 15:55

I switched the ISO images back to video=vesafb, please test as soon as they're on mirrors.
https://github.com/Sabayon/molecules/co ... 9c9db85ba0
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Next

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest