How to go back to openrc? [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Re: How to go back to openrc?

Postby ElDuderino » Sat Jun 29, 2013 16:45

BTW: you mentioned you used 'eselect settingsd set 1', but according to lxnay it's deprecated. I suggested 'eselect sysvinit set 1' for systemd, '2' for openrc. But maybe you made a typo... Anyway, if you had used settingsd, it would have given you an error.
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: How to go back to openrc?

Postby greendave8 » Sun Jun 30, 2013 12:39

I seen your previous post and did

Code: Select all
 eselect settingsd set 1
followed by
Code: Select all
eselect systemd
and rebooted

This worked for me....

gd8
greendave8
Growing Hen
 
Posts: 152
Joined: Thu Aug 02, 2007 12:23

Re: How to go back to openrc?

Postby Provia » Sun Jun 30, 2013 18:23

From my experience using numbers in eselect sysvinit don't work (maybe i'm wrong) i've used
Code: Select all
eselect sysvinit set sysvinit

and
Code: Select all
eselect settingsd set 0
to disable that options (but it seems to be deprecated)
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: How to go back to openrc?

Postby lxnay » Sun Jun 30, 2013 18:26

No need to run eselect settingsd anymore (unless eselect-settingsd is still installed :P)
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: How to go back to openrc?

Postby osoloco » Mon Jul 01, 2013 19:04

After reading your responses, I think that "eselect sysvinit set sysvinit" was enough to go back to openrc, since now I get:

Code: Select all
# eselect sysvinit list
Available init implementations:
  [1]   systemd
  [2]   sysvinit *


And yes, my computer is beahving better than when it was set to systemd.

So I guess this is solved, thanks!
osoloco
Baby Hen
 
Posts: 19
Joined: Thu Oct 18, 2012 8:55

Previous

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron