3.2 - x86-64 and Unreal Tournament 2004 problem [SOLVED]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
teom
Young Hen
Posts: 20
Joined: Sun Dec 24, 2006 1:50
Location: Trieste, Italy

3.2 - x86-64 and Unreal Tournament 2004 problem [SOLVED]

Post by teom » Tue Dec 26, 2006 15:17

Greetings,
Maybe this isn't the best place to ask for help about a game but maybe someone else had this problem too. My specs:
Athlon 64 3500+
1GB ram
GeForce 6800GT + nvidia proprietary drivers
Sabayon 3.2 x86_64 + AIGLX/Beryl working
trying to make Unreal Tournament 2004 work.
So, I installed the game normally and tried to run it. When I call ut2004 the splash screen is shown but when the game tries to show what seems to be the 3D window or rendering area or something like that it kicks me back to the login screen, i'd say that the X server crashes. I've tried this under KDE with and without Beryl and under Fluxbox, with the same result. I'm now going to emerge the new nvidia drivers, but it's going to take a while on my 64k ISDN.
The same UT2004 when installed worked out-of-the-box on Mandriva 2007 on the same hardware.
Please someone help me and if you need more data let me know, I don't exactly know what log files would be useful.
Last edited by teom on Wed Dec 27, 2006 2:29, edited 1 time in total.

Appleman1234
Old Dear Hen
Posts: 964
Joined: Mon Nov 27, 2006 9:48
Location: Land Down Under / Australia
Contact:

Post by Appleman1234 » Wed Dec 27, 2006 2:13

The new nvidia drivers should fix this problem.
Image

teom
Young Hen
Posts: 20
Joined: Sun Dec 24, 2006 1:50
Location: Trieste, Italy

Post by teom » Wed Dec 27, 2006 2:29

Yup the new nvidia drivers did the trick 8)

johnnyhay
Technological Hen
Posts: 304
Joined: Sun Oct 08, 2006 8:54
Location: Google's main DNS

Post by johnnyhay » Wed Dec 27, 2006 6:10

I'm just cursious, but what's your readings for the glxgears test?
Mine is around the 10,000.
Running a ...althon 2600+, 6800gx, with 1.5 GBs of ram.

teom
Young Hen
Posts: 20
Joined: Sun Dec 24, 2006 1:50
Location: Trieste, Italy

Post by teom » Thu Dec 28, 2006 17:12

glxgears gives me 3500-5000 with beryl 0.1.4 running
or 11000-13000 with good old KWin

Post Reply