Automount needs credentials after each boot

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Automount needs credentials after each boot

Postby msdobrescu » Fri Mar 08, 2013 0:18

I've just been blown up my knee today by upgrading to the latest KDE and kernel 3.8.
Now, the disks are mounted on /run/media/<user>/<label>. All my old shortcuts must be upgraded.
But that's not the main issue.
Every reboot asks for root credentials on disk mount. This is SO annoying!
No solution works for my.
I've tried the stuff found here: http://www.sabayon.org/article/argh-udi ... anity-back.
No success...
What changed and how?
fstab is not a solution, as I take out disks from the pc (this means crash at reboot when fstab disks are missing).
How could I avoid this frantic root password request?
msdobrescu
Technological Hen
 
Posts: 421
Joined: Sun Aug 21, 2011 8:48

Re: Automount needs credentials after each boot

Postby wolfden » Fri Mar 08, 2013 12:51

For some that article works and for others it does not, not sure why but 100% way to make it work:

Edit -- /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy

Need to set up the mounts so they read:
ResultAny=yes
ResultInactive=yes
ResultActive=yes
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Automount needs credentials after each boot

Postby msdobrescu » Sat Mar 09, 2013 9:06

Now, I could access the disks as I changed the *udisks2* policies, but it doesn't mount the usb disks. It detects them, but it does nothing. Is this related to the *udisks2* policies?

Wine can't see the mapped drives too, as all the mounted drivers are moved to /run/media/<user>/. Any idea what config to edit?
msdobrescu
Technological Hen
 
Posts: 421
Joined: Sun Aug 21, 2011 8:48

Re: Automount needs credentials after each boot

Postby msdobrescu » Sat Mar 09, 2013 12:47

I have managed to mount without credentials, the inserted disks or usb sticks are recognized, but not if they have ntfs file system. What should be set for that?
msdobrescu
Technological Hen
 
Posts: 421
Joined: Sun Aug 21, 2011 8:48

Re: Automount needs credentials after each boot

Postby msdobrescu » Sat Mar 09, 2013 13:43

So, I presumed it's polkit udisks 2, but it is something else.
I have several usb disks with ntfs, one of them failing to be correctly recognized.

Code: Select all
[ 4120.147794] usb 7-4: new high-speed USB device number 9 using ehci-pci
[ 4120.263258] usb 7-4: New USB device found, idVendor=14cd, idProduct=6116
[ 4120.263264] usb 7-4: New USB device strings: Mfr=1, Product=3, SerialNumber=2
[ 4120.263268] usb 7-4: Product: USB 2.0  SATA BRIDGE   
[ 4120.263272] usb 7-4: Manufacturer: Super Top   
[ 4120.263275] usb 7-4: SerialNumber: M6116018VF16
[ 4120.263786] scsi17 : usb-storage 7-4:1.0
[ 4142.128484] ASC=0x11 ASCQ=0x0
[ 4142.128487] sd 17:0:0:0: [sdi] CDB:
[ 4142.128489] cdb[0]=0x28: 28 00 00 00 08 00 00 00 08 00
[ 4142.153482] sd 17:0:0:0: [sdi] Unhandled sense code
[ 4142.153488] sd 17:0:0:0: [sdi] 
[ 4142.153490] Result: hostbyte=0x00 driverbyte=0x08
[ 4142.153493] sd 17:0:0:0: [sdi] 
[ 4142.153495] Sense Key : 0x3 [current]
[ 4142.153500] sd 17:0:0:0: [sdi] 
...
msdobrescu
Technological Hen
 
Posts: 421
Joined: Sun Aug 21, 2011 8:48

Re: Automount needs credentials after each boot

Postby msdobrescu » Sat Mar 09, 2013 13:52

gparted displays "/dev/sdi: unrecognised disk label" and sees unallocated space.
Windows 7 64 bit recognizes the disk and a check reveals no issues.
Could it be something from the kernel 3.8 (on 3.6 worked)?
msdobrescu
Technological Hen
 
Posts: 421
Joined: Sun Aug 21, 2011 8:48

Re: Automount needs credentials after each boot

Postby msdobrescu » Sat Mar 09, 2013 14:36

Hello,

I've found this: https://bbs.archlinux.org/viewtopic.php?pid=1189026
Is here anybody knowing about this stuff?

Thank you.
msdobrescu
Technological Hen
 
Posts: 421
Joined: Sun Aug 21, 2011 8:48

Re: Automount needs credentials after each boot

Postby dentman » Sun Mar 10, 2013 7:01

I'm in this holy hell with you! What a mess. This is what makes me want to run away from Sabayon.
dentman
Baby Hen
 
Posts: 9
Joined: Wed Aug 15, 2012 17:58

Re: Automount needs credentials after each boot

Postby msdobrescu » Sun Mar 10, 2013 8:19

Don't blame Sabayon for this.

The KDE team does this from time to time, the udisks2 seem to be designed for Gnome and hard to be implemented for others, the hardware in discussion here has buggy implementation in the new kernel that corrupts the data, leading to disabling it for now, which is better than losing the data, and the new philosophy of mounting in /run/media/<user> is a solution to the right management... don't know if this is from kde ot kernel or both.

I think that from time to time things are better to be reimplemented than live with badly designed code that make sprocesses slow and greedy with the resources, and development a hell. This is evolutuion and that's one reason I wanted to work on a rolling relased distro.

For now, having to set many entries to "Yes" in the udisks2 policy file, makes it useless.

Is there a script to override the entries when an update will set back the file?

Thank you.
msdobrescu
Technological Hen
 
Posts: 421
Joined: Sun Aug 21, 2011 8:48

Re: Automount needs credentials after each boot

Postby wolfden » Tue Mar 12, 2013 11:23

Interesting, so your usb drives are getting corrupted? Is that what I am understanding?

Looks like it all started here:
https://plus.google.com/u/0/11077347414 ... qPUifsFUYH

and of course many are blaming Lennart too - http://cgit.freedesktop.org/systemd/sys ... 6f8c6971fa

I guess I don't mess with USB drives that much so not aware of issues. I just hated the friggin authorization prompt to view my other drives. Editing the policy file has solved that issue for me. I'm not having any issue accessing my drives/partitions. I do have a 1TB drive plugged into a docking station via USB and that works fine, but I can't remember off the top of my head what file system it is. I assume it's ntfs. All my usb flash drives are fat32.

equo conf update should give you the option to write or not. I just tell equo not to and delete it.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Next

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron