webcam not working after the update [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
gocool
Growing Hen
Posts: 173
Joined: Wed Aug 06, 2008 13:37

webcam not working after the update [Solved]

Post by gocool » Sun Feb 10, 2013 1:45

I have the sabayon current.

After I did the update my webcam stopped working. I tried Skype as well as google hangout.

This was working before.

I have no clue where to start in the first place. Any help would be highly appreciated.

thx
gocool
Last edited by gocool on Mon Feb 25, 2013 1:29, edited 1 time in total.

User avatar
linuxfluesterer
Old Dear Hen
Posts: 863
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: webcam not working after the update

Post by linuxfluesterer » Sun Feb 10, 2013 12:33

Do you have an external (old) USB webcam?
Then you could connect it and make a new try in skype.
Attention, in Skype you must select this cam in Options, video settings.
And... can you try Kopete (if you have KDE),
or 'cheese' which can work in different DEs, Gnome, KDE...?
Both are programs, which use webcams.
Good luck,

-Linuxfluesterer (I love KDE ...)
Take away Facebook from me and let there be real people again...

Superdonk
Baby Hen
Posts: 11
Joined: Sun Apr 15, 2012 1:51

Re: webcam not working after the update

Post by Superdonk » Sun Feb 10, 2013 15:04

I had this problem, all I did was unplug the webcam then reconnect it, Skype then detected it again with no issues. (sorry if you've tried this already, but sometimes I forget the 'obvious')

User avatar
linuxfluesterer
Old Dear Hen
Posts: 863
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: webcam not working after the update

Post by linuxfluesterer » Sun Feb 10, 2013 18:25

It would be great, you'd mark your thread as [Solved].
Thank you,

-Linuxfluesterer (I love KDE ...)
Take away Facebook from me and let there be real people again...

svantoviit
Old Dear Hen
Posts: 724
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: webcam not working after the update

Post by svantoviit » Mon Feb 11, 2013 15:11

@linuxfluesterer: Superdonk != gocool ;)

gocool, could you provide some more info f.ex. lsusb, dmesg, /var/log/messages…?
"my webcam stopped working" is a very vague description of a problem.

gocool
Growing Hen
Posts: 173
Joined: Wed Aug 06, 2008 13:37

Re: webcam not working after the update

Post by gocool » Tue Feb 12, 2013 4:01

@linuxfluesterer : No I don't have another external webcam handy, mine is an integrated webcam.
@Superdonk : It's not an external webcam. Thank you for the response though, much appreciated.

@svantoviit : Here's the details....sorry about it..

Code: Select all

[email protected] ~ $ lsusb
Bus 001 Device 002: ID 046d:09b0 Logitech, Inc. Acer OrbiCam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
My entier dmesg is is found here : https://pastebin.sabayon.org/pastie/11986

Do you want me to grep the /var/log/messages by any particular keyword...please do let me know and I'll provide it.

Thank you again for your time.

svantoviit
Old Dear Hen
Posts: 724
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: webcam not working after the update

Post by svantoviit » Tue Feb 12, 2013 10:02

OK, the cam is there…

Code: Select all

[   23.304886] Linux video capture interface: v2.00
[   24.498173] uvcvideo: Found UVC 1.00 device <unnamed> (046d:09b0)
[   24.504563] input: UVC Camera (046d:09b0) as /devices/pci0000:00/0000:00:1d.7/usb1/1-4/1-4:1.0/input/input12
[   24.504787] usbcore: registered new interface driver uvcvideo
[   24.504792] USB Video Class driver (1.1.1)

Code: Select all

Bus 001 Device 002: ID 046d:09b0 Logitech, Inc. Acer OrbiCam
gocool wrote:Do you want me to grep the /var/log/messages by any particular keyword…
Look for cam, webcam, the vendor (046d) or product ID (09b0) and eventually for any related errors and warnings.

You could check, if the driver is loaded, should be uvcvideo and fully support your webcam

Code: Select all

lsmod | grep uvc
Just to be sure, are you (your user) in the video group?

Code: Select all

groups
Another thing to check, if the permissions of /dev/video are set properly

Code: Select all

ls -l /dev/vid*
crw-rw---- 1 root video 81, 0 Feb 11 08:36 /dev/video0

gocool
Growing Hen
Posts: 173
Joined: Wed Aug 06, 2008 13:37

Re: webcam not working after the update [SOLVED]

Post by gocool » Mon Feb 25, 2013 1:27

Thank you svantoviit.

It's working now. But I did not do anything, just went ahead with updating the system blindly with all the updates as it gets pushed through.

I keep getting this issue when there is a major upgrade...I should keep an eye on it I guess.

I'll bookmark this post to resolve such issues in the future.

Regards,
gocool


Post Reply