Can I delete the kernel 3.5.0?

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Can I delete the kernel 3.5.0?

Postby ocheung » Mon Jan 07, 2013 5:22

In my computer now, has kernel-3.5.0/3.6.0/3.7.0.
I want to delete kernel 3.5.0. 3.6.0 for backup, 3.7.0 for use.
But I have a doubt with zf3#3.5.0-sabayon.
Code: Select all
@@ Package: app-emulation/virtualbox-guest-additions-4.2.0#3.5.0-sabayon branch: 5, [__system__]
@@ Package: app-laptop/nvidiabl-0.79#3.5.0-sabayon branch: 5, [__system__]
@@ Package: net-wireless/broadcom-sta-5.100.82.112-r2#3.5.0-sabayon branch: 5, [__system__]
@@ Package: net-wireless/ndiswrapper-1.58_rc1#3.5.0-sabayon branch: 5, [__system__]
@@ Package: sys-fs/zfs-20120903#3.5.0-sabayon branch: 5, [__system__]
@@ Package: x11-drivers/nvidia-drivers-304.64#3.5.0-sabayon branch: 5, [__system__]
@@ Package: x11-drivers/xf86-video-virtualbox-4.2.0#3.5.0-sabayon branch: 5, [__system__]

That is depend package for upgrade kernel. Since kernel3.6.0 , the zfs package donesn't can install with
Code: Select all
equo install --ask zfs#3.6.0-sabayon


After kernel 3.5.0 don't need zfs package? I'm afraid when I delete kernel 3.5.0 , the system can't start.

Code: Select all
origin* ~ >| eselect bzimage list
Available kernel targets:
  [1]   kernel-genkernel-x86_64-3.5.0-sabayon
  [2]   kernel-genkernel-x86_64-3.6.0-sabayon
  [3]   kernel-genkernel-x86_64-3.7.0-sabayon *
origin* ~ >| eselect kernel list
Available kernel symlink targets:
  [1]   linux-3.5.0-sabayon
  [2]   linux-3.6.0-sabayon
  [3]   linux-3.7.0-sabayon *


So, can I delete ?


THX!!!
ocheung
Baby Hen
 
Posts: 9
Joined: Wed Jan 02, 2013 15:47

Re: Can I delete the kernel 3.5.0?

Postby svantoviit » Mon Jan 07, 2013 11:29

The question is, do you use the ZFS file system?
Probably you'll be fine with the sys-fs/zfs-userspace package anyway.

I'm running the 3.7 kernel and don't have ZFS installed.
svantoviit
Old Dear Hen
 
Posts: 649
Joined: Sun Feb 28, 2010 17:55

Re: Can I delete the kernel 3.5.0?

Postby ocheung » Wed Jan 09, 2013 3:22

svantoviit wrote:The question is, do you use the ZFS file system?
Probably you'll be fine with the sys-fs/zfs-userspace package anyway.

I'm running the 3.7 kernel and don't have ZFS installed.


Ok, I knew it. I don't use ZFS file system. Use ext4 file system.
At first I thought zfs is use with linux-sabayon kernel.
Now, I knew ZFS is a unnecessary package for my system.

THX......
ocheung
Baby Hen
 
Posts: 9
Joined: Wed Jan 02, 2013 15:47


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron