locale error - gtk &LC_ALL=en_US.UTF-8 [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

locale error - gtk &LC_ALL=en_US.UTF-8 [Solved]

Postby Jago25_98 » Mon Nov 26, 2012 21:45

I'm still getting that locale error which should have been fixed by exporting to profile (have run source /etc/profile)

Besides... I need a UK locale really.

Belated bug:

Code: Select all
[email protected] ~ $ autokey-gtk-2.7

(process:19016): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.
ERROR:root:Could not find any typelib for AppIndicator3
Traceback (most recent call last):
  File "/usr/bin/autokey-gtk-2.7", line 20, in <module>
    from autokey.gtkapp import Application
  File "/usr/lib64/python2.7/site-packages/autokey/gtkapp.py", line 31, in <module>
    from gtkui.configwindow import ConfigWindow
  File "/usr/lib64/python2.7/site-packages/autokey/gtkui/configwindow.py", line 27, in <module>
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib64/python2.7/locale.py", line 539, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
[email protected] ~ $ update-locale: command not found
bash: update-locale:: command not found
[email protected] ~ $ LC_ALL=en_US.UTF-8 autokey-gtk-2.7

(process:19024): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
ERROR:root:Could not find any typelib for AppIndicator3
Traceback (most recent call last):
  File "/usr/bin/autokey-gtk-2.7", line 20, in <module>
    from autokey.gtkapp import Application
  File "/usr/lib64/python2.7/site-packages/autokey/gtkapp.py", line 31, in <module>
    from gtkui.configwindow import ConfigWindow
  File "/usr/lib64/python2.7/site-packages/autokey/gtkui/configwindow.py", line 27, in <module>
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib64/python2.7/locale.py", line 539, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
[email protected] ~ $ locale-gen en_US.UTF-8
bash: locale-gen: command not found
[email protected] ~ $ sudo locale-gen en_US.UTF-8
Password:
Usage: locale-gen [options] -- [localedef options]

Generate locales based upon the config file /etc/locale.gen.

Options:
    -k, --keep               Don't nuke existing locales
    -d, --destdir <dir>      Use locale data in specified DESTDIR tree
    -c, --config <config>    Use specified config instead of default locale.gen
    -l, --list               List all the locales to be generated
    -a, --ask                Ask before generating each locale
    -A, --all                Pretend the locale list contains all locales
    -u, --update             Only generate locales that are missing
    -G, --generate <locale>  Generate specified locale (one shot; implies -k -u)
    -j, --jobs <num>         Number of locales to generate at a time (parallel)
    -q, --quiet              Only show errors
    -V, --version            Meaningless version information
    -h, --help               Show this help cruft

Localedef Options:
    By default, -c is passed to localedef.

For more info, see the locale-gen(1) and locale.gen(8) manpages.

 * Unknown option 'en_US.UTF-8'
[email protected] ~ $ sudo locale-gen -- en_US.UTF-8
 * Generating 4 locales (this might take a while) with 1 jobs
 *  (1/4) Generating en_US.UTF-8 ...Try `localedef --help' or `localedef --usage' for more information.
 [ !! ]
 *  (2/4) Generating en_US.ISO-8859-1 ...Try `localedef --help' or `localedef --usage' for more information.
 [ !! ]
 *  (3/4) Generating en_US.UTF-8 ...Try `localedef --help' or `localedef --usage' for more information.
 [ !! ]
 *  (4/4) Generating en_US.ISO-8859-1 ...Try `localedef --help' or `localedef --usage' for more information.
 [ !! ]
 * Generation complete
[email protected] ~ $ LC_ALL=en_US.UTF-8 autokey-gtk-2.7

(process:19253): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
ERROR:root:Could not find any typelib for AppIndicator3
Traceback (most recent call last):
  File "/usr/bin/autokey-gtk-2.7", line 20, in <module>
    from autokey.gtkapp import Application
  File "/usr/lib64/python2.7/site-packages/autokey/gtkapp.py", line 31, in <module>
    from gtkui.configwindow import ConfigWindow
  File "/usr/lib64/python2.7/site-packages/autokey/gtkui/configwindow.py", line 27, in <module>
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib64/python2.7/locale.py", line 539, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
[email protected] ~ $


Code: Select all
[email protected] /etc/env.d $ cat 02locale
LANG="en_US.UTF-8"
SYSFONT="LatArCyrHeb-16"
[email protected] /etc/env.d $

Code: Select all
[email protected] /etc/env.d $ grep UTF-8 /usr/share/i18n/SUPPORTED |grep GB
cy_GB.UTF-8 UTF-8
en_GB.UTF-8 UTF-8
gd_GB.UTF-8 UTF-8
gv_GB.UTF-8 UTF-8
kw_GB.UTF-8 UTF-8
[email protected] /etc/env.d $

Code: Select all
equo --version
invalid filesystem encoding ANSI_X3.4-1968, must be UTF-8.
Make sure to set LC_ALL, LANG, LANGUAGE to valid UTF-8 values.
Please execute:
  LC_ALL=en_US.UTF-8 /usr/bin/equo
Cannot automatically recover from this.


This is 32bit version. I will have to type "LC_ALL=en_US.UTF-8 " everytime I want to run equo and the autokey program won't work?
Last edited by Jago25_98 on Tue Nov 27, 2012 15:37, edited 1 time in total.
Everytime someone helps me I give $5 to Sabayon. Hopefully this will speed up equo bandwidth. If someone has helped you, why not say thanks and donate to speed it up for all :-)
Jago25_98
Young Hen
 
Posts: 21
Joined: Sun Nov 20, 2011 22:18

Re: locale error - gtk &LC_ALL=en_US.UTF-8 equo search "Pack

Postby Fitzcarraldo » Mon Nov 26, 2012 23:46

Follow all the steps in the post Re: en_GB language missing after install. and that should hopefully straighten it out. (You might need to add LC_ALL="en_GB.UTF-8" to the end of the list in Step 3, but try without first.)

See also Issue with equo/sulfur since recent update and locale en_gb.utf-8 error after kde upgrade [Solved].
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: locale error - gtk &LC_ALL=en_US.UTF-8 equo search "Pack

Postby Jago25_98 » Tue Nov 27, 2012 12:51

Thanks!

How did I miss those threads I don't know, not for want of trying I assue you.

$5 donated to Sabayon in your honour :-)
Everytime someone helps me I give $5 to Sabayon. Hopefully this will speed up equo bandwidth. If someone has helped you, why not say thanks and donate to speed it up for all :-)
Jago25_98
Young Hen
 
Posts: 21
Joined: Sun Nov 20, 2011 22:18


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron