gdm won't start after upgrade

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

gdm won't start after upgrade

Postby mdmarmer » Sat Aug 06, 2011 21:04

gdm won't start after upgrade

error is:
Setting up gdm ...
process 6301: arguments to dbus_connection_ref() were incorrect, assertion "connection !=NULL" failed in file /var/tmp/portage/sys-apps/dbus-1.4.12/work/dbus-1.4.12/dbus/dbus-connection.c line 2626.
This is normally a bug in some application in some application using the D-Bus library.
D-Bus not built with -rdynamic so unable to print a backtrace
* start-stop-daemon: failed to start /usr/bin/gdm
* ERROR: could not start the Display Manager
mdmarmer
Advanced Hen
 
Posts: 240
Joined: Thu Oct 19, 2006 1:46
Location: dayton OH usa

Re: gdm won't start after upgrade

Postby kitsios » Sat Aug 06, 2011 21:33

I have the exact same problem. Can anyone help?
kitsios
Baby Hen
 
Posts: 11
Joined: Sun Mar 13, 2011 16:04

Re: gdm won't start after upgrade

Postby amitvn » Sat Aug 06, 2011 22:33

try this one(as root):
Code: Select all
equo update
equo install dbus-glib
Love Sabayon <3
amitvn
Simple Hen
 
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: gdm won't start after upgrade

Postby kitsios » Sun Aug 07, 2011 11:42

Unfortunately it didn't help much. Now I'm stuck in an infinite loop with the NVIDIA driver logo and a blank screen.
kitsios
Baby Hen
 
Posts: 11
Joined: Sun Mar 13, 2011 16:04

Re: gdm won't start after upgrade

Postby gosport_gaz » Sun Aug 07, 2011 15:15

Hi
I've got the same.
I have reinstalled Sabayon 5.5 and carried out the the upgrade again, but this time I've not yet restarted.
The progress terminal in Entropy is littered with this message for various programs (over 170):
Traceback (most recent call last):

File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 2231, in _pkg_foorm

header = red(" ## ")

File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 1985, in _portage_doebuild

myroot = os.path.sep

File "/usr/lib/portage/pym/portage/package/ebuild/doebuild.py", line 577, in doebuild

use_cache, mydbapi)

File "/usr/lib/portage/pym/portage/package/ebuild/doebuild.py", line 313, in doebuild_environment

["SRC_URI"], mytree=mytree)

TypeError: aux_get() got an unexpected keyword argument 'mytree'

## QA: Cannot run Source Package Manager trigger for x11-drivers/xf86-video-neomagic-1.2.5.
## Please report it. Attach this: /var/log/entropy/spm.log [postrm]
>>> Regenerating /etc/ld.so.cache...
## SPM: post-install phase
Traceback (most recent call last):

File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 2139, in _pkg_fooinst



File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 2117, in _pkg_setup



File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 1985, in _portage_doebuild

myroot = os.path.sep

File "/usr/lib/portage/pym/portage/package/ebuild/doebuild.py", line 577, in doebuild

use_cache, mydbapi)

File "/usr/lib/portage/pym/portage/package/ebuild/doebuild.py", line 313, in doebuild_environment

["SRC_URI"], mytree=mytree)

TypeError: aux_get() got an unexpected keyword argument 'mytree'

## QA: Cannot run Source Package Manager trigger for x11-drivers/xf86-video-neomagic-1.2.5.
## Please report it. Attach this: /var/log/entropy/spm.log [postinst]


Unfortunately I seem to have lost the file manager and gnome menu, so I can't copy the log files, in fact it seems that I have an incomplete gnome 3, having lost Gnome 2.

If you can tell me how to get these logs I'll try and attach them. I'll leave Firefox open in the mean time.
gosport_gaz
Young Hen
 
Posts: 31
Joined: Sat Jul 10, 2010 11:08

Re: gdm won't start after upgrade

Postby gosport_gaz » Sun Aug 07, 2011 16:00

I've got the log now but Its too long to post; should I post this as a bug?
gosport_gaz
Young Hen
 
Posts: 31
Joined: Sat Jul 10, 2010 11:08

Re: gdm won't start after upgrade

Postby amitvn » Sun Aug 07, 2011 17:04

@gosport_gaz
use pastebin to paste the log http://pastebin.sabayon.org/
Love Sabayon <3
amitvn
Simple Hen
 
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: gdm won't start after upgrade

Postby gosport_gaz » Sun Aug 07, 2011 17:14

I've posted it just now.
Gaz
gosport_gaz
Young Hen
 
Posts: 31
Joined: Sat Jul 10, 2010 11:08

Re: gdm won't start after upgrade

Postby amitvn » Sun Aug 07, 2011 17:21

I've posted it just now.
Gaz

how will some person know where is it?
paste the link of that pastebin
Love Sabayon <3
amitvn
Simple Hen
 
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: gdm won't start after upgrade

Postby mdmarmer » Sun Aug 07, 2011 20:26

@kitsios -- i think my problem was more complex and i had to do several things to solve it, but, as you said, equo install dbus-glib did not solve it. This should get you closer
emerge --sync
emerge dbus-glib

Mike
mdmarmer
Advanced Hen
 
Posts: 240
Joined: Thu Oct 19, 2006 1:46
Location: dayton OH usa

Next

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest