Beryl questions

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Beryl questions

Postby SteveyDevey » Sun Dec 03, 2006 21:45

I installed 3.2 on my desktop after trying it and really liking it.

When using the live disc, Beryl started up and ran fine (though I didn't know how to control it well).

When I installed it, it did not ask me which acceleration to use, AIGLX or XGL, and beryl did not start automatically. I got it running, but just thought it was odd.

I've got a few issues/questions though.

Firstly, I run a dual monitor setup and I'd like to be pointed to good information on making it run on both monitors. I'm running AIGLX right now, so I'm under the impression that it should be possible.

Also, there seems to be a problem with something I'm doing, or there's a bug/incompatibility. In the beryl configuration panel (that lives on the desktop), when I go to the Desktop Panel (instead of Desktop Cube) all of the window title bars, decorations, and controls just disappear. I also lose the ability to control them through KDE/Gnome/etc.

Is that something others have experienced?
SteveyDevey
Baby Hen
 
Posts: 8
Joined: Thu Nov 30, 2006 3:54

Postby cvill64 » Sun Dec 03, 2006 22:29

yes, that's a bug, usually you have to restart beryl-manager and reload beryl again, or sometimes try removing ~/.beryl and restarting beryl helps

for dual monitor, here's mine with nvidia/aiglx combination that works through two vga slots

Code: Select all
Section "Module"

# This loads the DBE extension module.

   Load        "dbe"   # Double buffer extension
   Load         "extmod"

# This loads the Type1 and FreeType font modules
    Load        "type1"
    Load        "freetype"


# This loads the GLX module
    Load       "glx"


EndSection

# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"


#    FontPath   "unix/:-1"

#    FontPath   "/usr/share/fonts/freefont"
#    FontPath   "/usr/share/fonts/sharefonts"
#   FontPath    "/usr/local/share/fonts"

    FontPath    "/usr/share/fonts/misc:unscaled"
    FontPath    "/usr/share/fonts/local"
    FontPath    "/usr/share/fonts/Type1"
    FontPath    "/usr/share/fonts/TTF"
    FontPath    "/usr/share/fonts/corefonts"
    FontPath    "/usr/share/fonts/ttf-bitstream-vera"
    FontPath    "/usr/share/fonts/75dpi:unscaled"
    FontPath    "/usr/share/fonts/100dpi:unscaled"
    FontPath    "/usr/local/share/fonts"
EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

 Option "Xinerama" "off"
 Option "AIGLX" "true"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier "Keyboard1"
    Driver "kbd"
    Option "AutoRepeat" "500 30"

    Option "XkbModel" "xorg"
    Option "XkbLayout" "us"

EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

  Identifier    "Mouse1"
  Driver        "mouse"
  Option        "Protocol"      "IMPS/2"
  Option        "ZAxisMapping"  "4 5"
  Option        "Device"        "/dev/psaux"

EndSection


# **********************************************************************
# Monitor section
# **********************************************************************


Section "Monitor"

    Identifier  "My Monitor"
    HorizSync   31.5 - 105
    VertRefresh 60 - 75
    Option      "DPMS"
EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

Section "Device"
    Identifier  "Dispositivo1"
    Driver      "nvidia"
    BusID       "PCI:1:0:0"
    Screen      0
    #Option "IgnoreEDID" "true"
    #Option "AllowGLXWithComposite" "true"
    Option "RenderAccel" "1"
    Option "NoLogo" "On"
    Option "TwinView" "true"
    #Option "MetaModes"                "1440x900,1440x900"
    Option "MetaModes"                "1440x900,1440x900; 1024x768,1024x768"
    Option "HorizSync"                "CRT-0: 31.5-105; CRT-1: 31.5-105"
    Option "VertRefresh"              "CRT-0: 60-75; CRT-1: 60-75"
    Option "ConnectedMonitor"         "CRT-0,CRT-1"
    Option "IgnoreDisplayDevices"     "TV-0"
    Option "TwinViewOrientation"      "RightOf"
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************


Section "Screen"
    Identifier  "Screen1"
    Device      "Dispositivo1"
    Monitor     "My Monitor"
    DefaultDepth 24
    Option "AddARGBGLXVisuals" "true"

    Subsection "Display"
        Depth       8
        Modes       "1440x900" "1024x768"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1440x900" "1024x768"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1440x900" "1024x768"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
 Identifier     "Normal"
 Screen         "Screen1"
 InputDevice    "Mouse1"         "CorePointer"
 InputDevice    "Keyboard1"      "CoreKeyboard"
 Option         "Xinerama"       "off"
 Option         "Clone"          "off"
# Option         "AIGLX"          "true"
EndSection

Section "Extensions"

        Option "Composite" "Enable"
#       Option "RENDER" "Enable"
#       Option "DAMAGE" "true"

EndSection
cvill64
Sagely Hen
 
Posts: 2185
Joined: Fri Dec 30, 2005 10:03
Location: Virginia, USA

Postby enervation » Thu Dec 07, 2006 13:20

cvill64 wrote:yes, that's a bug, usually you have to restart beryl-manager and reload beryl again, or sometimes try removing ~/.beryl and restarting beryl helps


Sorry, I have been looking around loads of places, and I can't find any kind of step-by-step instructions on how to do this. I'm having the same problem - worked fine on liveDVD, doesn't work once installed. I've found the acceleration settings applet thing and selected AIGLX. It seems that it's just Beryl that is not working.

I know how to get to the terminal - could you give me something to type in to restart & reload beryl please?

Also, I don't currently have the internet working in Sabayon so I can't emerge off the internet or anything like that.

Thanks in advance to anyone willing to help :D

PS if it makes any difference, using most recent version of x86 sabayon and Nvidia Geforce fx5900 card
enervation
Baby Hen
 
Posts: 1
Joined: Thu Dec 07, 2006 13:15

Postby lxnay » Thu Dec 07, 2006 14:07

beryl-settings is still quite buggy sometimes.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest