Going Fullscreen in Vmware-Server

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Going Fullscreen in Vmware-Server

Postby Square Bottle » Fri Dec 01, 2006 9:19

Is anybody else having trouble going fullscreen with vmware-server? This may or may not be just a 64-bit edition issue.

Unable to find an appropriate host video mode.
Adding the guest mode to the 'display' subsection of the 'screen' section of your /etc/X11/XF86Config and restarting X is likely to help.

Failed to switch to full screen mode.


And of course, the file it's talking about doesn't even exist to begin with though, which leads me to believe that this is not just a 64-bit thing.

Any thoughts?
My soul hurts. Please read what happened. It hurts, and nothing will happen. Perhaps they will try to soothe their conscience by removing this from my signature, so read it, and talk about it.
Square Bottle
Growing Hen
 
Posts: 106
Joined: Wed Oct 11, 2006 6:57
Location: San Diego, CA

Postby janstedehouder » Mon Dec 11, 2006 17:20

No, it isn't solely a 64-bit issue. I had the problem with VMware as well and it was solved after I installed the proper nvidia drivers and changed the corresponding section in xorg.conf. By default it does not use the proprietary driver and that one will not allow VMware to use the max screen.

The driver in section Device should be nvidia instead of nv

Code: Select all
Section "Device"
   Identifier   "NVIDIA Corporation NV40? [Unknown nVidia Card]"
   Driver      "nvidia"
   BusID      "PCI:1:0:0"
EndSection


Now, I don't know if you have a nvidia card or another one, but this would be good place to start.

Another issue I had was with Neverwinter Nights while have desktop acceleration enabled.
janstedehouder
Baby Hen
 
Posts: 3
Joined: Sat Nov 25, 2006 18:23

Postby lxnay » Mon Dec 11, 2006 17:23

It's because adding "Modes"-lines to xorg.conf is not needed anymore. Just open your xorg.conf, find lines starting with Modes and remove the "#". Then, add, following the actual lines, your current resolution.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Quick Fix for XP

Postby spunknibbles » Thu Dec 14, 2006 1:34

Edit the .vmx file for the WinXP virtual machine and add the following lines:

Code: Select all
svga.maxWidth = "xxxx"
svga.maxHeight = "xxxx"

Of course, where xxxx is your resolution. So if you have 1280x800 it would be:
svga.maxWidth = "1280"
svga.maxHeight = "800"


Then hit the fullscreen, and in the window change your desktop properties to your new resolution that is now available.
Image
"Art is only limited by creativity."
User avatar
spunknibbles
Simple Hen
 
Posts: 43
Joined: Sat Dec 02, 2006 1:33
Location: Tyler, TX

Postby rpa3133 » Thu Dec 14, 2006 4:05

If you add the following line:

gui.FullScreenAtPowerOn = "TRUE"

to "*.vmx" file will give you full screen.

But when you come out by pressing "ALT+CTRL" and then go back again it switches back to window.
rpa3133
Young Hen
 
Posts: 22
Joined: Sun Nov 26, 2006 4:20
Location: USA


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron