S_Amd64_5.5Gnome on Sony VAIO CG ATI

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
jaguar1637
Simple Hen
Posts: 62
Joined: Sun Jul 26, 2009 9:11
Location: Toulouse - France

S_Amd64_5.5Gnome on Sony VAIO CG ATI

Post by jaguar1637 » Sat Feb 12, 2011 18:12

Hi

Well, I tried to install the last Sabayon 5.5 Amd_64 on a Sony VAIO VPCEF3E1E.
This computer got an ATI Mobility RAdeaon HD 4200 series (yep, it's a cheap computer)

I tried several xorg.conf for VESA. I tried the command X-configure and so on, w/o any success. Is it possible to someone to help me in this case

Is there another way or maybe a fbdev configuration file ?

TIA
_________________________________________________________________________
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
### <percent>: "<f>%"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "DefaultRefresh" # [<bool>]
#Option "ModeSetClearScreen" # [<bool>]
Identifier "Card0"
Driver "vesa"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

_________________________________________________________________________

ENd of the log
_____________________________________________________________________
[ 1498.544] (II) VESA(0): Total Memory: 256 64KB banks (16384kB)
[ 1498.544] (II) VESA(0): Monitor0: Using hsync value of 55.56 kHz
[ 1498.544] (II) VESA(0): Monitor0: Using vrefresh value of 60.00 Hz
[ 1498.544] (WW) VESA(0): Unable to estimate virtual size
[ 1498.544] (II) VESA(0): Not using built-in mode "1152x864" (no mode of this name)
[ 1498.544] (II) VESA(0): Not using built-in mode "1024x768" (no mode of this name)
[ 1498.544] (II) VESA(0): Not using built-in mode "800x600" (no mode of this name)
[ 1498.544] (II) VESA(0): Not using built-in mode "640x480" (no mode of this name)
[ 1498.544] (II) VESA(0): Not using built-in mode "720x400" (no mode of this name)
[ 1498.544] (II) VESA(0): Not using built-in mode "640x350" (no mode of this name)
[ 1498.544] (II) VESA(0): Not using built-in mode "512x384" (no mode of this name)
[ 1498.544] (II) VESA(0): Not using built-in mode "320x240" (no mode of this name)
[ 1498.544] (II) VESA(0): Not using built-in mode "320x200" (no mode of this name)
[ 1498.544] (WW) VESA(0): No valid modes left. Trying less strict filter...
[ 1498.544] (II) VESA(0): Monitor0: Using hsync value of 55.56 kHz
[ 1498.544] (II) VESA(0): Monitor0: Using vrefresh value of 60.00 Hz
[ 1498.544] (WW) VESA(0): Unable to estimate virtual size
[ 1498.544] (II) VESA(0): Not using built-in mode "1152x864" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "1024x768" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "800x600" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "640x480" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "720x400" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "640x350" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "512x384" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "320x240" (illegal horizontal timings)
[ 1498.544] (II) VESA(0): Not using built-in mode "320x200" (illegal horizontal timings)
[ 1498.544] (WW) VESA(0): No valid modes left. Trying aggressive sync range...
[ 1498.544] (II) VESA(0): Monitor0: Using hsync range of 31.50-55.56 kHz
[ 1498.544] (II) VESA(0): Monitor0: Using vrefresh range of 50.00-60.00 Hz
[ 1498.544] (WW) VESA(0): Unable to estimate virtual size
[ 1498.544] (II) VESA(0): Not using built-in mode "640x480" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "720x400" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "640x350" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "512x384" (hsync out of range)
[ 1498.544] (II) VESA(0): Not using built-in mode "320x240" (illegal horizontal timings)
[ 1498.544] (II) VESA(0): Not using built-in mode "320x200" (illegal horizontal timings)
[ 1498.544] (--) VESA(0): Virtual size is 1152x864 (pitch 1152)
[ 1498.544] (**) VESA(0): *Built-in mode "1152x864"
[ 1498.544] (**) VESA(0): *Built-in mode "1024x768"
[ 1498.544] (**) VESA(0): *Built-in mode "800x600"
[ 1498.544] (**) VESA(0): Display dimensions: (380, 210) mm
[ 1498.544] (**) VESA(0): DPI set to (77, 104)
[ 1498.544] (II) VESA(0): Attempting to use 60Hz refresh for mode "1024x768" (123)
[ 1498.545] (II) VESA(0): Attempting to use 60Hz refresh for mode "800x600" (122)
[ 1498.545] (**) VESA(0): Using "Shadow Framebuffer"
[ 1498.545] (II) Loading sub module "shadow"
[ 1498.545] (II) LoadModule: "shadow"
[ 1498.545] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[ 1498.545] (II) Module shadow: vendor="X.Org Foundation"
[ 1498.545] compiled for 1.9.3, module version = 1.1.0
[ 1498.545] ABI class: X.Org ANSI C Emulation, version 0.4
[ 1498.545] (II) Loading sub module "fb"
[ 1498.545] (II) LoadModule: "fb"
[ 1498.546] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 1498.546] (II) Module fb: vendor="X.Org Foundation"
[ 1498.546] compiled for 1.9.3, module version = 1.0.0
[ 1498.546] ABI class: X.Org ANSI C Emulation, version 0.4
[ 1498.546] (==) Depth 24 pixmap format is 32 bpp
[ 1498.546] (II) Loading sub module "int10"
[ 1498.546] (II) LoadModule: "int10"
[ 1498.547] (II) Reloading /usr/lib64/xorg/modules/libint10.so
[ 1498.547] (II) VESA(0): initializing int10
[ 1498.552] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[ 1498.552] (II) VESA(0): VESA BIOS detected
[ 1498.552] (II) VESA(0): VESA VBE Version 3.0
[ 1498.552] (II) VESA(0): VESA VBE Total Mem: 16384 kB
[ 1498.552] (II) VESA(0): VESA VBE OEM: ATI ATOMBIOS
[ 1498.552] (II) VESA(0): VESA VBE OEM Software Rev: 10.94
[ 1498.552] (II) VESA(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
[ 1498.552] (II) VESA(0): VESA VBE OEM Product: RS880M
[ 1498.552] (II) VESA(0): VESA VBE OEM Product Rev: 01.00
[ 1498.555] (II) VESA(0): virtual address = 0x7fb736ea3000,
physical address = 0xe0000000, size = 16777216
[ 1498.564] (II) VESA(0): Setting up VESA Mode 0x156 (1152x864)
[ 1498.722] (==) VESA(0): Default visual is TrueColor
[ 1498.722] (==) VESA(0): Backing store disabled
[ 1498.722] (==) VESA(0): DPMS enabled
[ 1498.722] (==) RandR enabled
[ 1498.722] (II) Initializing built-in extension Generic Event Extension
[ 1498.722] (II) Initializing built-in extension SHAPE
[ 1498.722] (II) Initializing built-in extension MIT-SHM
[ 1498.722] (II) Initializing built-in extension XInputExtension
[ 1498.722] (II) Initializing built-in extension XTEST
[ 1498.722] (II) Initializing built-in extension BIG-REQUESTS
[ 1498.722] (II) Initializing built-in extension SYNC
[ 1498.722] (II) Initializing built-in extension XKEYBOARD
[ 1498.722] (II) Initializing built-in extension XC-MISC
[ 1498.722] (II) Initializing built-in extension XINERAMA
[ 1498.722] (II) Initializing built-in extension XFIXES
[ 1498.722] (II) Initializing built-in extension RENDER
[ 1498.722] (II) Initializing built-in extension RANDR
[ 1498.722] (II) Initializing built-in extension COMPOSITE
[ 1498.722] (II) Initializing built-in extension DAMAGE
[ 1498.729] (EE) GLX error: Can not get required symbols.
[ 1498.951] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[ 1498.951] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 1498.951] (II) LoadModule: "evdev"
[ 1498.951] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 1498.952] (II) Module evdev: vendor="X.Org Foundation"
[ 1498.952] compiled for 1.9.3, module version = 2.6.0
[ 1498.952] Module class: X.Org XInput Driver
[ 1498.952] ABI class: X.Org XInput driver, version 11.0
[ 1498.952] (**) Power Button: always reports core events
[ 1498.952] (**) Power Button: Device: "/dev/input/event2"
[ 1498.957] (--) Power Button: Found keys
[ 1498.957] (II) Power Button: Configuring as keyboard
[ 1498.957] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[ 1498.957] (**) Option "xkb_rules" "evdev"
[ 1498.957] (**) Option "xkb_model" "evdev"
[ 1498.957] (**) Option "xkb_layout" "us"
[ 1498.984] (II) config/udev: Adding input device Video Bus (/dev/input/event6)
[ 1498.985] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[ 1498.985] (**) Video Bus: always reports core events
[ 1498.985] (**) Video Bus: Device: "/dev/input/event6"
[ 1498.988] (--) Video Bus: Found keys
[ 1498.988] (II) Video Bus: Configuring as keyboard
[ 1498.988] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
[ 1498.988] (**) Option "xkb_rules" "evdev"
[ 1498.988] (**) Option "xkb_model" "evdev"
[ 1498.988] (**) Option "xkb_layout" "us"
[ 1498.989] (II) config/udev: Adding input device Sony Vaio Keys (/dev/input/event7)
[ 1498.989] (**) Sony Vaio Keys: Applying InputClass "evdev keyboard catchall"
[ 1498.989] (**) Sony Vaio Keys: always reports core events
[ 1498.989] (**) Sony Vaio Keys: Device: "/dev/input/event7"
[ 1498.992] (--) Sony Vaio Keys: Found keys
[ 1498.992] (II) Sony Vaio Keys: Configuring as keyboard
[ 1498.992] (II) XINPUT: Adding extended input device "Sony Vaio Keys" (type: KEYBOARD)
[ 1498.992] (**) Option "xkb_rules" "evdev"
[ 1498.992] (**) Option "xkb_model" "evdev"
[ 1498.992] (**) Option "xkb_layout" "us"
[ 1498.992] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[ 1498.992] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 1498.993] (**) Power Button: always reports core events
[ 1498.993] (**) Power Button: Device: "/dev/input/event0"
[ 1499.005] (--) Power Button: Found keys
[ 1499.005] (II) Power Button: Configuring as keyboard
[ 1499.005] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[ 1499.005] (**) Option "xkb_rules" "evdev"
[ 1499.005] (**) Option "xkb_model" "evdev"
[ 1499.005] (**) Option "xkb_layout" "us"
[ 1499.005] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[ 1499.005] (II) No input driver/identifier specified (ignoring)
[ 1499.008] (II) config/udev: Adding input device USB Laser Wheel Mouse (/dev/input/event5)
[ 1499.008] (**) USB Laser Wheel Mouse: Applying InputClass "evdev pointer catchall"
[ 1499.008] (**) USB Laser Wheel Mouse: always reports core events
[ 1499.008] (**) USB Laser Wheel Mouse: Device: "/dev/input/event5"
[ 1499.013] (--) USB Laser Wheel Mouse: Found 9 mouse buttons
[ 1499.013] (--) USB Laser Wheel Mouse: Found scroll wheel(s)
[ 1499.013] (--) USB Laser Wheel Mouse: Found relative axes
[ 1499.013] (--) USB Laser Wheel Mouse: Found x and y relative axes
[ 1499.013] (--) USB Laser Wheel Mouse: Found absolute axes
[ 1499.013] (II) USB Laser Wheel Mouse: Configuring as mouse
[ 1499.013] (II) USB Laser Wheel Mouse: Adding scrollwheel support
[ 1499.013] (**) USB Laser Wheel Mouse: YAxisMapping: buttons 4 and 5
[ 1499.013] (**) USB Laser Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 1499.013] (II) XINPUT: Adding extended input device "USB Laser Wheel Mouse" (type: MOUSE)
[ 1499.013] (**) USB Laser Wheel Mouse: (accel) keeping acceleration scheme 1
[ 1499.013] (**) USB Laser Wheel Mouse: (accel) acceleration profile 0
[ 1499.013] (**) USB Laser Wheel Mouse: (accel) acceleration factor: 2.000
[ 1499.013] (**) USB Laser Wheel Mouse: (accel) acceleration threshold: 4
[ 1499.013] (II) USB Laser Wheel Mouse: initialized for relative axes.
[ 1499.013] (WW) USB Laser Wheel Mouse: ignoring absolute axes.
[ 1499.013] (II) config/udev: Adding input device USB Laser Wheel Mouse (/dev/input/mouse1)
[ 1499.013] (II) No input driver/identifier specified (ignoring)
[ 1499.014] (II) config/udev: Adding input device Sony Visual Communication Camer (/dev/input/event10)
[ 1499.014] (**) Sony Visual Communication Camer: Applying InputClass "evdev keyboard catchall"
[ 1499.014] (**) Sony Visual Communication Camer: always reports core events
[ 1499.014] (**) Sony Visual Communication Camer: Device: "/dev/input/event10"
[ 1499.021] (--) Sony Visual Communication Camer: Found keys
[ 1499.021] (II) Sony Visual Communication Camer: Configuring as keyboard
[ 1499.021] (II) XINPUT: Adding extended input device "Sony Visual Communication Camer" (type: KEYBOARD)
[ 1499.021] (**) Option "xkb_rules" "evdev"
[ 1499.021] (**) Option "xkb_model" "evdev"
[ 1499.021] (**) Option "xkb_layout" "us"
[ 1499.022] (II) config/udev: Adding input device HDA ATI SB Mic (/dev/input/event11)
[ 1499.022] (II) No input driver/identifier specified (ignoring)
[ 1499.022] (II) config/udev: Adding input device HDA ATI SB Headphone (/dev/input/event12)
[ 1499.022] (II) No input driver/identifier specified (ignoring)
[ 1499.024] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event3)
[ 1499.024] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 1499.024] (**) AT Translated Set 2 keyboard: always reports core events
[ 1499.024] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event3"
[ 1499.029] (--) AT Translated Set 2 keyboard: Found keys
[ 1499.029] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[ 1499.029] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[ 1499.029] (**) Option "xkb_rules" "evdev"
[ 1499.029] (**) Option "xkb_model" "evdev"
[ 1499.029] (**) Option "xkb_layout" "us"
[ 1499.029] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event4)
[ 1499.029] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[ 1499.029] (**) PS/2 Generic Mouse: always reports core events
[ 1499.029] (**) PS/2 Generic Mouse: Device: "/dev/input/event4"
[ 1499.034] (--) PS/2 Generic Mouse: Found 3 mouse buttons
[ 1499.034] (--) PS/2 Generic Mouse: Found relative axes
[ 1499.034] (--) PS/2 Generic Mouse: Found x and y relative axes
[ 1499.034] (II) PS/2 Generic Mouse: Configuring as mouse
[ 1499.034] (**) PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
[ 1499.034] (**) PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 1499.034] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE)
[ 1499.034] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
[ 1499.034] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
[ 1499.034] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
[ 1499.034] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
[ 1499.034] (II) PS/2 Generic Mouse: initialized for relative axes.
[ 1499.034] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse0)
[ 1499.034] (II) No input driver/identifier specified (ignoring)
[ 1499.034] (II) config/udev: Adding input device PC Speaker (/dev/input/event9)
[ 1499.034] (II) No input driver/identifier specified (ignoring)
[ 1499.041] (II) config/udev: Adding input device Sony Vaio Jogdial (/dev/input/event8)
[ 1499.041] (II) No input driver/identifier specified (ignoring)
[ 1499.042] (II) config/udev: Adding input device Sony Vaio Jogdial (/dev/input/mouse2)
[ 1499.042] (II) No input driver/identifier specified (ignoring)
_____________________________________________________________________________________

Matte88
Technological Hen
Posts: 399
Joined: Wed Dec 29, 2010 14:37
Location: @/etc/entropy/repositories.conf.d/entropy_sabayon-limbo

Re: S_Amd64_5.5Gnome on Sony VAIO CG ATI

Post by Matte88 » Tue Feb 15, 2011 15:28

Your ATI Radeon HD 4200 is fully supported by official ATI drivers for Linux: see here.
Image
When I became the sun,
I shone life into the man's hearts.

Post Reply