Problems with Chromium-bin 64bit and GLIBCXX_3.4.14

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
ispettorezenigata
Old Dear Hen
Posts: 561
Joined: Thu May 03, 2007 11:47
Location: Cremona
Contact:

Problems with Chromium-bin 64bit and GLIBCXX_3.4.14

Post by ispettorezenigata » Wed Feb 09, 2011 10:49

- Version Sabayon: Sabayon_Linux_DAILY_amd64_Gnome 06-Feb-2011 13:20
- Kernel: Linux 2.6.37-sabayon (x86_64)
- C Library: GNU C Library version 2.11.2 (stable)
- Default C Compiler: GNU C Compiler version 4.4.4 ( 4.4.4-r2 p1.3, pie-0.4.5)

After install www-client/chromium-bin-8.0.552.224 (amd64),[In Entropy Repo) it won't start but
complains:

Code: Select all

/opt/chromium.org/chrome: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /opt/chromium.org/chrome)
Reproducible: Always

Steps to Reproduce:
1. Sabayon_Linux_DAILY_amd64_Gnome
2. Install www-client/chromium-bin-8.0.552.224
3. Run chromium-bin

Here's my output for gcc-config:

Code: Select all

$ gcc-config -l
 [1] x86_64-pc-linux-gnu-4.4.4 *
Similar Bug in gentoo bug:
http://bugs.gentoo.org/show_bug.cgi?id=348777
http://bugs.gentoo.org/show_bug.cgi?id=348824

joost
Sagely Hen
Posts: 2805
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: Problems with Chromium-bin 64bit and GLIBCXX_3.4.14

Post by joost » Wed Feb 09, 2011 10:54

Why are you using the -bin version?

I see that the -bin version in Entropy is outdated, I will update it.
I also wonder what the use is off having the -bin version in Entropy.
My blog | Mastodon | Please support Sabayon: Become a Patron

ispettorezenigata
Old Dear Hen
Posts: 561
Joined: Thu May 03, 2007 11:47
Location: Cremona
Contact:

Re: Problems with Chromium-bin 64bit and GLIBCXX_3.4.14

Post by ispettorezenigata » Wed Feb 09, 2011 11:08

www-client/chromium-9.0.597.84 work. :D

Regarding the problem with the version www-client/chromium-bin-8.0.552.224
i solved with this step:
- emerged sys-devel/gcc-4.5.2.
- gcc-config x86_64-pc-linux-gnu-4.5.2
- source /etc/profile

Thanks joost. SOLVED!
I see that the -bin version in Entropy is outdated, I will update it.
I also wonder what the use is off having the -bin version in Entropy.
Yes, the version in Portage is:

Code: Select all

chromium-bin-9.0.597.84
but reflected the same error.
The only solution is to update gcc to make it work

Post Reply