Page 1 of 1

bind9 and ldap

PostPosted: Thu Nov 23, 2006 15:07
by sabayonuser2

I installed SabayonLinux 3.1 from the full DVD on my server.
Then I configured everything I need.

works fine!!!

I installed openldap, now I want to configure bind to use ldap as backend... worked on my system before (suse)....
When I start bind (/etc/init.d/named start) there is an error post (/var/log/messages): unknown database type: ldap.

Well.. recompile with the right Useflags.... USE="ldap" emerge bind .....

When I start bind..... same error.....

then I read about that bind does not support ldap an about bind-sdb (
so I tried this... but now when I try to compile bind from source there are also errors with the ldap libraries..... (whicht have to be manually written in the

Is there any easier or working way to get bind run with ldap as backend??


PostPosted: Thu Nov 23, 2006 16:57
by lxnay
This might help you:

PostPosted: Thu Nov 23, 2006 18:51
by sabayonuser2

but this is not my main problem... to get ja bind running is easy... only how to access ldap as backend is my problem...... :(