Question with Azureus

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Postby lxnay » Sun Nov 26, 2006 18:42

Just run env-update && source /etc/profile before IIRC
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby hwertz » Tue Nov 28, 2006 4:32

I had this same problem, azureus not starting with a gjl error. I'm running stock gentoo, not sabayon, but *shrug*.. this is the ONLY thread with this problem google could find. I got the same error from gjl just with different line numbers... it seemed pretty cryptic but I think the dep stuff in the error means a missing dependency is the REAL problem... I used "java-config -l" which lists all your java packages, and where the ".env" file describing it is. For azureus this is /usr/share/azureus/package.env, which had this line:
DEPEND="[email protected]:[email protected]:[email protected]:[email protected]"

I ran "emerge --oneshot log4j commons-cli swt bcprov"
While these reinstalled, emerge also installed junit which I did not have installed. I would guess this was the REAL problem.

If any other java apps you had broken are still broken (didn't just need junit..) I suspect running a similar procedure of reinstalling stuff from package.env DEPENDS line would work. I wonder if there is a working revdep-rebuild or python-updater equivalent for java stuff?

Cheers!
hwertz
Baby Hen
 
Posts: 1
Joined: Tue Nov 28, 2006 4:19

Previous

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest