Page 1 of 1

Printer driver Error..

Posted: Thu Nov 09, 2006 18:49
by scimmia pazza
Hi..
The problem is that when I try to install a new printer..it fails.
I've a Lexmark x75..I do evrythink..I select the right driver..but at the end the error is:
Non è possibile caricare il driver richiesto:
Impossibile creare il driver Foomatic [Lexmark-X75,lxx74]. Il driver non esiste oppure non hai i permessi necessari per eseguire questa operazione.
..that in english (in my english XD):
Impossible load the selected driver:
Impossible create the Foomatic driver [Lexmark-X75,lxx74]. The driver doesn't exist or you aren't allowed to do this
..I have this problem too if I run as Root..

Someone have this problem too??

(Sorry for the bad English..)

Posted: Fri Nov 10, 2006 4:21
by cvill64
try reinstalling the foomatic drivers using emerge or try (if you upgraded to kde 3.5.5)

# layman -s sabayon
# emerge =kdelibs-3.5.5-r6

Posted: Sun Nov 12, 2006 10:27
by scimmia pazza
No..If I reinstall footmatic the problem already exist..

Emh..how can I update kde? :oops:

Posted: Sun Nov 12, 2006 23:05
by cvill64
# emerge --sync && layman -s sabayon
# emerge kde-meta
# emerge kicker kde-libs

then you need to run etc-update, which is the probably the most difficult part, look in /etc/make.conf, and delete all cfg files that want to overwrite files in /usr/kde/3.5/share/config/kdm and /etc and you should be good

Posted: Fri Nov 17, 2006 15:15
by scimmia pazza
cvill64 wrote:try reinstalling the foomatic drivers using emerge or try (if you upgraded to kde 3.5.5)

# layman -s sabayon
# emerge =kdelibs-3.5.5-r6
..Nothing..
kdelibs-3.5.5-r6 don't exist..I emerger kdelibs..is the some right? :?:

Posted: Fri Nov 17, 2006 16:55
by cvill64
there is an -r7 kicker in our overlay now with more fixes, you need to make sure that

# layman -s sabayon

completes successfully, if you get a svn error

# USE="-java -apache2" emerge subversion