Page 1 of 1

mounting NTFS in a Live Session

Posted: Sat Oct 28, 2006 16:24
by SNyD
Hey there!

I'm (very) new to sabayon and like it very much! After searching in Forum and HowTo's i found not really answers. I need the Power of Sabayon especially in Live Mode to use it on "inconstant" places but i found no way to get access to NTFS Partitions. On Installed System it works but not in Live. In Debian Sid (via Kanotix) where i'm coming from,this worked out of the box to me. However,i want to learn and only use Sabayon anymore! :wink:

Thanks for any help

Posted: Sat Oct 28, 2006 19:09
by cvill64
until 3.2 comes out, you can do this

# layman -s sabayon && emerge ntfs-policy && /etc/init.d/hald restart

and then you can mount using kde and pmount, this is fixed upstream in 3.2

Posted: Sat Oct 28, 2006 22:17
by SNyD
Thnx for fast reply!
When in LiveMode i type as root "# layman -s sabayon" i get this:

Code: Select all

[email protected] ~ $ su
Password:
sabayonx86 sabayonuser # layman -s sabayon
* Failed to sync overlay "sabayon".
* Error was: No such overlay ("sabayon")!

What does it mean,what can i do to solve this?
I properly should wait until 3.2 where it is fixed and i'm gonna be (restless) happy. :roll:

Posted: Sun Oct 29, 2006 0:29
by cvill64
are you connected to the internet?

what if you do an

# layman -f -a sabayon

?

Posted: Sun Oct 29, 2006 7:28
by Goatee
Run gparted.
Then when it's done scanning drives close it and goto storage media!

TADA!!!

Posted: Sun Oct 29, 2006 13:31
by SNyD
Both methods work as far as now i can mount the NTFS Partitions but a PopUp Window says: "Could not enter folder /media/xxx.." I only want to read NTFS,not write on it.

I'm connected to the net and
when i run "layman -f -a sabayon" i get:

Code: Select all

sabayonx86 sabayonuser # emerge ntfs-policy
--- 'profiles/arch.list' is empty or not available. Empty portage tree?
--- 'profiles/arch.list' is empty or not available. Empty portage tree?
!!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
!!! Is the symlink correct? Is your portage tree complete?

sabayonx86 sabayonuser #    
It seems that i'm unable to "emerge --sync" in live mode..

(sorry about my stupid questions,but this are my early steps in gentoo world)

Posted: Sun Oct 29, 2006 17:46
by cvill64
yes, that might be a little bit annoying, if you have eth access, you can emerge --sync in live mode

sorry for the troubles, its fixed upstream I swear! 8)

Posted: Sun Oct 29, 2006 18:29
by SNyD
So let's see... :cyclopsani:

I'm longing for 3.2...