Failed trying to load font helvetica-bold-r-normal [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Failed trying to load font helvetica-bold-r-normal [Solved]

Postby Haber_Nir » Thu Jan 22, 2009 11:16

anyone know whice package do i need to install?

i know that in fedora i need to install this packages :

xorg-x11-fonts-75dpi-7.2-3.fc8
xorg-x11-fonts-ISO8859-1-75dpi-7.2-3.fc8

anyone know which package is it in sabayon?
Haber_Nir
Simple Hen
 
Posts: 47
Joined: Mon Dec 25, 2006 14:49

Re: Error: Failed trying to load font helvetica-bold-r-normal ?

Postby micia » Thu Jan 22, 2009 12:38

Try from equo (or spritz) liberation-fonts.
You could open a console as root and type:
Code: Select all
equo install liberation-fonts


After installing type, as root:
Code: Select all
eselect fontconfig enable 60-liberation.conf
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Error: Failed trying to load font helvetica-bold-r-normal ?

Postby Haber_Nir » Thu Jan 22, 2009 13:18

micia wrote:Try from equo (or spritz) liberation-fonts.
You could open a console as root and type:
Code: Select all
equo install liberation-fonts


After installing type, as root:
Code: Select all
eselect fontconfig enable 60-liberation.conf

thanks alot i try that but it didnt work
the full message that the program maya (autodesk maya 2008) write me is

"Error: Failed trying to load font : -*-helvetica-bold-r-normal--11-*-*-*-*-*-iso8859-1 // "
Haber_Nir
Simple Hen
 
Posts: 47
Joined: Mon Dec 25, 2006 14:49

Re: Error: Failed trying to load font helvetica-bold-r-normal ?

Postby micia » Thu Jan 22, 2009 13:39

I forgot to specify to restart the X Server, if you did that too then
probably you need to install:
font-adobe-75dpi and font-adobe-100dpi, unfortunately these
are not open source....

As above, in a console as root:
Code: Select all
equo install font-adobe-75dpi font-adobe-100dpi

and restart X.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Error: Failed trying to load font helvetica-bold-r-normal ?

Postby Haber_Nir » Thu Jan 22, 2009 14:05

thanks but it still write the same thing :(
Haber_Nir
Simple Hen
 
Posts: 47
Joined: Mon Dec 25, 2006 14:49

Re: Error: Failed trying to load font helvetica-bold-r-normal ?

Postby micia » Thu Jan 22, 2009 16:28

I think I found a valid solution (once in a while :D ), the fonts are installed into the /usr/share/fonts directory,
but the X Server has no clue that they are there; basically it does not know he has that font...

Try to give these commands in a root console (I assume you still have the adobe fonts installed):

Code: Select all
xset +fp /usr/share/fonts/100dpi/
xset +fp /usr/share/fonts/75dpi/
xset fp rehash

These commands should tell to the X Server that you got fonts
in those directories (the first two commands) and the third one will
tell him to read again fonts.
Hope this one helps...
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Error: Failed trying to load font helvetica-bold-r-normal ?

Postby Haber_Nir » Fri Jan 23, 2009 0:23

works perfect.
thanks alot micia
Haber_Nir
Simple Hen
 
Posts: 47
Joined: Mon Dec 25, 2006 14:49


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron