Page 1 of 1

New 3.5 x64 installation on 30" display. . .

Posted: Sat Jul 19, 2008 13:26
by 2ny
I have rewarded myself a new monitor for my ageing eyes - it has a native resolution of 2560x1600 but no matter what I put in the x-config file, I have not been able to wring it out of 1280x800 - which was the resolution the system chose for itself without ever asking me. It is not a major problem, everything is clearly visible and the font display isn't half bad either, but I do not ever want to read the screen from outside of this room. I would much prefer having more sensible use of the desktop area instead. I have tried inserting a new Display Section in /etc/X11/xorg.conf. Just now, I tried changing the GPU Scaling option in the nVidia X Server Settings applet too, but there is no reaction what-so-ever to the resolution.

I would be really glad if some-one can think of something to try - no other distro that I have played with, or indeed Windows, is behaving like this.

One more thing - over the last couple of years (since the introduction of AIGLX!) I've had endless trouble with Beryl and Compiz. It usually worked for the most part, but there was allways one or two issues that ruined the whole experience. This time, when I enable Compiz the window titlebars disappear, but I fixed that by enabling Indirect Rendering in Compiz Options. The Compiz Fusion Icon is of course a front end - anybody know what command to put where, Indirect Rendering configured as text - I have a laptop (HP zv5000) that I need to experiment on as well.

Many thanks in advance. . .

Re: New 3.5 x64 installation on 30" display. . .

Posted: Sat Jul 19, 2008 13:33
by rand.a
Paste relevant configs.... like say... xorg.conf

Re: New 3.5 x64 installation on 30" display. . .

Posted: Sat Jul 19, 2008 13:45
by 2ny
Yes - sure!

Section "Module"
SubSection "extmod"
Option "omit xfree86-dga"
Load "i2c"
Load "ddc"
Load "synaptics"
Load "vbe"
# Load "dri"

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"

Section "InputDevice"
Identifier "Synaptics1"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
# For ALPS/MacBook TouchPads
#Option "MaxSpeed" "0.7"
#Option "MinSpeed" "0.18"
#Option "AccelFactor" "0.08"
#Option "TopEdge" "120"
#Option "LeftEdge" "120"
#Option "BottomEdge" "830"
#Option "RightEdge" "650"
#Option "FingerLow" "25"
#Option "FingerHigh" "30"
# MacBook touchpad
#Option "MaxTapTime" "180"
#Option "MaxTapMove" "220"
#Option "MaxDoubleTapTime" "180"
#Option "VertScrollDelta" "20"
#Option "HorizScrollDelta" "50"
#Option "TapButton2" "3"
#Option "TapButton3" "2"
#Option "VertTwoFingerScroll" "1"

# Do you keep moving the mouse while typing? Try this trick.
#synclient TouchpadOff=1 disable your synaptics touchpad
#synclient TouchpadOff=0 enable your synaptics touchpad

# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/psaux"

# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"
Identifier "Generic Monitor"
VertRefresh 43 - 60
HorizSync 28 - 80

# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
Identifier "VESA"
Driver "nvidia"
#Option "RenderAccel" "on"
Option "XAANoOffscreenPixmaps"
#Option "BusType" "PCI"
#Option "ColorTiling" "on"
#Option "EnablePageFlip" "on"
Option "AccelMethod" "XAA"

# **********************************************************************
# Screen sections.
# **********************************************************************

Section "Screen"

# The Identifier, Device and Monitor lines must be present

Identifier "Screen 1"
Device "VESA"
Monitor "Generic Monitor"
Option "AddARGBGLXVisuals" "true"

# The favoured Depth and/or Bpp may be specified here

DefaultDepth 24

SubSection "Display"
Depth 8
ViewPort 0 0
#Modes "1024x768" "800x600" "640x480"

SubSection "Display"
Depth 16
ViewPort 0 0
#Modes "1024x768" "800x600" "640x480"

SubSection "Display"
Depth 24
ViewPort 0 0
#Modes "1024x768" "800x600" "640x480"


Section "ServerLayout"
# The Identifier line must be present

Identifier "Main Layout"
Screen 0 "Screen 1"
InputDevice "Mouse1" "CorePointer"
#InputDevice "Synaptics1" "SendCoreEvents"


Section "DRI"
Mode 0666

Section "Extensions"
Option "Composite" "Enable"



Re: New 3.5 x64 installation on 30" display. . .

Posted: Sat Jul 19, 2008 19:39
by rand.a
Anything in xorg.conf that has a # infront of it is completely ignored. Notice how your "Modes" lines that set the resolution begin with a #?

I find it interesting that you have no settings for a keyboard. No keyboard input device is defined anywhere in that.

Re: New 3.5 x64 installation on 30" display. . .

Posted: Sat Jul 19, 2008 23:33
by Darksurf
yeah, thats fairly similar to the ATI drivers. the proprietary drivers have their own way of controlling the screen resolution. They don't really
depend on xorg.conf . Being the worlds largest Linux/AMD/ATI fan, I know ati has the "aticonfig --initial -f" command to force the aticonfigurator
to make a new fglrx xorg.conf. Does nvidia have anything like that? If so, I'd suggest using it, and trying to use that Nvidia GUI tool to change
your resolution. If you still can't, I'd report this problem to Nvidia with the model of your monitor and your issues, it could be a driver issue.

BTW, xorg is finding new ways to use things such as the keyboard and mouse without it having to be in the xorg.conf .
Xorg is getting more and more modular, and is becoming less dependant on the xorg.conf file. Don't misunderstand me, it still requires
an xorg.conf file, it just is be less and less depended on for things like it used to be when xfree86 first started out.