unable to login

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
xlnagla
Sagely Hen
Posts: 1078
Joined: Mon May 28, 2007 2:44

unable to login

Post by xlnagla » Sat Feb 02, 2008 23:58

Hello all,

I just put a nice fresh 3.4f install on my computer and used exclusively equo to update equo to its most recent version, and then preformed an equo world. I didn't blow away any config files that I knew to avoid, but there were quite a few I didn't recognize in the process, and so it's quite possible I've destroyed something important there.

But, the main problem is that I cannot log in (at all) - X crashed after about 2 seconds of loading, and I am unsuccessful when trying to log in on one of the tty's. It prompts for login, and no matter what login I enter, it tells me "login incorrect" three times, and then maxes out. It does not prompt me for a password throughout all of this - the only input I'm giving is "username <carriagereturn>" or "root <carriagereturn>". Also, network manager fails at startup so no ssh. I basically have no idea how to get into my system at all. Any advice? And yes, I can get in in "maintenance-mode" as root so I can fix stuff, just don't really know where to start - nano, emacs, vim, and pico are all missing, so no easy way to update config files.

~xlnagla

rand.a
Growing Hen
Posts: 163
Joined: Fri Mar 23, 2007 20:08
Location: Shelton, WA
Contact:

Re: unable to login

Post by rand.a » Sun Feb 03, 2008 1:57

sounds like you didnt update some crucial configs. i'd suggest booting a livecd and chrooting in to finish the job.

xlnagla
Sagely Hen
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: unable to login

Post by xlnagla » Sun Feb 03, 2008 4:46

I replaced all the ones equo noticed - I've got another up-to-date computer, I'll use the liveDVD and compare the configs to see what's up. Thanks, I'll post back here if I have more troubles.

~xlnagla

rand.a
Growing Hen
Posts: 163
Joined: Fri Mar 23, 2007 20:08
Location: Shelton, WA
Contact:

Re: unable to login

Post by rand.a » Sun Feb 03, 2008 4:57

check the logs thoroughly when you chroot in, if you still cant find the problem

xlnagla
Sagely Hen
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: unable to login

Post by xlnagla » Thu Feb 07, 2008 4:52

It could be in a config within which I don't know to look, but I keep getting this little problem when I try to emerge anything:

checking whether the C compiler (gcc -Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s) works... no

which I figure is a bad thing. I'll try to get entropy to rebuild GCC, but I have to say I'm not tremendously hopeful. Is there something I've missed?

~xlnagla

Post Reply