Any tablet pc users out there?

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Any tablet pc users out there?

Postby razor1394 » Sat Jun 23, 2007 23:22

So, are there any tablet pc users out there?

I'm thinking of picking up am HP tx1020 tablet but I'm worried about how good it will work with Sabayon. Things like the fingerprint reader are not that important, but I'm worried about how good for ex the passive screen and wifi will work. A passive screen is not a very good choice when taking notes but Windows has an API that makes better results and cancels out invalid input like for ex your hand resting on the screen.

For wifi:

lspci wrote:Broadcom Corporation BCM4310 UART

On the Ubuntu forums it seems to work ok with bcm43xx but it isn't even listed on bcm43xx's device page.

According to the touchscreen works but it is way off in terms of calibration. How would I configure this? Xorg, kernel? I'm not entirely sure but I think it acts as a standard mouse HID device. This is where the big problem lies. Windows has very good calibration tools which makes using the touch screen much easier after some hours of writing.

Media keys and automatic screen rotation? Any patches needed?

I know about xstroke for converting handwriting to machine text and most journal/onenote like apps (have tried them).

I'm sorry, but I can't stand Windows even though It's what most people would say It's the best choice for a tablet. It comes with Vista and by experience I know It's a battery hog. Also I heard about HP denying repair or exchange if installing another OS... BS?

Thanks for any answers.
Growing Hen
Posts: 130
Joined: Sat Oct 28, 2006 19:32
Location: Sweden

Postby razor1394 » Sun Jun 24, 2007 22:25

Seems like wifi and touchscreen are no go. Wifi works like crap (keeps disconnecting all the time) with bcm43xx. The touch screen is very badly calibrated and it seems you either have to go the easy way with the vendor's driver or the hard way with a kernel driver. touchcfg says "bad eeprom" and the changing of the MinX, MaxX, MinY and MaxY doesn't seem to work. The screen seems to work fine in Vista though but I've removed that now and I don't plan on going back just yet.

System doesn't shut down properly either unless I use the the power button but that's now biggie. I'll se what I can do tomorrow. I hope someone can help out.

These are the links I've checked so far: ... ml#4116431 ... uchscreens
Growing Hen
Posts: 130
Joined: Sat Oct 28, 2006 19:32
Location: Sweden

Postby razor1394 » Wed Jun 27, 2007 17:32

Ok, some more progress. I found a guide at Ubuntu that indicates that everything except the fingerprint reader should work: ... stcount=16 .

The problem is evdev is compiled inside the kernel and I don't have any /etc/modprobe.conf.local file. Starting from a terminal crashes Xorg.

Some more pages I've been looking into:

I tried Ubuntu amd64 and I realize that it was a mistake. I never managed to compile the evtouch module.

I noticed that the screen behaves differently under 3.4 loop3 as it only seems to register presses not the movement of the pen tip (at least it's not visible). Also setting the clock under 3.3 final locks the whole computer.
Growing Hen
Posts: 130
Joined: Sat Oct 28, 2006 19:32
Location: Sweden

Postby totedati » Thu Jun 28, 2007 1:32

sabayon is a live sistem ... so ... you should pick it up with you to shop store and test here if is working ... if not ... bad luck .... and blame winblows monopoly for that ...
linux is free, the expertise to harness it is not!
you don't make so much money selling open source software!
You make MORE money USING it, just like google!
linux registered user #352479
Technological Hen
Posts: 417
Joined: Thu Jan 11, 2007 0:24
Location: Sibiu, Romania

Postby razor1394 » Thu Jun 28, 2007 14:26

Well the dvd drive was locked and I read on the Tabletpcreview site that some have got it working so I took a chance or what you call it.

SetClientVersion: 0 9

0: /usr/bin/X(xf86SigHandler+0x6d) [0x48d35d]
1: /lib/ [0x2b2282e5f8e0]
2: /usr/bin/X [0x4789c3]
3: /usr/bin/X(xf86PostButtonEvent+0x52) [0x4795f2]
4: /usr/lib64/xorg/modules/input// [0x2b2284d011c7]
5: /usr/lib64/xorg/modules/input// [0x2b2284d01218]
6: /usr/lib64/xorg/modules/input// [0x2b2284d015ff]
7: /usr/lib64/xorg/modules/input// [0x2b2284d00ed5]
8: /usr/lib64/xorg/modules/input// [0x2b2284d01810]
9: /usr/bin/X [0x55df88]
10: /usr/bin/X(WaitForSomething+0x633) [0x55e683]
11: /usr/bin/X(Dispatch+0x8b) [0x448c1b]
12: /usr/bin/X(main+0x45b) [0x431f9b]
13: /lib/ [0x2b2282e4d374]
14: /usr/bin/X(FontFileCompleteXLFD+0xa1) [0x431289]

Fatal server error:
Caught signal 11. Server aborting
Growing Hen
Posts: 130
Joined: Sat Oct 28, 2006 19:32
Location: Sweden

Postby WarraWarra » Thu Jun 28, 2007 23:10

Not sure but you would have to build a kernel from scratch as there is tablet pc options and touchscreen options in the kernel but not sure if it is active in current 3.4 versions.

Also I saw a touch screen option for the mouse in xorg.conf .

There is a text recogn. type program for linux have to google for it.

IE: everything you need to make it work is out there for linux but might have to build it yourself or use a redhat / ubuntu type linux as they might have it working already.
Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Postby razor1394 » Fri Jun 29, 2007 12:48

Yup, I know about those recognition apps. I think they are called onestroke and xstroke. Everything seems to work on Ubuntu i386 except the fingerprint reader. However sometimes the pointer slows down to a crawl and unlike Gentoo the event* filenames keep changing after every boot so I have to edit Xorg but I think this can be overcome by sleeping instead. Also something that puzzles me is that Portage does not contain any of the note taking apps available for GNU/Linux. On Ubuntu at least Gournal and Xournal is available.
Growing Hen
Posts: 130
Joined: Sat Oct 28, 2006 19:32
Location: Sweden

Postby alexandru » Thu Jul 12, 2007 8:44

I also have a tabletpc, but has a wacom digitizer. I used Sabayon and I remember it wasn't hard to make everything working. I now use ubuntu, but I'm checking everyday the "Planet" to see news from the 3.4 development.
I shall install Sabayon right after it is released and I'll post how I make my on-the-fly screen rotation and how to install xournal or gournal (...I had some trouble with gournal, but finally it worked on Sabayon).
I think Sabayon is a great distro for tablet PC. Other distros suited I think are Ubuntu (recognized my tablet and set it up directly - in Sabayon I had to do some manual staff in xorg.conf) and openSUSE (again, all automatically, at a single click from YaST)
Baby Hen
Posts: 2
Joined: Sun Jun 24, 2007 2:24

Even i Have one of the hp tablets tx1003au

Postby rajivenator » Mon Jul 30, 2007 18:40

Till now no success with SLed 10 sp1,
Fedora works but no sound or touchscreen

lets hope sabayon has some tricks up its sleeve..
I even tries OSX-86 its works on ma pc but tablet no go hdd not osx86 hope future releases get this thing done...

Why not we start a separate Thread for tx1000 owners to share their grievances...
Baby Hen
Posts: 2
Joined: Mon Jul 30, 2007 18:19

Postby edgevision » Mon Jul 30, 2007 19:43

Good thing I checked this out; was hoping to buy a laptop in this series.
Maybe go for one of the dv's instead of tx.
Will monitor this to see how it goes..
Growing Hen
Posts: 180
Joined: Tue Jun 26, 2007 18:40
Location: New Brunswick, Canada


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest