HP multifunction ENVY 4500 scanning troubles

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
alexo
Baby Hen
Posts: 16
Joined: Thu Apr 11, 2019 16:24

HP multifunction ENVY 4500 scanning troubles

Post by alexo » Sun Sep 20, 2020 12:08

Hello sabayoners,

this week it happened a strange thing after upgrading my laptop:
xsane and scanimage don't find the Scanner.

I have an HP ENVY 4500 set by HPLIP (version 3.20.6) that correctly detects
the printer and prints regularly.

When I launch xsane (version 0.999) a popup appears showing the following message:

- no device available

and if I launch the scanning process from inside the HPLIP HP Device Manager i get:

- cannot open device

The text message here reported where translated back to English from the Italian ones,
so the exact words could be slightly different.

I tried to start the laptop with an older kernel (4.4.0 instead of the last one), but
the same thing happens.


On my machine are coexisting 3 Linux bistros:

- Debian 10 Stable
- Linux Mint 19
- Sabayon (regularly updated)

all three with the MATE desktop environment.

Before updating the scanner was recognized but when the scanning was completed there was not
the document digitized but a message reporting an error relative to the scanner (I don't
remember the exact words, sorry)

Since I have a similar problem in Linux Mint but not in Debian stable, I presume it could be
some regression somewhere, and I'm asking you if some of you encountered similar troubles.

Thank you

Post Reply