Xorg error and classic black screen with Nvidia.

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
User avatar
Baby Hen
Posts: 1
Joined: Mon Mar 30, 2020 3:31

Xorg error and classic black screen with Nvidia.

Post by judd » Mon Mar 30, 2020 5:45

Hello, installed Sabayon iso Mate downloaded by torrent.
It boots from Grub and then black screen with promp flickering, then I go to tty2 login and see that Xorg doesn't start with startx doesn't work, xinit doesn't either.

Another attempt was to write to the kernel line, next to quiet splash pci=noaer and pcie_aspm=off which worked for me on Arch Linux.

I pass to test failsafe-mode and the same as before.

In tty2 I was able to do systemctl --failed and it throws me lightdm failed.
So are you complaining about my Nvidia graphics card ?

Code: Select all

Machine:   Type: Desktop Mobo: Gigabyte model: B365M DS3H v: x.x serial: <root required> UEFI [Legacy]: American Megatrends 
           v: F5 date: 08/13/2019 
Memory:    RAM: total: 15.58 GiB used: 1.01 GiB (6.5%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: 6-Core model: Intel Core i5-9400 bits: 64 type: MCP L2 cache: 9216 KiB 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
Graphics:  Device-1: NVIDIA TU117 [GeForce GTX 1650] driver: nvidia v: 440.64 
           Display: server: X.Org 1.20.7 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 440.64
Quick photo after Grub and then the black screen ... (difficult to capture, happens very quickly :)

From what I could see in live-iso before installing I really liked it and I hope I can use it, it looks nice and elegant graphics, it shows that they have worked a lot and very grateful for me!

My respects.

Post Reply